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FuncTions AND
COMMANDS

This section of Quick Reference provides an alphabetical listing of important
WordStar topics. Under the topics you will find a list of classic and pull-down
commands and brief explanations of their functions. The commands are used
at the Edit Menu unless “Opening Menu” appears beside the classic command.
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ALIGN ONE LINE OF TEXT AT RIGHT MARGIN

Classic Pull-down
QO] Layout=Right Align Line

Use this command to align one line of text at the right margin instead of the left

margin.
ALIGNMENT OF TEXT
Classic Pull-down
~OS Layout=>Alignment and Spacing

You can select how to align text: Flush Left, Centered, Flush Right, or Justified
(both margins aligned). You can also set alignment in paragraph styles. Line
spacing is another option in the Alignment and Spacing dialog box. For more
information on line spacing, see “Line Spacing.”
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AscIr

Classic Pull-down

N (Opening Menu) File=>Open Nondocument
AKW Edit=>Copy=>To Another File=>Copy in ASCII Format

ASCII (American Standard Code for Information Interchange) is a standard file
format. To create an ASCII file, open a nondocument file. To convert a docu-
ment to ASCII format, print the file to disk using the ASCII PDF. You can also
copy a block of text as an ASCII file. Mark a block and then press ~KW (Copy
to Another File). Select the option to Copy in ASCII Format in the dialog box.

AUTO ALIGN

Classic Pull-down
AOA Edit=Editing Settings=>Auto Align

When you edit text, you change the length of the lines. The auto align feature
aligns the text to fit within the margins. This command turns auto align on and
off. When aligning a whole document, you can mark certain sections of text,
such as charts, that you do not want to align. Place the cursor on the line
above the section and type the dot command .aw off. Type .aw on on the line
above the line where you want aligning to resume.

BACKUP FILES

Each time you save a file, WordStar saves the previous version of the file as a
backup and gives the backup filename the .BAK extension. To edit a .BAK file,
you must first rename it with a different extension. In WSCHANGE, you can set

WordStar to make backup files every few minutes, or you can turn backup files
off.

BIDIRECTIONAL PRINTING

Classic
.bp on/off

Some printers print from right to left, then from left to right on alternate lines.
On some printers, you can turn bidirectional printing off to improve print
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quality, or on to speed up printing. The .bp on and .bp off dot commands turn
bidirectional printing on or off. The default setting for bidirectional print is on.
Some printers will revert to left-to-right printing on the first few lines of a page.
Some printers may not print bidirectionally with a page offset of .8 inch. Try set-
ting the page offset to 1 inch if you want bidirectional print.

BINDING SPACE
Classic Pull-down
APO Layout=>Special Effects=>Keep Words Together on Line

To make sure that adjacent words print on the same line instead of different
lines, put the command between the words instead of pressing the Spacebar.

BIANK LINES

Classic
AN

You can use either AN or Enter to insert a blank line (space between two lines
of text). When you press AN, a blank line is inserted and the cursor remains at
its original position. If insert mode is on and you press Enter, a blank line is
inserted and the cursor moves to the next line.

BLOCK COMMANDS

A block is a marked portion of a document on which you can perform certain
tasks. All the commands for working with blocks of text are listed below.

Classic Pull-down

AKB Edit=>Mark Block Beginning
AKK Edit=>Mark Block End

AKH View=>Block Highlighting
AKC Edit=>Copy=>Block

AKV Edit=>Move=>Block

AKY Edit=>Delete=>Block

AKW Edit=>Copy=>To Another File
AKR Insert=>File
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Classic Pull-down
AKN Edit=>Editing Settings=>Column Block Mode
AKI Edit=>Editing Settings=>Column Replace Mode
AKA Edit=>Copy=>Block from Other Window
AKG Edit=>Move=>Block from Other Window
AKM Utilities=>Block Math
AKZ Utilities=>Sort Block
AK’ Style=>Convert Case=>Lowercase
AK! Style=>Convert Case=>Uppercase
AK. Style=>Convert Case=>Sentence Case
AK? Utilities=Word Count
AK] Edit=>Copy=>From Windows Clipboard
AK] Edit=>Copy=>To Windows Clipboard
AKU Edit=>Mark Previous Block
AK< (Unmarks
a block)

Brock mata
Classic Pull-down
AKM Utilities=>Block Math
AM= Insert=>Other Value=>Last Math Result
AM$ Insert=>Other Value=>Last Math as Dollar

Mark the mathematical expression as a block and press AKM (Block Math) to
calculate the answer. To insert the most recent answer at the cursor position,
press AM= (Last Math) or AM$ (Last Math as Dollar) for dollar amounts.

BoLp

Classic Pull-down
APB Style=>Bold

To make text bold, place the cursor where you want the bold to start and use
APB (Bold). To mark the end of bold, place the cursor one space after the last
character you want bold and repeat the command. Bold is printed as a 13 per-
cent offset if you have a page printer and there is no bold font. If you want less
of an offset, you can use double strike which prints at 7 percent offset.
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CALCULATOR
Classic Pull-down
AQM Utilities=>Calculator
AM= Insert=>Other Value=>Last Math Result
M$ Insert=>Other Value=Last Math, as Dollar
AM# Insert=>Other Value=>Last Math Expression

To use the onscreen calculator during editing, use the calculator command,
type a mathematical expression, and press Enter. Press AM= (Last Math) or
AMS$ (Last Math, as Dollar) to insert the answer into your document at the cur-
sor position. To insert the last mathematical expression in your text, press AM#
(Last Math Expression).

CARRIAGE RETURN

Carriage returns are either hard or soft. You enter a hard return by pressing the
Enter key. WordStar adds a soft return when it wraps text to the next line.

CASE CONVERSION

Classic Pull-down

AK Style=>Convert Case=>Lowercase
AR Style=>Convert Case=>Uppercase
AK. Style=Convert Case=>Sentence Case

To change the case of characters, mark a block containing the text you want to
change and press the command for the case conversion you want. (Do not

rou

hold down the Ctrl key when you press the ’, “, or . character.)

CENTERING TEXT

Classic Pull-down
~NOC Layout=>Center Line
.0jc Layout=Alignment and Spacing=>Centered

AOC (Center Line) centers one line of text. To center a group of lines, select
Centered in the Alignment and Spacing dialog box or type the dot command
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directly. Another way to center text is with paragraph styles. Define a style and
then press Alt+N to select Centered. For information on centering text verti-
cally, see “Vertically Center Text.”

CLASSIC COMMANDS

Classic Pull-down
AOB View=>Screen Settings=>Classic Commands on Pull-down
Menus

Classic commands appear on the menus at all help levels. Some people prefer
to work at help level 4 (pull-down menus) without seeing classic commands. If
you don’t want the classic commands to appear on the pull-down menus, use
AQOB (Classic Commands on Pull-down Menus) and turn them off.

CLEARING THE SCREEN

Classic
A\

This command (sometimes called a screen refresh) removes extra characters
which are sometimes caused by electrical interference or a message from the
operating system. These characters are not actually in the file.

CLIPBOARD
Classic Pull-down
AK Edit=>Copy=>To Windows Clipboard
AK T Edit=Copy=>From Windows Clipboard

Before you copy text to the Clipboard, mark the text as a block. You can also
copy ASCII text from the Clipboard to WordStar. The Clipboard feature works
only if you have Windows running in 386 enhanced mode.
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COLORS AND SHADING

Classic Pull-down
AP— Style=>Other=>Color/Shading

To print text in a different color or shading, give the command where you want
the color to begin. The colors or shadings you can use are those that are avail-
able on your printer. Select a color or shading from the colors list. Text follow-
ing the command is printed in the selected color or shading until you change
the color again.

COLUMN BLOCKS
Classic Pull-down
AKN Edit=>Editing Settings=Column Block Mode
AKI Edit=>Editing Settings=Column Replace Mode

You can work with columns of text easily by switching from a horizontal
arrangement of text to a vertical arrangement. Put the beginning and ending
block markers at the top-left and bottom-right corners of the block. Turn on
Column Block Mode and then Column Replace Mode to replace text at the cur-
sor with a moved, copied, or inserted block. Also, if you delete a block with
Column Replace Mode on, text doesn’t move to fill in the space.

COLUMN TABS

Classic Pull-down
AOI Layout=>Ruler Line=>Tab Stops

Set a tab where each column of text is to begin. Use Al or the Tab key to move
the cursor to the beginning of each column and type the text for that line.
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COLUMNS, NEWSPAPER-STYLE

Classic Pull-down
AQU Layout=>Columns
.cb Insert=>Column Break

To set up newspaper-style columns, press AOU, and specify the number of
columns (from 1- 8). You can also determine the space between columns. If
necessary, specify the right margin for the page (not the column width).
WordStar calculates the width of each column.

C OMMAND FILES
Classic Pull-down
fi Insert=>File at Print Time

A command file contains dot commands only and no text. For example, a com-
mand file can contain .fi commands to insert several files. Command files are
useful for chaining and nesting files.

COMMENTS
Classic Pull-down
AONC Insert=>Note=>Comment

Use this command to insert unprinted comments and instructions into a file.
When display of command tags is on, the first few words of the comment
appear in a tag onscreen. When display is off, the tag does not appear. You
can view the entire comment by moving the cursor to the command tag and
pressing NOND (Edit Note). Use the dot command .ig or .. (two periods) to
create a one-line comment that is entirely displayed.
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CONVERTING DOCUMENTS

Use Star Exchange™ to convert documents created on one type of word proces-
sor to documents that are compatible with another type of word processor. You
can also convert spreadsheets and databases. For more information on the
applications that you can convert, see “Star Exchange” in the Companion
Programs manual.

COPYING A FILE

Classic Pull-down
O (Opening Menu) File=>Copy
AKO File=Copy

Copying a file makes an exact duplicate of the file that is copied; the original is
preserved, not erased.

COPYING TEXT

Classic Pull-down

AKC Edit=-Copy=>Block

AKA Edit=>Copy=Block From Other Window
AKW Edit=Copy=>To Another File

AK ] Edit=>Copy=>To Windows Clipboard

AK [ Edit=Copy=From Windows Clipboard

Copying text makes an exact duplicate of whatever is copied; the original is
preserved, not erased. For information on copying text to and from the Clip-
board, see “Clipboard.”

CURSOR

The cursor is a small blinking rectangle or line on the screen that marks your
place. To change the shape of the cursor, use WSCHANGE.
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CURSOR DIAMOND

WordStar commands that move the cursor up one line, left one character, right
one character, and down one line form a diamond on the keyboard.

Up one line AE
Down one line AX
Left one character NS
Right one character AD
Left one word AN
Right one word AF
Scroll up one line AW
Scroll down one line NZ
Scroll up one screen AR
Scroll down one screen ~C

10
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CURSOR MOVEMENT AND SCROLLING

You can use the direction keys and the cursor movement control commands to
move the cursor and to scroll through text. The direction keys and cursor move-
ment control commands move the cursor across text. Scrolling allows you to
move another portion of text onto the screen, either vertically or horizontally.

One line AE or Up Arrow

To column 1 in first onscreen line AQE or Home

One line (scroll up) AW or APgUp

Line by line to document beginning AQW (type 0-9 for speed)
To previous screen R or PgUp

Directly to document beginning AQR or "Home

Screen by screen to document beginning | AQQ*R (type 0-9 for speed)

One character AS or Left Arrow
One word AA or ALeft Arrow
To column 1 of current line ~QS

One character AD or Right Arrow

One word AF or ARight Arrow

To end of current line QD

11
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One line AX or Down Arrow
To last onscreen line AQX or End
One line (scroll down) AZ or APgDn

Line by line to document end

AQZ (type 0-9 for speed)

To next screen

AC or PgDn

Directly to document end

AQC or Ctrl+End

Screen by screen to document end

AQQAC (type 0-9 for speed)

Beginning of block QB
Character AQGx
Character (backward) AQHXx

End of block AQK

Font tag Q=

Last find/replace or block location QV
Marker ~QO0-9
Next page AQI+ (Plus key) Enter
Note NONG
Page or line (number) AQIn Enter
Paragraph end AQG Enter

Previous page

AQI- (Minus key) Enter
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Window AOK

Word or phrase AQF word/phrase

CUSTOM PRINTER CODE

Classic Pull-down

APF Insert=Custom Printer Code=>1

PG Insert=>Custom Printer Code=>2

APQ Insert=>Custom Printer Code=>3

APW Insert=>Custom Printer Code=>4

APE Insert=>Custom Printer Code=>5

APR Insert=>Custom Printer Code=>6

P! Insert=>Custom Printer Code=>Other...

Custom printer codes are special printing instructions that let you take
advantage of special features on your printer. Use these commands to insert
printer codes in your documents. APF prints the phantom character at a print
wheel’s hex code 20 (space) position. ~PG prints the character at hex code 7F
(rubout) position.

You can define a printer code by adding it to your PDF in PRCHANGE or by
typing a dot command directly in your document. The dot command is fol-
lowed by the hex code for the printer feature. Use .xq to define the printer
code sent by APQ, .xw for APW, .xe for APE, and .xr for APR. To define a
printer code you use only once, press AP! and type the ASCII code or type
% F'filename"to name the file containing the printer code.

CUSTOMIZING WORDSTAR

To customize WordStar, run the WordStar installation program WINSTALL,
then choose the WSCHANGE or PRCHANGE option from the WINSTALL menu.

13
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IDATA FILES

A WordStar data file is a nondocument file that holds information to merge into
a WordStar document. A data file consists of a series of records. Each record
consists of several fields or items of information. You can use WordStar to
create your own data files or you can use data files from MailList™, dBASE II,
111, 1+, or IV, Symphony, Quattro, or Lotus 1-2-3, all versions previous to 3.

DEcIMAL TABS
Classic Pull-down
AOI Layout=Ruler Line=>Tab Stops

A decimal tab stop aligns decimal points in a column. To set a decimal tab, set
a regular tab preceded by the # symbol.

DEFAULTS

DELAYS

Most options in WordStar have preset, or default, settings. To change settings
in a single document, use editing commands. To change settings for all docu-
ments, use paragraph styles or WSCHANGE.

A delay is a pause before an instruction is carried out. For example, a delay
allows you to press the other key in a classic command before the submenu
appears. You can change the length of delays with WSCHANGE.

DELETING TEXT

14

The chart below shows the WordStar commands for deleting text.

Character, space, or command tag at Press ~G or Del.
cursor

Previous character, space, or command Press AH or Backspace.
tag




FUNCTIONS AND COMMANDS

Word

Place cursor on first character and
press AT.

Carriage return

Place cursor at end of line and press AT,
"G, or Del.

Line, blank line, or dot command line Press AY.
Line right of cursor Press AQY.
Line left of cursor Press AQ Del.

From cursor to a specific character

Press AQT and type the character.

Sentence

Press AQT and type a period.

Paragraph

Press AQT and press Enter.

Page or text block

Mark beginning (*KB) and end (*KK),
then press AKY.

Footnote Place cursor on command tag and
press G or Del.

File Press Y at the classic Opening Menu or
AKJ while editing.

DiALoc BOXES

A dialog box has one or more areas where you fill in information or select
settings. The chart below shows how to move around in a dialog box. (In

addition, you can use the arrow keys.)

Forward

The Tab key

Backward

Shift and the Tab key

To specific option

Alt plus the highlighted or underlined
character

15
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To select a file or change settings in the dialog box, follow the steps below as
appropriate.

= Type a name or press the arrow keys to select a name from the list. You can
use the AR (Restore) command to restore the information you entered
previously.

®  Move the cursor to the option button with the setting you want to select or
clear, or press Alt and the key for the highlighted or underlined character.
When you move the cursor to a button, it’s selected. A diamond shape
indicates a selection.

= Move the cursor to the check box for the setting you want to turn on or off
and press the Spacebar, or press the key for the highlighted or underlined
character. An X in the brackets indicates that the setting is on. To turn the
setting off, repeat the keystroke.

To save the settings and close a dialog box, press F10 or choose OK. (F10
enters the WordStar command ~K; you can use AK and F10 interchangeably.)

DIRECTORY DISPLAY

Classic Pull-down

F (Opening Menu)  File=>Change Filename Display

Press F at the classic Opening Menu to turn on or off the display of filenames in
the current directory. When you turn on the display of filenames, you can
specify which files to see. For example, you could use *.DOC to display only
files with the .DOC extension. To change the default display of directories to
off, use WSCHANGE. When you change the logged drive or directory, the dis-
play shows the files on the new logged drive and directory.

DISPLAYING COMMAND TAGS AND OTHER SCREEN SETTINGS

Classic Pull-down
AOD View=>Command Tags
~OB View=>Screen Settings
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Press AOD (Command Tags) to turn the display of command tags and other
screen elements on or off. The other screen elements that can be turned on or
off with command tags are dot commands, the flag column, and soft space dots.
Use ~OB (Screen Settings) to change which of these elements are displayed
with command tags. You can also use the Screen Settings dialog box to turn on
or off the scroll bar, the style bar, the status line, the ruler line, and classic com-
mands on pull-down menus.

DocUMENTS AND NONDOCUMENTS

Classic Pull-down

D (Opening Menu) File=Open Document

S (Opening Menu)  File=>New

N (Opening Menu) File=>Open Nondocument

Document files are text files. Nondocument files are ASCII files. If you open a
document file with D (Open Document), you name the file before you open it.
If you create a document file with S (New), you name the file when you save it.

Dot commaNDs
Classic Pull-down
~OD View=>Command Tags
~OB View=>Screen Settings=>Dot Commands

A WordStar dot command has a period in column one followed by a code that
changes settings in a document. Most dialog boxes and some classic com-
mands insert dot commands. If you prefer, you can type a dot command
directly into a document. For a complete list of dot commands see the “Com-
mand Reference” section in this book.

Use ~OD (Command Tags) to turn the display of dot commands on or off. If

you want dot commands to remain displayed when Command Tags are off, use
AOB.

17



QUICK REFERENCE

DoOUBLE STRIKE
Classic Pull-down
APD Style=>QOther=>Double Strike

When you use this command, the printer strikes each character twice to
produce a light bold. To double strike text, place the cursor where you want
the double strike to start and give the command. To mark the end of double
strike, move the cursor to the space after the last character you want WordStar
to double strike and repeat the command.

EbprtiNG

Editing is the process of making changes to the content or appearance of an
existing document. To edit a document, open the file and use any of the
WordStar edit commands. To edit a file without going through the Opening
screen, name the file at the system prompt when you start WordStar. For
example, type ws filename.

When you do extensive editing in one session, it's a good idea to use ~KS to

save your work frequently. If you then experience any hardware or power
failures, most of your work will have been saved to disk.

Ewms

WordStar supports Expanded Memory Specification (EMS) if it is available. The
default for EMS support is 256 kilobytes of memory (16 pages of 16 kilobytes
memory for each page). EMS support can be increased or decreased in
WSCHANGE.

ENDNOTES. See “Footnotes, Endnotes, and Annotations.”

ENVELOPES

To create a file that prints a standard 9.5 x 4-inch business envelope, use the fol-
lowing editing settings: top margin 2 inches, bottom margin 0 inch, page length
4 inches, page offset 4 inches, and page numbers off. These settings work with

18
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most printers except lasers and other page printers. WordStar provides several
files for printing envelopes on HP LaserJet and compatible printers. For more

information on printing envelopes, see the “MailList” section of Companion
Programs.

EXITING A DOCUMENT

Classic Pull-down

AKD File=>Save and Close
AKQ File=>Close

AKT File=>Save As

AKX

Use AKD (Save and Close) to save and exit a document. Use *"KQ (Close) to
save or abandon changes and exit a document. Use ~KT (Save As) to save the
document under a new name and exit. Use AKX to save the file and exit
WordStar.

EXITING WORDSTAR

Classic Pull-down
X (Opening Menu)  File=>Exit WordStar

To exit WordStar, use X (Exit WordStar) at the Opening Menu. You can’t exit
while you are printing in the background; you must finish or quit printing first.

EXTENDED CHARACTER SET

Classic Pull-down
APO Insert=>Extended Character

Some printers can print special characters such as graphic characters, Greek let-
ters, and letters with accent marks. These characters are called the extended
character set and may vary from font to font. If your font uses the IBM extended
character set, you can use AP0 (Extended Characters) and choose the characters
from a dialog box.
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FAX FILES

Classic Pull-down

\ (Opening Menu)  File=>Fax
AK\ File=>Fax

Use these commands to create .PCX graphic format files from WordStar docu-
ments. You can send these files using a fax board and fax software.

FILENAMES

A filename can have up to eight characters and an optional three-character
extension. Filenames can include letters, numbers, and the following symbols:

$&#@ ' % " ()—_~
Some filenames do not appear in the directory, for example, .EXE and .COM

extensions. For more information on filenames and the directory, see “Direc-
tory Display.”

FINDING TEXT

Classic Pull-down
AQF Edit=Find

The Find command locates text or command tags. You can select options such
as searching for whole words, ignoring the case of characters, or searching
backward. If you don’t select any options in the Find dialog box, WordStar
uses the default options you set in WSCHANGE. Use AL (Next Find) to find the
next occurrence.

FINDING AND REPLACING TEXT

20

Classic Pull-down
AQA Edit=Find and Replace
AL Edit=>Next Find

Use the Find and Replace command to locate and replace or delete text or com-
mand tags. You can select options such as having WordStar replace text
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without asking and indicating how many occurrences of the string are to be
replaced. If you don’t select any options, WordStar uses the default options you
set in WSCHANGE. Use the Next Find command to repeat the same Find and
Replace.

Fra¢ coLumn

Fonrs

Classic Pull-down
AOD View=Command Tags
~OB View=>Screen Settings=>Flag Column

The flag column on the right side of the screen displays a flag for each line to
remind you of what you typed on the line. For example, when WordStar inserts
a dot command into your file, a dot appears in the flag column. Use AOD
(Command Tags) to turn the display of the flag column on or off. If you want
the flag column displayed even when command tags are hidden, use ~OB
(Screen Settings).

Classic Pull-down
AP= Style=>Font

A font is a particular style and size of typeface in a character set. To change to
a different font, use this command where you want the font to begin. The para-
graph that contains the font reformats automatically. To reformat the rest of the
document, press A*QU.

FOOTNOTES, ENDNOTES, AND ANNOTATIONS

Classic Pull-down

AONF Insert=>Note=>Footnote

AONE Insert=>Note=>Endnote

AONA Insert=>Note=>Annotation

.pe Edit=>Note Options=>Endnote Location

Footnotes and annotations appear at the bottom of the page; endnotes appear
on the last page of the document. Use .pe (Endnote Location) to specify a

21
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different location for endnotes. Use Preview to see how the footnotes and
annotations appear on the printed page.

ForMm FEEDS
Classic Pull-down
APL
.pa Insert—>Page Break

Use these commands to cause your printer to advance to the next page. If your
printer requires a different form-feed string than the printer description file
(PDF) uses, type the dot command .xl and the required form-feed string.

FuncTION KEYS

Function keys are labeled F1-F10 (or F12) and are assigned specific functions
with macros. To change the settings of the function keys, re-record or edit the
current macros. For a list of the function keys, see the Reference manual.

GRAPHICS (INSET®)

Classic Pull-down
AP Insert=>Graphic
AP& Utilities=>Inset

AP& (Inset) starts Inset during editing. Use AP* (Graphic) to import images in
graphics format into a WordStar document. This command allows you to use
files from a number of graphics programs.

HANGING INDENT

A hanging indent indents all lines of text after the first line of a paragraph. For
example, the paragraph style Hanging Indent 1 starts the first line of a para-
graph at the left margin and indents subsequent lines to the first tab stop.

22
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HEADERS AND FOOTERS
Classic Pull-down
.hn/.fn Layout=>Headers/Footers

Use this command to insert a header or footer dot command. You can define
up to five lines for each header and footer. The dot commands for five lines of
a header are .he or .h1, .h2, .h3, .h4, .h5. The dot commands for five lines of a
footer are .fo or .f1, .f2, .f3, ,f4, f5. To specify a different header or footer for
odd or even pages, select Odd Pages or Even Pages in the Header and Footer
dialog boxes. You can also type e or o after the header or footer number in the
dot command, for example, .h1e for an even header.

HELP LEVELS
Classic Pull-down
F1F1 Help=>Change Help Level

Use these commands anywhere in WordStar to control the amount of onscreen
information displayed in menus, messages, and prompts. Help level 4 displays
pull-down menus. Help levels 3 and below display decreasing levels of classic

menus.
HELP MESSAGES
Classic Pull-down
F1 Help=>Help
Onscreen help is available for every command and option anywhere in
WordStar.
HYPHENATION
Classic Pull-down
AOH Layout=>Alignment and Spacing=>Hyphenation
AOE Layout=>Special Effects=Optional Hyphen

Use A"OH (Hyphenation) to turn auto-hyphenation on and off. WordStar
hyphenates words at the ends of lines when auto-hyphenation is on. The

23
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hyphens that WordStar adds during auto-hyphenation are called soft hyphens.
To specify that a word can be hyphenated even when auto-hyphenation is off,
or to change the location of a soft hyphen, place the cursor where you want the
word to be hyphenated and press AOE (Optional Hyphen).

INDENTING
Classic Pull-down
AQI Layout=>Ruler Line=>Tab Stops
AO, Layout=>Ruler Line=>First Line Indent
AOL Layout=>Ruler Line=>Left Margin

You can indent text several ways: Set tab stops and then press the Tab key, set
a first line indent, or change the left margin. You can set tab stops in the Ruler
Line dialog box or when you define paragraph styles. The Hanging Indent
paragraph styles supply preset hanging indents.

INDEXING
Classic Pull-down
| (Opening Menu)  Utilities=>Index
AONI Insert=>Index/TOC Entry=>Index Entry
APK Insert=>Index/TOC Entry=>Mark Text for Index

Use AONI (Index Entry) to type index entries. Use APK (Mark Text for Index) to
mark the beginning and end of text for index entries. To create the index, press
I (Index) at the Opening Menu.

INSERTING FILES
Classic Pull-down
AKR Insert=>File
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To insert a file at the cursor location, give the command, and specify the file
you want to insert. Include the drive and directory name, if necessary. You
can also insert a file with the .fi dot command. The file is inserted when you
print the document and does not remain in the document. For information on
commands to copy or insert part of a file, see “Copying Text.”
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INSERTING TEXT

Classic
AV

Use AV to turn Insert mode on and off. When Insert mode is on, you can insert
characters without typing over existing text. When Insert mode is off, you over-
type characters. Another way to turn Insert mode on and off is to press the Ins
key.

INSTALLING WORDSTAR

For information on installing WordStar see the Installing and Customizing
booklet.

INTERNATIONAL CHARACTERS

ItaLic

Some international characters have accents or other diacritical marks that distin-
guish them from other alphabetical characters. When the international charac-
ter table is turned on in WSCHANGE (the default setting is OFF), you can enter
international characters into your document by pressing the two keys that com-
pose the character. For information on the onscreen display and printing of
international characters, see the Reference manual.

Classic Pull-down
APY Style=>ltalic

To make text italic, place the cursor where you want the italic to start and press

APY (ltalic). To mark the end of italic, place the cursor in the space after the
last character you want italic and repeat the command.
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JUSTIFICATION
Classic Pull-down
AO)J Layout=>Alignment and Spacing=>Justified

When justification is on, WordStar adds spaces to make all lines extend to the
right margin. When justification is off, right margins are ragged.

KERNING
Classic Pull-down
.kr on/off Layout=>Alignment and Spacing=>Kerning

Kerning adjusts the space between certain pairs of printed characters for a more
professional look. Kerning eliminates gaps and gives an even look to letters that
are typically paired.

LANDSCAPE AND PORTRAIT MODE

Classic Pull-down
AOY Layout=>Page=>Portrait
AQY Layout=>Page=>Landscape

Use these commands at the top of a page if you have a page printer and want to
switch between portrait and landscape mode. If you specify portrait mode (the
default), your document is printed the usual way on the page. If you specify
landscape mode, your document is printed lengthwise on the page.

LANGUAGE CHANGE
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Classic Pull-down

Ja Utilities=>Language Change

With the appropriate dictionaries installed in WordStar, you can hyphenate and
check spelling in various languages. You can change the default language in
WSCHANGE. To change the language within a document, use this command
and the code for the language you want.
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LINE DRAWING

When used with the Alt key, ten of the function keys produce line-drawing char-
acters. You can use these characters to draw lines and boxes. For more infor-
mation on box and line drawing, see “Box and Line Drawing” in the Reference
manual.

LINE FEEDS

Classic
/\PJ

When the printer encounters a line-feed symbol, it moves down a line without

returning to the left margin and prints in the column following the one that con-
tains the line feed.

When you press Enter with insert on, a hard carriage return and a line feed are
inserted into the file. When insert is off, Enter moves the cursor to the next line
and no code is inserted into the file.

LINE HEIGHT
Classic Pull-down
NOS Layout=>Alignment and Spacing=>Leading

The distance between lines of print is the leading (or line height). It is measured
from the bottom of one line to the bottom of the following line. You can
specify the distance between lines (in 48ths of an inch) using this command or
your current paragraph style. When you change line height, use Preview to see
the new spacing onscreen.

LINE NUMBERING
Classic Pull-down
# Layout=Line Numbering

Line numbers print in the left margin of your document. This command turns
your document into legal pleading paper.
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LINE sPACING
Classic Pull-down
AQS Layout=>Alignment and Spacing=>Line Spacing

Line spacing prints your text double-spaced, triple-spaced, and so on. When
you change line spacing, you see the new spacing onscreen.

LOGGED DRIVE AND DIRECTORY

Classic Pull-down
L (Opening Menu)  File=>Change Drive/Directory
AKL File=>Change Drive/Directory

The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive unless you tell it otherwise. Use
these commands to change the logged drive or directory.

LsrronTs

Use the LSRFONTS option in WINSTALL to add laser fonts to a custom font
database. Then use PRCHANGE to add the fonts from the database to a PDF.
These fonts are for HP or compatible printers, PostScript printers, the IBM
4019/4029, and the Xerox 4045. For more information on LSRFONTS, see the
Installing and Customizing booklet.

Macros
Classic Pull-down
M (Opening Menu)  Ultilities=>Macros
AMD Utilities=>Macros=>Edit/create
AMO Utilities=>Macros—>Copy
AMP Utilities=>Macros—>Play
AMR Utilities=Macros=>Record
"ME Utilities=>Macros=>Rename
AMS Utilities=>Macros=>Single Step
AMY Utilities=>Macros=>Delete
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You can record or create macros to enter frequently used text into a document
or to enter a sequence of commands. When you want to play the macro, use
the Play command or use the hot key assigned to the macro. Single Step
allows you to play the macro one step at a time in order to analyze it.

Marriist
Classic Pull-down
AM (Opening) Additional=MailList

MailList lets you easily create, update, and sort mailing lists and inventories by
providing onscreen forms for entering your data. You can then print letters,
reports, or lists using this data.

MAILMERGE® See “Merge Printing.”

MARGINS

The margins in a document specify the limits of the text area. WordStar has
eight margins—first line indent, header and footer, left and right, page offset,
and top and bottom. The default unit of measurement for setting margins is
inches. You can also set margins in ruler units (columns), lines, centimeters, or
points.

MARGINS, FIRST LINE INDENT

Classic Pull-down

AOL Layout=>Ruler Line=>First Line Indent

The first line indent sets a separate left margin for the first line of each para-
graph. This is useful for indenting the first line, or for outlines where you want
the first line of a paragraph to hang out to the left of the text. WordStar puts a
.pm command in your document when you choose First Line Indent in the
dialog box. You can also set a first line indent when you define a paragraph
style ("OFD).
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MARGINS, HEADER AND FOOTER

Classic Pull-down
NOY Layout=>Page=>Header
AOY Layout=>Page=>Footer

The header margin is the space between the last header line and the first line of
text. The footer margin is the space between the last line of text (on a full page)
and the first footer line. WordStar inserts a .hm command in your document for
a header margin and a .fm command for a footer margin.

MARGINS, LEFT AND RIGHT

Classic Pull-down
AOL Layout=>Ruler Line=>Left Margin
AOR Layout=>Ruler Line=>Right Margin

The left margin is the space between the page offset and the start of text. The
right margin is the space between the page offset and the end of text. You

can set the left margin to any value between 0 and 25.4 inches, and the right
margin between 1 and 36 inches, but there must be at least a .2 inch space
between them. WordStar puts a .Im command in your document when you
change the left margin and a .rm command when you change the right margin.

MARGINS, PAGE OFFSET
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Classic Pull-down
rOY Layout=>Page=>Odd Offset
AOY Layout=>Page=>Even Offset

Page offset is the amount of space between the left edge of the paper and
column 1 of your text. When you select different page offsets for odd and even
pages, WordStar inserts .poe in your document for even pages and .poo for odd
pages. If you put pages in a binder, you may want a bigger page offset on odd
pages to leave room for the binder holes. To set a page offset for all pages, type
the dot command .po. For example, .po .5" prints text .5 inch from the left
edge of the paper for all pages.
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MARGINS, TOP AND BOTTOM

Classic Pull-down
MY Layout=>Page=>Top
DO Layout=>Page=>Bottom

The top margin is the amount of space between the top of the page and the text
area. The bottom margin is the amount of space between the bottom of the
page and the text area. The top and bottom margin commands take effect at
the beginning of the next page after they are inserted. If you want the com-
mands to take effect on the current page, you must place them at the top of the
page. When you change the top margin, WordStar inserts a .mt command.
When you change the bottom margin, WordStar inserts a .mb command. Use
Preview to see the top and bottom margins of a page.

MARKERS
Classic Pull-down
AKn (0 to 9) Edit=>Set Marker
AQn (0to 9) Edit=>Go to Marker

Temporary markers help you find your place. Once you set a marker, you can
quickly move the cursor to that marker with 2AQn.

MEMORY USAGE

Classic Pull-down

? (Opening Menu)  File=>Status
AO? File=>Status

WordStar is loaded into a computer’s random-access memory (RAM). At the

Status screen you can find out how much RAM is used by WordStar and your
text and data files.
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MENU BAR

MENUS

The menu bar shows the names of the pull-down menus. To see a menu at the
Opening screen click the menu name with a mouse, or press the key for the
highlighted or underlined character in the menu name. To see a menu at the
Edit screen, use the mouse or press Alt plus the highlighted or underlined char-
acter in the menu name. Use the direction keys to move from name to name.

A menu contains a list of commands from which you choose the task you want
to do. WordStar has two types of menus: pull-down and classic. The pull-
down menus are the default menus. When the help level is 3 or below, the
classic Opening Menu appears when you start WordStar.

MERGE PRINTING

Merge printing is the process of inserting information into a document while it’s
being printed. Merge printing is most commonly used with form letters, mailing
labels, contracts, and any other documents that require you to “fill in the
blanks.” You can use data files from MailList, Lotus 1-2-3 (all versions except
3), Symphony, Quattro, dBASE II, IIl, Ill+, or IV for merge printing. WordStar
comes with files that include the correct commands to merge print using
MailList data files.

MERGE PRINTING — CONDITIONAL COMMANDS
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Classic Pull-down

Jif Utilities=>Merge Print Commands=>If

.ei Utilities=>Merge Print Commands=>End If
el Utilities=>Merge Print Commands=>Else

Conditional merge print dot commands allow you to use a master document to

produce letters that contain customized information, based on conditions you
set.
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MERGE PRINTING — DOT COMMANDS

Classic Pull-down

.av Utilities=>Merge Print Commands=>Ask for Variable

df Utilities=>Merge Print Commands=>Data File

.ma Utilities=>Merge Print Commands=>Set Variable to
Math Result

v Utilities=>Merge Print Commands=>Name Variables

.SV Utilities=>Merge Print Commands=>Set Variable

Merge printing dot commands in the master document tell WordStar the vari-
able names and where to get the data that goes with them. The Ask for Vari-
able command (.av) has WordStar pause during printing and ask you for the
data to replace a variable. The Data File command (.df) tells WordStar the
name of your data file. Set Variable to Math Result (.ma) performs calculations
while you are merge printing. The Name Variables command (.rv) tells
WordStar the variable names for the fields in your data file. Every .df command
must be followed by a .rv command to name the fields. For information on the
Set Variable command (.sv) see “Merge Printing—Variable Formatting” and
“Merge Printing—Variable Number Formatting.”

MERGE PRINTING — MESSAGES WHILE PRINTING

Classic Pull-down

.CS Utilities=>Merge Print Commands=>Clear Screen While
Printing

.dm Utilities=>Merge Print Commands=>Display Message

These commands are useful for displaying messages that explain what's going
on while you're printing. For example, you can have WordStar clear the screen
and then display messages that give reminders and instructions to the person
doing the printing.

. MERGE PRINTING — VARIABLE FORMATTING

Classic Pull-down
.SV Utilities=>Merge Print Commands=>Set Variable

Variable formatting allows you very close control of the appearance of your
form documents, especially those that use merge print variables in tables or
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charts. For example, with the set variable command you can define the maxi-
mum number of characters allowed to replace a variable and how the data is
justified.

MERGE PRINTING — VARIABLE NUMBER FORMATTING

Classic Pull-down
.SV Utilities=>Merge Print Commands=>Set Variable

Variable number formatting controls the appearance of numeric data items that
replace variables in your form documents. For examples of variable number for-
matting, see the Reference manual.

MERGE PRINTING — VARIABLES
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Master documents contain variables wherever data is to be inserted. At the spot
in the text where you want to insert variable data, type the variable name with
ampersands (&) before and after it.

See the following table for the eight predefined variables. WordStar supplies
data for these variables when you print a document.

&#& Inserts the current page number.

&_& Inserts the current line number.

&@& Inserts today’s date.

&!& Inserts the current time.

&:& Inserts the currently logged drive.

&.& Inserts the currently logged directory name.

&*& Inserts the current filename.

&\& Inserts the full path and filename of the current file.
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MICROJUSTIFICATION

Mousk

Classic
.uj on/off/dis

When text is justified, microjustification spreads the white space as evenly as
possible, not only between words but also between the letters of each word. In
your document, type .uj on to turn microjustification on. If microjustification is
on, then justification (Layout=>Alignment and Spacing=>)ustified) should also
be on. Justification tells WordStar to extend all lines to the right margin. To
turn microjustification off, type .uj off. The default .uj dis lets WordStar deter-
mine whether to use microjustification.

You can use a mouse in WordStar to position the cursor; select commands or
options from menus, dialog boxes, and the style bar; move between windows,
and select text.

NESTING AND CHAINING

Classic Pull-down

fi Insert=>File at Print Time

You can chain files so that they print one after the other, or nest them, inserting
one inside the other. The files are connected only for printing; their contents
remain separate. You can nest files up to eight levels.

NONDOCUMENTS. See “Documents and Nondocumenis.”

OUTLINING. See “Paragraph Outline Numbering.”
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OVERPRINTING
Classic Pull-down
APH Layout=>Special Effects=>Overprint Character
AP Layout=>Special Effects=>Overprint Line

To print two characters in one space, use APH (Overprint Character). To printa
line on top of another line, use AP.

PAGE BREAKS
Classic Pull-down
.pa Insert=>Page Break

A page break is the division between two pages. WordStar inserts page breaks
when the text fills a page. You can insert a hard page break anywhere you
want to begin a new page. For information on form feeds see “Form Feeds.”

PAGE NUMBERING
Classic Pull-down
ANO# Layout=>Page Numbering=>Set Page Number
NO# Layout=>Page Numbering=>Position on Line
AO# Layout=>Page Numbering=>Print Page Numbers

The page numbering commands control the printing of the default page num-
ber. In the Page Numbering dialog box, use the Set Page Number option to
restart page numbers at a specified number. Use the Position on Line option to
print the page number at a specified location. Clear the Print Page Numbers

check box to omit printing of page numbers. Select Print Page Numbers to turn
printing of page numbers on.

PAGE OFFSET. See “Margins, Page Offset.”

PAGE PREVIEW., See ““Preview.”
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PAPER BIN
Classic Pull-down
AOY Layout=>Page Layout=>Paper Bin

Single-sheet printers, such as laser printers, use sheet feeders to advance the
paper. If you have a laser printer, WordStar installs your paper bin for you. If
you have another type of printer, you need to install it yourself. Some sheet
feeders have more than one paper bin. You can use paper from different bins
in one document by selecting the bin in the dialog box.

PARAGRAPH OUTLINE NUMBERING

Classic Pull-down
NOZ Insert=>Paragraph Outline Number
.p# Insert=>Paragraph Outline Number=>Options

Paragraph numbers are useful for outlines, proposals, and contracts. Place the
cursor where you want the number to appear and press AOZ (Paragraph Out-
line Number). You can change the numbering system from only numerals to
combinations of letters, roman numerals, and numerals in the dialog box.

PARAGRAPH STYLES
Classic Pull-down
XOES Style=>Select Paragraph Style
AOFP Style=>Return to Previous Style
AOFD Style=>Define Paragraph Style
AOFO Style=>Manage Paragraph Styles=>Copy Style to Library
AOFY Style=>Manage Paragraph Styles—>Delete Library Style
AOFR Style=>Manage Paragraph Styles=>Rename Library Style
NOFE Style=>Manage Paragraph Styles=>Rename Document Style

Paragraph styles store layout settings such as margins, tabs, and line heights.
Styles also set print attributes such as bold, underline, and italic. By using a
paragraph style you can change several layout and print settings at once.
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Partns
The basic directory on a disk is called the root directory, with other directories
forming a tree structure off the root directory. The directories you go through
from the root directory to a specific file comprise the path to that file.

PAUSE PRINTING
Classic
APC
Use the pause printing command at the location in your document where you
want printing to pause. Your printer’s buffer may affect the location of the print
pause.

PprEDIT
The PDFEDIT program allows you to make changes to printer files (PDFs). You
can also make changes to PDFs for supported printers. To use PDFEDIT, you
must have installed a printer and created a PDF. For more information about
PDFEDIT, see the Installing and Customizing hooklet.

Prrca

Pitch is the amount of horizontal space taken up by each character in a non-
proportional font, usually expressed as characters per inch (cpi). In a propor-
tional font, where characters take up different amounts of space, point size is
used instead of pitch.

PILACE MARKERS. See “Markers.”

PorrTs
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Printers are usually connected by cables to ports at the back of your computer.
WordStar looks for printers on the LPT1 port. If your printer is connected to a
different port, be sure to specify the correct port during installation. You can

also choose a different port at print time by using the option to Redirect Output
To in the Print dialog box.
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PRCHANGE

Use the PRCHANGE option in WINSTALL to specify default settings for your
printers. For information on PRCHANGE, see the Installing and Customizing

booklet.

PreviEW
Classic Pull-down
~QOP View=>Preview

Preview lets you see exactly how your document will look when printed. The
preview includes columns, headers, footers, footnotes, fonts, and so on. This
feature works only on a graphics monitor.

PRINTER DESCRIPTION FILES

Each time you install a printer, WordStar creates a printer description file (PDF).
The PDF contains the information WordStar needs to work with that printer.

PRINTING A FILE

Classic Pull-down
P (Opening Menu)  File=>Print
AKSAKP File=>Print

You can print from the Opening Menu or during editing. If you use the Print
command while you're editing, WordStar saves your current file and then dis-
plays the Print dialog box. Printing is normally done in the background. This
means that you can continue with what you were doing before you started the
printing process.
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PRINTING FROM KEYBOARD

Classic Pull-down
K (Opening Menu)  File=>Print from Keyboard

When you print from the keyboard, you use your printer like a typewriter. Each
time you press Enter, that line of text goes directly to the printer. Not all
printers can print from the keyboard. Use DRAFT.PDF for the best results.

PRINTING MERGE VARIABLES

Classic Pull-down

P (Opening Menu)  File=>Print
AKSAKP File=>Print

You can print from the Opening Menu or during editing. If you use the print
command while you’re editing, WordStar saves your current file and then dis-
plays the Print dialog box. In the Print dialog box, the default is for WordStar to
Interpret Merge Variables. If you clear this check box, variable names are
printed in the text rather than the variable data, and merge print commands are
ignored.

PRINTING TO DISK

Classic Pull-down

P (Opening Menu)  File=>Print
AKP File=>Print

Sometimes you may want to print a document to a file on disk rather than
printing it on paper. You can print to disk by using one of five special

PDFs — PRVIEW, ASCII, ASC256, XTRACT, and WS4. You can also print to
disk by typing a filename in the Redirect Output To option in the Print dialog
box. If you print to disk during editing, WordStar saves your file first.

PRoOFINDER™

ProFinder helps you manage all the files on your disk. For more information,
see the “ProFinder” section in Companion Programs.
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PROPORTIONAL SPACING

Proportional spacing occurs when you print a file with proportional fonts. In
proportional spacing, different letters take up different amounts of space; for

example, an “m” takes up more space than an “i.” Proportional font sizes are
measured in points (72nds of an inch), which specify the height of the letters.

PROTECTING A FILE

Classic Pull-down
C (Opening Menu)  File=>Protect/Unprotect

You can protect a file so it can’t be changed. Protect your own files if you
share disks with other operators, or protect final drafts of any documents. You
can remove protection whenever you want.

README

README contains technical advisories regarding WordStar and information that
came in too late to be included in the manuals.

To see the README information at the system prompt, log on to the WordStar
directory, type readme, and press Enter.

REFORMATTING TEXT

Classic Pull-down
B Utilities=>Reformat=>Paragraph
AQU Utilities=>Reformat=>Rest of Document

Use these commands to reformat text in document mode when you change mar-
gins, tabs, or fonts.

REFRESH SCREEN. See “Clearing The Screen.”
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RENAMING A FILE

Classic Pull-down

E (Opening Menu)  File=>Rename
AKE File=>Rename
AKT File=>Save As

You can rename a file either at the Opening Menu or the Edit menu. To
rename the edited version of the file you're working on, press KT (Save As).

REPEATING
Classic Pull-down
A0Q Utilities=>Repeat Next Keystroke

The repeat command tells WordStar to continuously repeat a single-letter com-
mand or a keyboard character. You stop the repeat command by pressing the

Spacebar.
RULER LINE
Classic Pull-down
AOL Layout=>Ruler Line
~OB View=>Screen Settings—>Ruler Line

The ruler line above the text shows the margins and tab stops that currently
apply to your text. Press AOL (Ruler Line) to change the left margin or first line
indent. Press AOR (Right Margin) to change the right margin and ~OlI (Tab
Stops) to change tab stops. The marker on the ruler line shows the position of
the cursor on the page and moves as you move the cursor. You can turn the
display of the ruler line on and off with AOB (Screen Settings).

RUNNING A DOS COMMAND

Classic Pull-down
R (Opening Menu)  File=Run DOS Command
NKF File=Run DOS Command
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You can run a DOS command at the Opening Menu or during editing without
leaving WordStar. WordStar temporarily moves into the background, and you
type the DOS command you want.

SAVING A FILE

Classic Pull-down

AKD File=>Save and Close
AKQ File=>Close

AKS File=>Save

AKT File=>Save As

AKX

When you open a document, the original file stays on the disk while you work

on a copy in the computer’s memory. When you save the document, the copy
in memory (with all the changes) goes back to the disk and replaces the original
file. The original file is saved with the .BAK extension.

When you use AKD (Save and Close), the file is saved and you return to the
Opening Menu. If you've edited the file, AKQ (Close) asks whether you want to
save, abandon your changes, or cancel the command and return to the file.
AKS (Save) saves the file and allows you to continue editing. ~KT (Save As)
prompts you for a new filename and saves the file with that name. ~KX saves
the file and exits WordStar.

SCREEN SETTINGS
Classic Pull-down
~OB View=>Screen Settings

At the Screen Settings dialog box you can select which of the following items
will be turned on and off with AOD (Command Tags): dot commands, flag
column, and soft space dots. You can also determine whether the following
items appear onscreen: scroll bar, style bar, status line, ruler line, and classic
commands on pull-down menus.
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SCROLL BAR
Classic Pull-down
AOB View=>Screen Settings=>Scroll Bar

If you have a mouse, you can use the vertical scroll bar at the right of the screen
to go forward or backward in a document by lines, screens, or pages. Choose
the Scroll Bar option in the Screen Settings dialog box to turn the display of the
scroll bar on and off.

SCROLLING. See “Cursor Movement and Scrolling.”

SHEET FEEDERS. See “Paper Bin.”

SOFT SPACES
Classic Pull-down
~OB View=>Screen Settings=>Soft Space Dots

When WordStar justifies text, it inserts extra soft spaces between words to make
the line extend all the way to the right margin. WordStar can display soft
spaces as dots.

The Soft Space Dots option allows you to choose to display soft space dots, to
have display off, or to display soft space dots with command tags.

SORTING
Classic Pull-down
AKZA Utilities=>Sort Block=>Ascending
AKZD Utilities=>Sort Block=>Descending
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You can sort lines in your text to put them in alphabetic and numeric order. If
column mode is on, WordStar determines the sort order based on the high-
lighted text. If column mode is off, the sort order is based on all the characters
on the line. To sort your text, mark the text as a block, then press AKZ (Sort

Block). When prompted, type A or D to choose ascending (A-Z) or descending
(Z-A) sort order.
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SPEED WRITE

Classic Pull-down
S (Opening Menu)  File=>New

Press S (New) at the Opening Menu to open a new, unnamed file and go
directly to the editing screen. When you save or exit the file, WordStar prompts
you for a filename.

SPELLING CHECK

Classic Pull-down

AQRAQL Utilities=>Spelling Check Global

AQL Utilities=>Spelling Check Other=>Rest of Document
AQN Utilities=>Spelling Check Other=>Word

~QO Utilities=>Spelling Check Other=>Type Word
AONL Utilities=>Spelling Check Other=>Rest of Notes

Use the spelling check commands to check the spelling in your documents and
to find double words, such as the the.

Press AQRAQL (Spelling Check Global) to check the spelling of your entire
document. Press AQL (Rest of Document) to check the spelling of the rest of
the document. Place the cursor under a word and press AQN (Word) to check
the spelling of a word. Press 2QO (Type Word) to type a word and check its
spelling. Press AONL (Rest of Notes) to check the spelling in notes, such as
footnotes and endnotes.

SPREADSHEETS
Classic Pull-down
AKR Insert=>File

You can insert a spreadsheet from Lotus 1-2-3 (previous to version 3.0),
Symphony, or Quattro into your WordStar document. You can insert the
entire worksheet or you can choose the range to insert. For Lotus 3.0 and for
other file formats, you can either save the file to a supported format or use
Star Exchange to convert the file to WordStar format before inserting it.
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STAR EXCHANGE™

Classic Pull-down

AS (Opening Menu) Additional=>Star Exchange

Use Star Exchange to convert documents created with one application to be
compatible with documents created with another application. For example,

you can convert a document originally created with WordStar 2000 to the
WordStar format, and then edit the file as you would any WordStar document.

STARTING WORDSTAR

Before you start WordStar for the first time, follow the installation instructions in
the Installing and Customizing booklet.

To start WordStar, type ws at the system prompt and press Enter.

STATUS LINE
Classic Pull-down
~OB View=>Screen Settings=>Status Line

The status line appears at the bottom of the screen when you edit a file. It
shows the cursor location and various messages. You can turn the display of
the status line on and off with AOB. You can change the location of the status
line in WSCHANGE.

STATUS SCREEN

Classic Pull-down
? (Opening Menu)  File=>Status
ers File=>Status

You can see the status screen from either the Opening Menu or the Edit menu.
The status screen includes information about memory usage, the name of your
default printer, and whether Inset is loaded.
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STRIKEOUT
Classic Pull-down
APX Style=>Other=>Strikeout
XX Style=>Settings=>Character for Strikeout

Text you mark for strikeout is overprinted with hyphens, for example, text. You
can change the strikeout character in WSCHANGE or use the dot command .xx
while you're editing. Strikeout is useful when you want the reader to see text
that was included in previous drafts.

STYLE BAR
Classic Pull-down
~OB View=>Screen Settings=>Style Bar

The style bar appears at the top of the screen. It contains option buttons you
can select with a mouse, and displays information such as the current para-
graph style and font. Select Style Bar at the Screen Settings dialog box to turn
display of the style bar on and off. In WSCHANGE, you can change the loca-
tion of the Style Bar or turn it off permanently.

SUBSCRIPT AND SUPERSCRIPT

Classic Pull-down
APV Style=>Other=>Subscript
APT Style=>Other=>Superscript

Subscript text is printed slightly below the rest of the text on the line, for
example, H,O. Superscript text is printed slightly above the rest of the text on
the line, for example, MailList™. To mark text for subscript, for example, press
APV (Subscript) at the beginning and end of the text to mark. If you have
trouble getting your subscript or superscript fonts to print, try using the com-
mand .sr 0 before the subscript or superscript commands.
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SUPPRESS BLANK LINES
Classic Pull-down
AOY Layout=>Page=>Suppress Blank Lines at Top of Page

Sometimes when you edit a file, blank lines ending with hard carriage returns
fall at the top of a page, creating uneven top margins. If you want to suppress
these lines in your printed document, move the cursor to the top of the page,
give the command, and select Suppress Blank Lines at Top of Page. The blank
lines at the tops of pages are suppressed in the rest of the printed document.

TABLE OF CONTENTS

Classic Pull-down
T (Opening Menu)  Utilities=>TOC
tc Insert=>Index/TOC Entry=>TOC Entry

In the TOC Entry dialog box, type the text you want to appear in the table of
contents; include punctuation and indentation. To create the table of contents,
use T (TOC) at the Opening Menu.

T'aBs
Classic Pull-down
AQOI Layout=>Ruler Line=>Tab Stops
Tab stops provide a way to indent text. Press 2Ol (Tab Stops) to set new tabs.
Type # in front of a number to set a decimal tab.
®
TELMERGE
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Classic Pull-down
AT (Opening Menu) Additional=>TelMerge

Use the TelMerge telecommunications program to link to telecommunications
services such as MCI Mail, or electronic bulletin boards to send files over your
phone lines. You need a modem to use Telmerge. For more information on
Telmerge, see the Companion Programs manual.



FUNCTIONS AND COMMANDS

TEMPORARY FILES

WordStar creates temporary files in the logged directory while you're editing
or printing a document. When you finish editing and close the document,
WordStar erases these temporary files.

THESAURUS
Classic Pull-down
Q) Utilities=>Thesaurus

To look up a synonym for a word in your document, place the cursor on the
word and press AQ)J (Thesaurus). To select a synonym, move the cursor to the
word you want and press Enter. The word you select replaces the original word
in your document.

TITLE BAR

The title bar is at the top of the screen and includes the name of the file being
edited, the program name, and messages, such as Printing, or messages when
macros are playing. If you have a second window open, the right side of the
title bar shows the current window number. If you have a mouse, the left side
of the title bar has a close button and the right side has a button to maximize or
minimize window size.

UNDERLINING
Classic Pull-down
APS Style=>Underline
.ul on/off Style=>Settings=>Continuous Underline

To underline text, place the cursor where you want the underlining to start and
use the Underline command. To mark the end of the underlining, place the cur-
sor in the space after the last character you want underlined and repeat the
command.

Usually spaces between underlined words are underlined when you print a file.

To stop underlining spaces, use .ul off. For information on double underscore,
see the Reference manual.
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Unpo

Classic Pull-down
AU Edit=>Undo

When you use the Undo command, the last group of characters you erased is
restored to the screen at the current cursor location. Single characters erased
with AG, ~AH, Backspace, or Del cannot be unerased (except for note tags).

UNITS OF MEASUREMENT

WordStar supports inches, ruler units (columns or lines), centimeters, and points
as units of measurement. You can use separate units of measurement for any
options that use measurements. Use the appropriate notation after the

measurement:

"oriorin inches

r ruler units (columns for horizontal settings,
lines for vertial settings)

c or cm centimeters

p or pt points (in 72nds of an inch)

You set default units in WSCHANGE. Otherwise, the default in dialog boxes is
inches and the default in dot commands is ruler units. The default is used if no
notation is specified.

VARIABLES. See “Merge Printing — Variables.”

VERTICALLY CENTER TEXT

Classic Pull-down

AQV Layout=>Special Effects=>Vertically Center Text on Page

When you center text vertically on a page, the text from the cursor to the next
page break is centered vertically in the remaining space on the page.
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FUNCTIONS AND COMMANDS

Winpows

Classic Pull-down
ANOK View=>Open/Switch Window

You can look at two documents at once, or at two parts of the same document.
You can edit in either window.

With this command, you can select the file that you want to open or move from
one window to the other. To copy a block from one window to another, use
AKA (Edit=>Copy=>Block From Other Window).

Worbp count

Classic Pull-down
NK2 Utilities=Word Count

To get a count of the words and bytes in a marked block, press ~K? (Word
Count). If no block is marked, you get a count for the entire file. The maxi-
mum words counted is 65,535.

WoRD wraP

Classic Pull-down
aw Layout=>Alignment and Spacing=>Word Wrap

As you type, WordStar moves the cursor to a new line when you reach the end
of the current line. This is called word wrap. You press Enter only to mark the
end of a paragraph. You can turn word wrap on and off with this command.

WSscHANGE

Use the WSCHANGE option in WINSTALL to customize WordStar to run
exactly the way you want. For more information on WSCHANGE, see the
Installing and Customizing booklet.
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WssETup

To install WordStar the first time, type wssetup at the system prompt. WordStar
prompts you for the disks to copy to your hard disk and lets you install your
monitor and printer.
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COMMAND
REFERENCE

The Command Reference includes commands from the classic menus, dot commands, and
commands from the pull-down menus. The commands from the classic menus and dot
commands are listed in alphabetical order. Commands from the pull-down menus are listed

by menu.

COMMANDS FROM THE CLASSIC OPENING MENU

COMMAND

DESCRIPTION
Display status

Fax

Screen repaint
Additional Menu
Protect/unprotect file
Open a document
Rename file
Directory display
Help

Index

Print from keyboard

COMMAND

L
M
N
0
P
R
S
.
X
Y

DESCRIPTION

Change drive/directory
Macros

Open a nondocument
Copy file

Print file

Run a DOS command
Speed Write (new file)
Table of contents

Exit WordStar

Delete file
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Wy
Q
P4
W
i~
W
w
Wy
=
Q
Z
<
2
2
Q
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COMMANDS FROM THE CLASSIC EDIT MENU

COMMAND

A

"6
N6

A
AB
AC
AD
AE
AEnd
AF
F1
AG
AH
AHome
Al

~K

AK
AK\
AK]
AK[
AKH
AK’
AR

AK?

NK<
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DESCRIPTION
Enlarge window
Auto-indent mode (nondoc)

Change hard carriage return to
soft in document file

Move left one word
Reformat paragraph
Scroll down a screen
Move right one character
Move cursor up one line
Move to end of file

Move right one word
Help

Delete character at cursor
Delete previous character
Move to beginning of file
Insert tab

Accept all answers in dialog
box

Block and Save Menu

Create fax file

Copy to Clipboard

Copy from Clipboard

Convert block to uppercase
Convert block to lowercase
Convert block to sentence case

Word/byte count of block or
file

Unmark block

COMMAND
~Kn (0-9)
AKA

AKB

AKC

AKD

AKE

AKF

AKG

AKH

AKI
AKJ
AKK
AKL
AKM
AKN
ARO
AKP
AKQ
AKR
AKS
AKT
AKU
AKV
AKW
AKX
AKY
AKZ

DESCRIPTION

Insert place marker

Copy block between windows
Beginning block marker

Copy block

Save file, go to Opening Menu
Rename a file

Run a DOS command

Move block between windows

Display/hide block/place
markers

Column replace mode on/off
Delete a file

Ending block marker

Change logged drive/directory
Block math

Column mode on/off

Copy a file

Print a file

Exit file and abandon changes
Insert file into document

Save file and resume editing
Save and name file

Mark previous block

Move block

Write block to file

Save file and exit WordStar
Delete block

Sort block
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AL

ALeft Arrow
M

AMI

AM#

/\M$

AM*
M.
AM:
AM=
M@
AM\

AMD
AME
AMO
AMP
AMR
AMS
AMY
AN
2O
A
AO]
AO#
AOJ
AOA

DESCRIPTION

Repeat previous find/replace
Move left one word

Macro Menu

Insert time

Insert math expression

Insert last math result as dollar
amount

Insert current filename
Insert current directory
Insert current drive name
Insert last math result
Insert today’s date

Insert current path and
filename

Edit/Create macro
Rename macro

Copy macro

Play macro

Record macro

Single step

Delete macro

Insert blank line
Onscreen Format Menu
Display status screen
Right-align line

Page number

Enter closes dialog box

Auto align text

COMMAND
~OB

AOC

~OD

AOE

AOF

~OFD
AOFE

AOFO
AOFP

AOFR

AOFS
AOFV
AOFY
~OG
"OH
Ol
AQ)
AOK
AQL
AOM
AON
AONA
AONC
AOND
AONE

DESCRIPTION

Change screen settings
Center line

Command tags on/off

Soft hyphen

Paragraph Style Menu
Create/edit paragraph style

Rename a document
paragraph style

Copy paragraph style to library

Revert to previous paragraph
style

Rename a library paragraph
style

Select paragraph style

View a paragraph style
Delete library paragraph style
Temporary indent
Auto-hyphenation on/off
Tab settings

Justification on/off
Open/switch window

Left margin

Size current window

Notes Menu

Create annotation
Comments (nonprinting)
View/edit notes/index entries

Create endnote
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AONF
AONG
AONI
AONL
AONN
AONU
AONV
Nele)
AOP
AOR
~OS
AOU
AOV
_ AOW
AOX
rOY
rOZ
AP

AP
NPl
AP&
ApP*
/\P_
AP.
AP=
AP?

AP
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DESCRIPTION

Create footnote

Find note

Index entry

Check spelling in notes
Change note number
Reformat text in notes
Convert notes

Ruler to text

Page preview

Right margin

Line spacing

Columns (newspaper-style)
Center text vertically
Word wrap on/off
Margin release

Page layout

Paragraph numbering

Enter control characters in
dialog boxes

Print Controls Menu
Custom printer code
Start Inset

Insert graphic

Change color/shading
Insert dot leaders to tab
Change font

Change printer

Overprint line

COMMAND
APO
APA
APB
APC
APD
APE
NP
APG
APgDn
APgUp
APH
AP|

/\PJ
APK
AP
APM
APN
APOY
/\PQ
PR
APS
APT
APV
APW
APX
APY
Q

DESCRIPTION

Insert extended character
Alternate font

Bold on/off

Pause print

Double Strike on/off
Custom printer code
Phantom space
Phantom rubout
Scroll down a line
Scroll up a line
Overprint character
Tab (8-column)

Line feed

Index entry on/off
Form feed

Carriage return
Normal font
Binding space
Custom printer code
Custom printer code
Underline on/off
Superscript on/off
Subscript on/off
Custom printer code
Strikeout on/off
Italic on/off
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AQ=
AQ<
AQn (0-9)
AQA
AQB
AQC
/\QD
AQDel
AQE

AQF
AQGn

AQGA
AQHn

AQI#
Q)

AQK
AQL

AQM
AQN
AQO

AQP
~QQn
AQR

DESCRIPTION

Go to font tag

Go to style tag

Find marker

Find and replace characters
Move to block beginning
Move to end of file

Move to end of line

Delete line left of cursor
Move to beginning of screen
Find characters

Go to next occurrence of
character n

Go to end of paragraph

Go to previous occurrence of
character n

Go to page/line number
Thesaurus

Move to block end

Check spelling in rest of file
Calculator

Check spelling of word in text

Check spelling of word you
enter

Go to previous position
Repeat keystroke n

Move to beginning of file

COMMAND
AQS

AQTn

AQU

/\QV

/\QW

AQX
AQY
AQZ

AR
AR
ARight Arrow
A8
AT
AlJ
A
AV
"W
AW
AX
Ky
AZ
NE

DESCRIPTION

Move to beginning of line
Delete to n

Reformat rest of file

Go to most recent find/replace
or block

Scroll up continuously, one
line at a time

Move to end of screen
Delete line right of cursor

Scroll down continuously, one
line at a time

Repeat last answer at prompt
Scroll up one screen

Move right one word

Move left one character
Delete word

Abandon changes (dialog box)
Undo last deletion

Insert on/off

Scroll file directory

Scroll up one line

Move cursor down one line
Delete line

Scroll down a line

Scroll file directory
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Dot coMMANDS

COMMAND

.av varname
.aw on/off
bnn

.bp on/off
.cb

.ccn

.Cco n,m

.cpn

e

.cve>e
.cve>f
.cve>f
.cvf>e

LW n

.df filename
.dm message
e# n

.ei

el

f#n
fn(1-5)

Afi filename
fmn

.fne/o
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DESCRIPTION
Unprinted comment
Ask for variable

Auto word wrap
Sheet feeder tray
Bidirectional printing
Column break

Conditional column break
(n=number of lines)

Columns (n=number, m=gutter
size)

Conditional page break
(n=number of lines)

Clear screen for messages
while printing

Print comment as endnote
Print comment as footnote
Print endnote as footnote
Print footnote as endnote
Character width (n/120)
Data file (merge printing)
Display message at print time
Endnote starting value
End If condition

Else condition

Footnote starting value
Footer(s)

Insert file at print time
Footer margin

Footer on even or odd pages

COMMAND
fo

.go top/bottom
.hn (1-5)
.he

.hm n
.hne/o

.hy on/off
.if condition
.ig

Jix

.kr on/off
#d

J#p

J#d/pn
A#d/p n,n

#0

Ja ccc

Jha
dhn
dmn
s n

.ma expression

.mb n

.mtn

DESCRIPTION

Footer

Skip to top/bottom
Header(s)

Header

Header margin
Header on even or odd pages
Hyphenation on/off
If condition
Unprinted comment
Index entry

Kerning

Line numbering continuous
throughout document

Line numbering restarted on
each page

Line number spacing

Place line number n columns
to left of column 1

Turn off line numbering

Language change
(ccc=country code)

Line height automatic leading
Line height

Left margin

Line spacing

Set variable to result of
expression

Bottom margin

Top margin



Dot cOMMANDS (Continued)

COMMAND
.oc on/off
.0j on/off
.0jC

.ojr

.op

p#N

.P# n,x.x.x...
-Or_
PH# XXX

.p#,,C

.p#,,0

.pa

.pcn

.pe
.pf on/off/dis
-P8

pln

.pmn

pnn

.poe/on

DESCRIPTION
Center line(s)
Justification

Center line(s)

Right align

Omit page number

Starting number for paragraph
numbers

Style for paragraph numbers

Options for x:

Z Uppercase letters

z Lowercase letters

| Uppercase roman numerals
i Lowercase roman numerals
9 Numbers starting with O

1 Numbers starting with 1

Switch from outline to
compound numbering

Switch from compound to
outline numbering

Page break

Page number position
(0 = center)

Endnote print position
Reformat at print time
Default page numbering on
Page length

Paragraph margin

Page number

Page offset (even/odd pages)

COMMAND
.pror=l/p
.ps on/off/dis
rmn

apn

rr

v

v

v+

.sb on/off

.srn
.SV
tbn
tb #n
Jde

tc1-9

.uj on/off/dis

.ul on/off

.xe hex code
x| hex code
.xq hex code
xr hex code
xw hex code

xx character

COMMAND REFERENCE

DESCRIPTION
Landscape/portrait orientation
Proportional spacing

Right margin

Repeat printing

Ruler line

Read variable(s)

Read field/dBASE/spreadsheet
variable

Read variable(s), combine with
next .rv

Suppress blank lines at top of
page

Subscript/superscript roll

Set variable

Tab settings

Decimal tab

Table of contents entry

Entries for additional table of
contents

Microjustification

Underline spaces between
words

Custom printer code define
Form feed define

Custom printer code define
Custom printer code define
Custom printer code define

Strikeout define
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COMMANDS FROM THE PULL-DOWN OPENING SCREEN

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
FILE MENU (F) Status EL
Open New F,W Exit WordStar F,X
Open Document F,D UTILITIES MENU (U)

Open Nondocument F,N Index Lul
Print F,P TOC uT
Print from Keyboard F,K Macros UM
Fax F,F ADDITIONAL MENU (A)

Copy F,O MailList AM
Delete FT TelMerge AT
Rename FE Star Exchange AS
Protect/Unprotect F.C HELP MENU (H)

Change Drive/Directory F,V Help H,H
Change Files Displayed F,H Change Help Level H,C
Run DOS Command F,R

COMMANDS FROM THE PULL-DOWN EDITING SCREEN

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
FILE MENU (ALT+F) Change Printer Alt+F,H
Open/Switch Alt+F,W Copy Alt+F,O
Close Alt+F,C Delete Alt+F, T
Save Alt+F,S Rename Alt+F,E
Save As Alt+F,A Change Drive/Directory Alt+F,V
Save and Close Alt+F,L Run DOS Command Alt+F,R
Print Alt+F,P Status Alt+F,U
Fax Alt+F,F Exit WordStar Alt+F,X
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS

EDIT MENU (ALT+E)

Undo

Mark Block Beginning

Mark Block End

Move

Move-Block

Move-Block from Other Window
Copy

Copy-Block

Copy-Block from Other Window
Copy-From Windows Clipboard
Copy-To Windows Clipboard
Copy-To Another File

Delete

Delete-Block

Delete-Word

Delete-Line

Delete-Line Left of Cursor
Delete-Line Right of Cursor
Delete-To Character

Mark Previous Block

Find

Find and Replace

Next Find

Go to Character

Go to Page

Go to Marker

KEYSTROKES

Alt+E,U
Alt+E,B
Alt+E,E
Alt+E,V
Alt+E,V,B
Alt+E,V,0O
Alt+E,C
Alt+E,C,B
Alt+E,C,O
Alt+E,C,F
Alt+E,C, T
Alt+E,C,A
Alt+E,D
Alt+E,D,B
Alt+E,D,W
Alt+E,D, L
Alt+E,D, |
Alt+E,D,R
Alt+E,D, T
Alt+E K
Alt+E,F
Alt+E,R
Alt+E, X
Alt+E,G
Alt+E,P
Alt+E,M

DESCRIPTIONS
Go to Marker-n (0 to 9)

Go to Other

Go to Other-Font Tag

Go to Other-Style Tag

Go to Other-Note

Go to Other-Previous Position
Go to Other-Last Find/Replace
Go to Other-Beginning of Block
Go to Other-End of Block

Go to Other-Document Beginning

Go to Other-Document End

Go to Other-Scroll
Continuously Up

Go to Other-Scroll
Continuously Down

Set Marker
Set Marker-n (0 to 9)

Edit Note
Note Options

Note Options-Starting Number
for Note

Note Options-Convert Note
Note Options-Convert at Print
Note Options-Endnote Location
Editing Settings

Editing Settings-Column Block
Mode

KEYSTROKES

Alt+E,M,n
(0to9)

Alt+E,O
Alt+E,O,F
Alt+E,O, T
Alt+E,O,N
Alt+E,O,P
Alt+E,O,L
Alt+E,O,B
Alt+E,O,E
Alt+E,O,D
Alt+E, 0,0
Alt+E,O,U

Alt+E,O,S

Alt+E,S

Alt+E,S,n
(0to9)

Alt+E,N
Alt+E, T
Alt+E,T,S

Alt+E, T,C
Alt+E, T,P
Alt+E,T,E
Alt+E, |

Alt+E,1,C
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
Editing Settings-Column Alt+E,I,R Variable-Page Alt+l,V,P
Replace Mode Variable-Line Alt+1,V,L
Editing Settings-Auto Align Alt+E,1,A Variable-Filename ALV F
Editing Settings-Closes Dialog Alt+E,1,D Variable-Drive Alt+LV,D
VIEW MENU Variable-Directory Alt+1,V, 1
Preview o Variable-Path Alt+,V,A
Command Tags ATRC Extended Character Alt+1,E
Block Highlighting Alt+V,B Custom Printer Code Alt+l,U
Open/Switch Window Alt+V,0 Custom Printer Code-n (1 to 6) Alt+1,U,n
Change Window Size Alt+V,W (1to 6)
Screen Settings Alt+V,S Custom Printer Code-Other Alt+1,U,0O
INSERT MENU File Alt+l,F
Page Break Alt+],P File at Print Time Alt+l,L
Column Break Alt+l,C Graphic Alt+],G
Today’s Date Value Alt+, T Note Alt+I,N
Other Value Alt+1,A Note-Comment Alt+I,N,C
Other Value-Current Time Alt+,A, T Note-Footnote Alt+I,N,F
Other Value-Last Math Result Alt+,A,M Note-Endnote Alt+1,N,E
Other Value-Last Math Expression Alt+l,A,E Note-Annotation Alt+1,N,A
Other Value-Last Math, as Dollar ~ Alt+I,A L Index/TOC Entry Alt+1,1
Other Value-Current Filename Alt+l,A,F Index/TOC Entry-TOC Entry Alt+1,1,T
Other Value-Current Drive Alt+1,A,D Index/TOC Entry-Index Entry Alt+1,1,1
Other Value-Current Directory Alt+1,A )l Index/TOC Entry-Mark Text Alt+1,1,M
Other Value-Current Path Alt+1,A,A torinder

Variable AlteLV Lr;dTe;t{rOC Entry-Dot Leader Alt+1,1,D
Variable-Date Alt+1,V,D Paragraph Outline Number Alt+1,0
Variable-Time Alt+,V,T Change Printer Codes Alt+l,H
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS

STYLE MENU

Bold

Italic

Underline

Font

Other

Other-Strikeout
Other-Subscript
Other-Superscript
Other-Double Strike
Other-Color/Shading
Select Paragraph Style
Return to Previous Style
Define Paragraph Style
Manage Paragraph Styles

Manage Paragraph Styles-
Copy Style to Library

Manage Paragraph Styles-
Delete Library Style

Manage Paragraph Styles-
Rename Library Style

Manage Paragraph Styles-
Rename Document Style

Convert Case
Uppercase
Lowercase
Sentence Case

Settings

KEYSTROKES

Alt+S,B
Alt+S,1
Alt+S,U
Alt+S,F
Alt+S,0
Alt+S,0,S
Alt+S,0,B
Alt+S,0,P
Alt+S,0,D
Alt+S,0,C
Alt+S,S
Alt+S,R
Alt+S,D
Alt+S,M
Alt+S,M,C

Alt+S,M,D

Alt+S,M,R

Alt+S,M,E

Alt+S,C
Alt+S,C,U
Alt+S,C,L
Alt+S,C,S
Alt+S,E

DESCRIPTIONS
LAYOUT MENU
Center Line

Right Align Line

Ruler Line

Columns

Page

Headers/Footers
Headers/Footers-Header
Headers/Footers-Footer
Page Numbering

Line Numbering
Alignment and Spacing
Special Effects

Special Effects-Overprint
Character

Special Effects-Overprint Line
Special Effects-Optional Hyphen

Special Effects-Vertically Center
Text on Page

Special Effects-Keep Words
Together on Line

Special Effects-Keep Lines
Together on Page

Special Effects-Keep Lines
Together in Column

UTILITIES MENU
Spelling Check Global
Spelling Check Other

KEYSTROKES

Alt+L,C
Alt+L,1
Alt+L,R
Alt+L,O
Alt+L,P
Alt+L,H
Alt+L,H,H
Alt+L,H,F
Alt+L,N
Alt+L,L
Alt+L,A
Alt+L,E
Alt+LE,C

Alt+L,E L
Alt+L,E,H
Alt+L,E,V

Alt+L,E, K

Alt+L,E,P

Alt+L,E,O

Alt+U,S
Alt+U,O
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
Spelling Check Other-Rest Alt+U,O,R Merge Print Commands- Alt+U,P,S
of Document Set Variable
Spelling Check Other-Word Alt+U,O,W Merge Print Commands- Alt+U,P,V
Set Variable to Math Result
Spelling Check Other-Type Word ~ Alt+U,O,T el Variable fo Math Resu
. Merge Print Commands- Alt+U,P,A
Spelling Check Other- Alt+U,O,N Adk B Variahile
Rest of Notes
M Print C ds-If Alt+U,P,1
Thesaurus Alt+U, T erge Frint Lommands *
M Print C ds-El Alt P,L
Language Change Alt+U,L erge Frint L-ommands-tise ELLF,
Merge Print Commands-End If Alt+U,P,E
Inset Alt+U, |
Merge Print Commands- Alt+U,P,T
Calculator AlteU,C Go to Top of Document
Block Math Alrgll, B Merge Print Commands- Alt+U,P,B
Sort Block Alt+U, K Go to Bottom of Document
Sort Block-Ascending Alt+U, KA Merge Print Commands- Alt+U,P,C
. Clear Screen While Printing
Sort Block-Descending Alt+U,K,D
| Merge Print Commands- Alt+U,P,M
Word Count Alt+U W Display Message
Macros Alt+U,M Merge Print Commands- Alt+U,P,R
Macros-Play Alt+U,M,P Print File n Times
Macros-Record Alt+U,M,R Reformat Alt+U,R
Macros-Edit/Create Alt+U,M,E Reformat-Rest of Document Alt+U,R,R
Macros-Single Step Alt+U,M,S Reformat-Paragraph Alt+U,R,P
Macros-Copy Alt+U,M,C Reformat-Rest of Notes Alt+U,R,N
Macros-Delete Alt+U,M,D Repeat Next Keystroke Alt+U,E
Macros-Rename Alt+U,M,N HELP MENU
Merge Print Commands Alt+U,P Help Alt+H,H
Merge Print Commands-Data File  Alt+U,P,D Change Help Level Alt+H,C
Merge Print Commands-Name Alt+U,P,N
Variables
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COMMAND REFERENCE

COMMANDS FROM THE SYSTEM PROMPT

To use the following commands, your DOS path should include the WordStar directory. If it
doesn’t, you need to log on to that directory.

COMMAND
wS§

ws filename

ws filename /n
ws filename /d
ws filename /s
ws filename /p

ws filename /x

ws filename /p /x

ws filename /o nnn

ws filename /hn

ws filename /m macroname

ws /m macroname

DESCRIPTION
Starts WordStar and goes to the Opening Menu.

Starts WordStar and opens the file filename in document mode unless the
default has been changed to nondocument.

Starts WordStar and opens the file filename in nondocument mode.
Starts WordStar and opens the file filename in document mode.
Starts WordStar and opens a new file with no filename.

Starts WordStar and prints the file filename.

Starts WordStar, opens the file, and exits WordStar upon returning to the
Opening screen. (Use x with another option; see next example.)

Starts WordStar, prints the file filename, and exits to DOS.

Starts WordStar, opens the file, and goes to the decimal location nnn.
Starts WordStar, opens the file, and sets the help level at n.

Executes the named macro from inside the file filename.

Plays the named macro from the Opening screen.
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... (view comment lines), 8 ASC256.PDF, 40
? command (Opening Menu), 31, 46 ascending sort order ("KZA), 44
\ command (Opening Menu), 20 ASCll files, 2, 6, 17, 40
A\ (clear screen), 6 ASCII.PDF, 40
ask for variable command (.av), 33
A AT command (Opening Menu), 48

auto align text (*OA and .aw), 2
AA (move left one word), 10, 11 auto-hyphenation (*OH), 23-24
abandon changes to file and quit (*KQ), 19, 43 v (ask for variable), 33

accent marks. See international characters -aw (auto align text), 2
Additional pull-down menu

MailList command, 29 B

Star Exchange command, 46

TelMerge command, 48 AB (reformat rest of paragraph), 41
advanced page preview. See preview background printing, 39
align text Backspace key (delete previous character,

auto align (*OA and .aw), 2 space, or command tag), 14

rest of document (*"QU), 21, 41 backup files (.BAK), 2, 43

rest of paragraph (*B), 41 BBS. See bulletin boards

right-align using O], 1 beginning of block

right-align using ~OJ, 26 mark (*KB), 3

using NOS, 1 move to ("QB), 12

See also justify text beginning of file, move to (*QR or AHome), 11
Alignment and Spacing command (Layout beginning of line, move to (*QS), 11

pull-down menu), 1, 5, 23-24, 26, 27, beginning of screen, move to (*"QE or
28, 51 Home), 11

Alignment and Spacing dialog box, 1 bidirectional printing (.bp), 2-3
alphabetize. See sort block bin number, 37
AM command (Opening Menu), 29 binding space (*PO), 3
ampersand (&), and variable names, 34 blank lines, 3, 15, 48
annotations. See footnotes and endnotes block commands, 3-4
arithmetic. See math column block mode (*KN), 4, 7
arrow keys, 11 column replace mode (~Kl), 4, 7
AS command (Opening Menu), 46 convert block to lowercase ("K’), 4, 5
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block commands (continued)
convert block to uppercase (*K"), 4, 5
convert first letter of block sentences to

uppercase ("K.), 4, 5
copy between windows (*KA), 4, 9, 51
copy from clipboard (*K[), 4, 6, 9
copy to another file ("\KW), 2, 3, 9
copy to clipboard (K1), 4, 6, 9
copy ("KC), 3,9
delete (AKY), 3, 15
display/hide block markers (highlighting)
(AKH), 3

insert block into document (*KR), 3, 24
mark (A"KB and ~AKK), 3
mark previous block (*"KU), 4
math (A"KM), 4
move ("KV), 3
move between windows (*"KG), 4
move to beginning of block (*QB), 12
move to end of block (*QK), 12
move to most recent block (*Q=), 12
read block into file (*KR), 3, 24
sort ("KZ), 4, 44
unmark (MK<), 4
in windows, 4
word/byte count (*K?), 4, 51
write block to file ("\KW), 2, 3, 9

bold text (APB), 4, 18

bottom margin. See margins

box drawing, 27
See also graphics

.bp (bidirectional printing), 2-3

bulletin boards, 48

byte count (*K?), 4, 51

C

C command (Opening Menu), 41

AC (scroll down a screen), 10, 12
calculations. See math

calculator (*QM), 5

cancel changes to file and quit (*KQ), 19, 43
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cancel command. See undo (AU)
carriage returns, 5, 15, 27
case conversion, 4, 5
.cb (column break), 8
center text, 1, 5-6, 50
centimeter, as unit of measurement, 50
chaining files, 8, 35
Change Drive/Directory command (File
pull-down menu), 28
Change Filename Display (Opening Menu), 16
changing. See editing
characters
delete (G or Del), 14
delete previous (*H or Backspace), 14
move left one character (AS), 10, 11
move right one character (AD), 10, 11
move to next occurrence of specified
character (*QG), 12
move to previous occurrence of specified
character (*QH), 12
charts. See columns
classic commands on pull-down menus,
display/hide, 6, 17, 43
classic menus, 32
See also Opening Menu
clear screen, 6, 33
clipboard, 4, 6, 9
close
dialog boxes, 16
files, 19, 43
windows, 49
color, printing in (AP-), 7
column block mode (*KN), 4, 7
column breaks (.cb), 8
column replace mode (~Kl), 4, 7
columns, 4, 7,8, 11
.COM filename extension, 20
command files, 8
command tags, 14, 16-17, 20-21
comment lines, 8, 12, 45
communications. See TelMerge
conditional merge print dot commands, 32



continuous underlining (.ul), 49

contracts. See merge printing; paragraph
outline numbering

convert case. See case conversion

convert files, 9, 46

copy
block between windows (AKA), 4, 9

block from clipboard (*K[), 4, 6, 9
block to another file ("\KW), 3, 9
block to clipboard (*K]), 4, 6, 9
block within same window (*KC), 3, 9
file (AKO), 9
macro (*MO), 28
paragraph style to library (*\OFQ), 37
create
ASClI files, 2,17
data files, 14
document files, 17, 45
footnotes/endnotes (*\ON), 21-22
graphics, 20, 22
index entries (\ONI), 24
macros ("MD), 28
nondocument files, 2, 17
paragraph styles (*\OFD), 37
table of contents, 48
.cs (clear screen), 33
cursor, 9
cursor diamond, 10
cursor movement, 11-13, 15
custom print controls. See custom printer codes
custom printer codes, 13
customize WordStar, 13

D

D command (Opening Menu), 17
AD (move right one character), 10, 11
data files, 14, 33
databases
converting files, 9, 46
and merge printing, 32
using data files from, 14

date, merge printing predefined variable for, 34
dBASE. See databases
decimal tabs, 14, 48
defaults, 14, 50
Define Paragraph Style command (Style
pull-down menu), 37
Del key, 14, 15
delays, 14
delete, 14-15, 28, 37
See also undo (AU)
descending sort order (*KZD), 44
.df (define data file), 33
dialog boxes, 15-16
See also specific dialog boxes by name
dictionaries, foreign language, 26
directories, 16, 28, 34
disk drive, logged, 28, 34
disk files. Seefiles
display
block markers (AKH), 3
classic commands on pull-down menus
("OB), 6,17, 43
command tags (*OD), 16-17, 21
directories, 16
dot commands (*OD), 16-17, 43
extended character set, 19
flag column (*OD), 16-17, 21, 43
international characters, 25
messages while printing (.dm), 33
notes (\OND), 8
RAM usage (O?), 31, 46
ruler line (*OB), 17, 42, 43
screen settings (*OB), 6, 16-17, 21, 42,
43-44, 46, 47
scroll bar (*OB), 17, 43, 44
soft space dots ("OD), 16-17, 43, 44
status line (*OB), 17, 43, 46
status screen (*O?), 31, 46
style bar (*OB), 17, 43, 47
two files at same time, 51
.dm (display message while printing), 33
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document files, 17
See also files
dollar amount, insert block math results as
("M$), 4
DOS, run a DOS command (AKF), 42—43
DOS text files. See ASCII files
dot commands
auto align text (.aw), 2
center text (.0jc), 5-6
clear screen (.cs), 33
column break (.cb), 8
command files for, 8
comment lines (.igor ..), 8
delete dot command line (2Y), 15
display/hide (*OD), 16-17, 43
for headers and footers, 23, 30
kerning (.kr), 26
language change (.la), 26
line numbering (.1#), 27
for margins, 29, 30, 31
for merge printing, 32-33
microjustification (.uj), 26, 35
overview of, 17
page break (.pa), 22, 36
page offset (.po), 30
paragraph outline numbering (.p#), 37
for printing,
bidirectional printing (.bp), 2-3
custom printer codes, 13
define form feed string (.xl), 22
endnote at specific location (.pe), 21-22
insert file at print time (.fi), 8, 24, 35
for merge printing, 32-33
message display while printing
(.dm), 33
strikeout text (.xx), 47
subscript/superscript roll (.sr), 47
table of contents entry (.tc), 48
underline space and words (.ul), 49
word wrap (.aw), 51
double spacing. See line spacing
double strike (APD), 4, 18
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double words, spelling check, 45
down, move cursor down, 10, 12
Down Arrow, move down a line, 12
DRAFT.PDF, 40
drawing, 27

See also graphics
drive, logged, 28, 34

E

E command (Opening Menu), 42
AE (move up a line), 10, 11
Edit pull-down menu
Copy command, 2, 3, 4, 6, 51
Delete command, 3
Editing Settings command, 2, 4, 7
Find and Replace command, 20-21
Find command, 20
Go to Marker command, 31
Mark Block Beginning command, 3
Mark Block End command, 3
Move command, 3, 4
Next Find command, 20-21
Note Options command, 21
Set Marker command, 31
Undo command, 50
editing
insert/overtype mode toggle (MV), 25
macros ("MD), 28
notes (*\OND), 8
overview of, 18
paragraph styles (*\OFD), 37
print file while editing (*KP), 39
rename file while editing (*KE), 42
run DOS command while editing (*KF), 43
save file and resume editing (*KS), 18, 43
two files at same time, 51
.ei (END IF condition), merge printing, 32
.el (ELSE condition), merge printing, 32
electronic bulletin boards, 48
electronic mail. See TelMerge
Email. See TelMerge



EMS, 18
End (move to end of screen), 12
AEnd (move to end of file), 12
END IF condition (.ei), merge printing, 32
end of block

mark (AKK), 3

move to (*QK), 12
end of file, move to (*QC or ~End), 12
end of line, move to (*QD), 11
end of paragraph, move to *QG Enter), 12
end of screen, move to (*QX or End), 12
endnotes. See footnotes and endnotes
Enter key, 3, 5

See also carriage returns
envelopes, printing, 18-19
erase. See delete
even pages, 23, 30
.EXE file extension, 20
exit document or WordStar, 19, 43

See also abandon changes to file and quit;

stop repeating a command

Expanded Memory Specification (EMS), 18
extended character set, 19

F

F command (Opening Menu), 16
AF (move right one word), 10, 11
F1 (help), 23
f1...5 (footer commands), 23
F10 (save dialog box settings), 16
fax files, 20
fi (insert file at print time), 8, 24, 35
File pull-down menu
Change Drive/Directory command, 28
Change Filename Display, 16
Close command, 19, 43
Copy command, 9
Exit WordStar command, 19
Fax command, 20
New command, 17, 45
Open Document command, 17

INDEX

File pull-down menu (continued)
Open Nondocument command, 2, 17
Print command, 39, 40
Print from Keyboard command, 40
Protect/Unprotect command, 41
Rename command, 42
Run DOS Command command, 42
Save and Close command, 19, 43
Save As command, 19, 42, 43
Save command, 43
Status command, 31, 46

filenames, 20, 34, 42

files
abandon changes and quit file (*KQ),

19, 43
backup files, 2, 43
chain, 8, 35
close, 19, 43
command files, 8
convert, 9.46
copy (*KO), 9
create, 17, 45
data files, 14, 33
delete (*KJ), 15
document files, 17
fax files, 20
insert file at print time (.fi), 8, 24, 35
insert file into document (*KR), 3, 24, 45
insert graphics into, 22
managing, 40
naming, 20, 34, 42
nest, 8, 35
nondocument files, 2, 17
open, 17
printing to, 40
protect, 41
renaming, 42
temporary files, 49
word/byte count of (*K?), 51
See also save
Find dialog box, 20
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find text or command tags (*QF), 12, 20-21,
31,45
first line indent, 29
flag column, 16-17, 21, 43
.fm (footer margin), 30
.fo (footer), 23
fonts
choose with AP=, 21
find font tag (*Q=), 12
laser fonts, 28
pitch of, 38
proportional fonts, 41
footers. See headers and footers
footnotes and endnotes
create (\ON), 21-22
delete (*G or Del), 15
display (*\OND), 8
edit ("\OND), 8
find (\ONG), 12
print endnote at specific location (.pe),
21-22
spelling check for (*\ONL), 45
foreign characters. See international characters
foreign languages, changing (.la), 26
form feeds (APL), 22
form letters. See MailList; merge printing
format files. See merge printing
formatting
reformat text, 41
variable formatting for printing, 33-34
See also align text
function keys, 22
See also individual function key entries

G

AG (delete character, space, command tag,
carriage return, or note), 14, 15

global find and replace. See replace text or
command tags

go to. See cursor movement; find text or
command tags
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Go to Marker command (Edit pull-down
menu), 31
graphics, 20, 22
See also drawing

H

AH (delete previous character, space, or
command tag), 14
.h1...5 (header commands), 23
hanging indent, 22
hard carriage returns. See carriage returns
hard page breaks. See page breaks
hardware failures, and saving files, 18
.he (header), 23
Header and Footer dialog boxes, 23
headers and footers, 23-24, 30
height of lines, 27
help, 23
Help pull-down menu, 23
Hewlett-Packard Laserjet Printer, fonts for, 28
hide
block markers (*KH), 3
classic commands on pull-down menus
(7OB), 6,17,43
command tags (*OD), 16-17, 21
dot commands (*OD), 16-17, 43
flag column (*OD), 16-17, 21, 43
ruler line (*"OB), 17, 42, 43
screen settings (*OB), 6, 16-17, 21, 42,
43-44, 46, 47
scroll bar (*OB), 17, 43, 44
soft space dots (*OD), 16-17, 43, 44
status line (*OB), 17, 43, 46
style bar (*OB), 17, 43, 47
highlighting, block (*KH), 3
.hm (header margin), 30
Home (move to beginning of screen), 11
AHome (move to beginning of file), 11
horizontal spacing. See margins
hyphenation, 23-24



[ command (Opening Menu), 24
Al (move to next tab stop), 7
IBM 4019/4029, fonts for, 28
[if (IF condition), merge printing, 32
.ig (view comment lines), 8
import. See insert, file into document
inch, as unit of measurement, 50
indentation, 22, 24, 29
indexing, 24
Ins key (insert/overtype mode on/off), 25
insert
blank lines in document (AN or Enter), 3
block into document (*KR), 3
custom printer codes, 13
extended characters, 19
file at print time (.fi), 8
file into document (AKR), 3, 24
graphics into document, 22
hard carriage return ("M), 27
headers and footers, 23
last math expression (*"M#), 5
last math result ("M=), 4
last math result as dollar (*M$), 4
line feeds (7P)), 27
marker (MK 0-9), 31
page break (.pa), 22, 36
text, 25
toggle insert/overtype mode (AV), 25
Insert pull-down menu
Column Break command, 8
Custom Printer Code command, 13
Extended Character command, 19
File at Print Time command, 8, 35
File command, 3, 24, 45
Graphic command, 22
Index/TOC Entry command, 24, 48
Note command, 8, 21
Other Value command, 4, 5
Page Break command, 22, 36
Paragraph Outline Number command, 37

INDEX

Inset, 22, 46
install WordStar, 25, 52

See also customize WordStar
international characters, 19, 25
interrupt. See pause
italic text (APY), 25

J

justify text
and auto align (.aw), 2
microjustification (.uj), 26, 35
using "OJ, 26
using NOS, 1
See also align text

K

K command (Opening Menu), 40

AK (save dialog box settings), 16

AK" (convert block to uppercase), 4, 5

AK' (convert block to lowercase), 4, 5

AK< (unmark block), 4

AK. (convert first letter of block sentences to
uppercase), 4, 5

AK 0-9 (insert marker), 31

AK? (word/byte count of block or file), 4, 51

AK[ (copy block from clipboard), 4, 6, 9

AK\ (create fax file), 20

AK] (copy block to clipboard), 4, 6, 9

KA (copy block between windows), 4, 9, 51

AKB (mark block beginning), 3

AKC (copy block), 3,9

AKD (save file, go to Opening screen), 19, 43

AKE (rename file), 42

kerning (.kr), 26

keyboard, printing from, 40

AKF (run a DOS command), 42

AKG (move block between windows), 4

AKH (display/hide block markers), 3

AKI (column replace mode), 4, 7
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AKJ (delete file), 15

AKK (mark block end), 3

AKL (logged drive and directory), 28

AKM (block math), 4

AKN (column block mode), 4, 7

AKO (copy file), 9

AKP (print file while editing), 39, 40

AKQ (quit file and abandon latest changes),
19,43

kr (kerning), 26

AKR (insert file into document), 3, 24

AKS (save file and resume editing), 18, 43

AKT (save and name afile), 19, 42, 43

AKU (mark previous block), 4

AKV (move block), 3

AKW (write block to file), 2, 3,9

AKX (save file and exit WordStar), 19, 43

AKY (delete block), 3, 15

AKZ (sort block), 4, 44

L

L command (Opening Menu), 28
AL (repeat previous find/replace), 20-21
# (line numbering), 27
.la (change language), 26
labels, mailing. See MailList; merge printing
landscape mode, 26
languages, change (.la), 26
laser printers, 28, 37
See also printers
Layout pull-down menu
Alignment and Spacing command, 1, 5,
23-24, 26, 27, 28, 51
Center Line command, 5
Columns command, 8
Headers/Footers command, 23
Page command, 26, 30, 31, 48
Page Layout command, 37
Page Numbering command, 36
Right Align Line command, 1

74

Layout pull-down menu (continued)
Ruler Line command, 7, 14, 24, 29, 30,
42,48
Special Effects command, 3, 23-24, 36, 50
leading, 27
left, move cursor to, 10, 11
Left Arrow, move left one character, 11
ALeft Arrow, move left one word, 11
left margin. See margins
legal pleading paper, 27
library paragraph styles, 37
line feeds (~P)), 27
line height, 27
line number
goto ("QI), 12
merge printing predefined variable for, 34
line numbering (.1#), 27
line spacing, 1, 3, 28
line unit, as unit of measurement, 50
lines
center, 5-6
delete, 15
draw, 27
move down a line (X or Down Arrow), 10,
12, 44
move to beginning of line (*QS), 11
move to end of line (*QD), 11
move up a line (*E or Up Arrow), 10, 11, 44
overprint (APJ), 36
See also blank lines3
.Im (left margin), 30
local paragraph styles. See paragraph styles
locate. See find text or command tags
logged drive and directory, 28, 34
Lotus 1-2-3. See spreadsheets
lowercase conversion, 4, 5
LSRFONTS, 28

M

AM# (insert last math expression), 5
AMS (insert last math result as dollar), 4, 5



AM= (insert last math result), 4, 5
.ma (set variable to math result), 33
macros, 28-29, 49
mailing labels. See merge printing
MailList, 14, 29, 32
MailMerge. See merge printing
Manage Paragraph Styles command (Style
pull-down menu), 37
managing files, 40
margins, 29-31
bottom margin (.mb), 31
described, 29
headers and footers, 30
left margin,
align text at, 1
described, 30
first line indent, 29
indentation and, 24, 29
set using .Im, 30
set using ~OL, 30, 42
page offset, 30
paragraph margin (.pm), 29
right margin,
align text at using ~OJ, 1
align text at using ~O)J, 26
described, 30
ragged, 26
set using .rm, 30
set using ~OR, 30, 42
top margin (.mt), 31
mark
block (*KB and ~KK), 3
index entry (APK), 24
unmark block (*KU), 4
markers
display/hide (*KH), 3
find (*Q 0-9), 12, 31
insert (*Q 0-9), 31
master documents. See merge printing
math, 4, 5, 33
.mb (bottom margin), 31
MCI Mail, 48

INDEX

AMD (edit/create macro), 28
measurement units, 50
AME (rename macro), 28
memory, display usage (*O?), 31, 46
menu bar, 32
menus, 32
See also pull-down menus; specific menus
by name
merge printing, 32-34, 40
messages
display while printing (.dm), 33
on title bar, 49
microjustification (.uj), 26, 35
AMO (copy macro), 28
monitor, install, 52
mouse, 35, 44, 47, 49
move
block between windows (AKG), 4
block within same window (*KV), 3
See also cursor movement; switch between
windows
AMP (play macro), 28, 29
AMR (record macro), 28
AMS (single step macro), 28, 29
.mt (top margin), 31
AMY (delete macro), 28

N

N command (Opening Menu), 2, 17
AN (insert blank line), 3
name variables command (.rv), 33
naming
files, 20, 34, 42, 43
macros ("ME), 28
paragraph styles, 37
nesting files, 8, 35
New command (File pull-down menu), 17, 45
newspaper-style columns (*OU), 8
Next Find command (Edit pull-down menu),
20-21
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next occurrence of specified character
(AQG), 12

next page, move to (*QIl+ Enter), 12

next tab stop, move to, 7, 24

nondocument files, 2, 17

See also ASClI files; data files; files

Note command (Insert pull-down menu), 8, 21

Note Options command (Edit pull-down
menu), 21

notes. See comment lines; footnotes and
endnotes

numbering. See line numbering; page numbers;
paragraph outline numbering

numbers, variable formatting for, 34

o

O command (Opening Menu), 9

AO# (page numbering), 36

AO? (display status screen), 31, 46

AO] (right-align line), 1

AOA (auto align text), 2

OB (display/hide screen settings), 6, 1617,
21,42,43-44, 46, 47

AOC (center text horizontally), 5-6

~OD (display/hide command tags), 16-17, 21

odd pages, 23, 30

AOE (soft hyphen), 23-24

AOF (paragraph styles), 37

AOH (auto-hyphenation), 23-24

AOI (set tab stops), 7, 14, 24, 42, 48

AQJ (justify text), 26

.0jc (center text), 5-6

AOK (open/switch between windows), 13, 51

AOL (left margin), 24, 29, 30, 42

AON (create notes), 21-22

AONA (create annotation), 21-22

~AONC (enter nonprinting comment lines), 8

AOND (view or edit notes), 8

AONE (create endnote), 21-22

AONF (create footnote), 21-22

AONG (find note), 12
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AONI (create index entry), 24
AONL (check spelling in notes), 45
onscreen calculator ("\QM), 5
AOP (preview), 39
open

files, 17

windows (*OK), 13, 51
Opening Menu, 32

? command, 31, 46

\ command, 20

AM command, 29

AS command, 46

AT command, 48

C command, 41

D command, 17

E command, 42

F command, 16

| command, 24

K command, 40

L command, 28

M command, 28

N command, 2, 17

O command, 9

P command, 39, 40

R command, 42

S command, 17, 45

T command, 48

X command, 19

Y command, 15
AOR (right margin), 30, 42
AOS (alignment and spacing), 1, 27, 28
Other command (Style pull-down menu), 7

18, 47
Other Value command (Insert pull-down
menu), 4, 5

AOU (newspaper-style columns), 8
outlining, 29, 37
AQV (center text vertically), 50
overprint characters (*PH), 36
overprint line (APJ), 36
overprint with strikeout (*PX or .xx), 47
overtype/insert mode toggle (AV), 25
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AOY
header and footer margins, 30
landscape/portrait mode on/off, 26
page offset, 30
paper bin number, 37
suppress blank lines, 48
top and bottom margins, 31

AOZ (paragraph outline numbering), 37

P

P command (Opening Menu), 39, 40
AP (overprint line), 36
AP! (insert custom printer code), 13
.p# (paragraph outline numbering), 37
AP& (start Inset from within WordStar), 22
AP* (import graphic images), 22
AP- (print in color or shading), 7
AP= (choose font), 21
APO (extended character set), 19
.pa (insert page break), 22, 36
page
delete, 15
go to specified (*QI), 12
odd and even pages, 23, 30
suppress blank lines at top of (*QY), 48
page breaks, insert (.pa), 22, 36
Page command (Layout pull-down menu), 26,
30, 31, 48
Page Down/Up. See PgDn; PgUp
Page Layout command (Layout pull-down
menu), 37
Page Numbering dialog box, 36
page numbers, 12, 34, 36
page offset, 30
See also margins
page preview. See preview
Page Up/Down. See PgDn; PgUp
paper bin number, 37
paragraph outline numbering, 37
paragraph styles (*OF), 6, 14, 37

INDEX

paragraphs
delete (*QT Enter), 15
indent, 22, 24, 29
margins, 29
move to end of paragraph (*QG Enter), 12
numbering, 37
reformat rest of paragraph (*B), 41
paths, 34, 38
pause
before executing instruction, 14
printing (*PC), 38
printing and ask for variable (.av), 33
APB (bold text), 4
APC (pause printer), 38
.PCX graphic format files, 20
APD (double strike), 18
PDFEDIT, 38
PDFs. See printer description files (PDFs)
.pe (print endnote at specific location), 21-22
APE (insert custom printer code), 13
APF (insert custom printer code), 13
APG (insert custom printer code), 13
PgDn (scroll down a screen), 12
APgDn (scroll down a line), 12
PgUp (scroll up a screen), 11
APgUp (scroll up a line), 11
APH (overprint character), 36
phantom characters, 13
pitch, 38
APJ (insert line feed), 27
APK (mark index entry), 24
APL (form feed), 22
place markers. See markers
play macro (*MP), 28, 29
pleading paper, legal, 27
.pm (paragraph margin), 29
.po (page offset), 30
APO (binding space), 3
point, as unit of measurement, 50
portrait mode, 26
ports, 38
PostScript printers, fonts for, 28
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pound sign (#), and decimal tabs, 48
power failures, and saving files, 18
APQ (insert custom printer code), 13
APR (insert custom printer code), 13
PRCHANCGE, 13, 39
preview (AOP), 39
See also printing, to disk
previous occurrence of specified character,
move to (*QH), 12
previous page, move to (*QI- Enter), 12
previous paragraph style, return to (*OFP), 37
Print dialog box, 38, 40
printer codes, custom, 13
printer description files (PDFs)
add custom printer codes to, 13
change, 38
described, 39
DRAFT.PDF, 40
for printing to disk, 40
printer drivers. See printer description
files (PDFs)
printers
custom printer codes, 13
default settings, 39
display default printer (*O?), 46
install, 52
laser fonts, 28
paper bins, 37
ports, 38
printing
background printing, 39
bidirectional printing (.bp), 2-3
bold text, 4, 18
in color or shading (AP-), 7
envelopes, 18-19
and exiting WordStar, 19
extended character set, 19
files, 39
files while editing (*KP), 39
insert file at print time (.fi), 8, 24
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printing (continued)
international characters, 25
italic text, 25
from keyboard, 40
in landscape mode, 26
line feeds (AP)), 27
merge printing, 32-34, 40
message display while (.dm), 33
overprinting, 36, 47
page numbers, 36
pause printing (*PC), 38
pause printing and ask for variable (.av), 33
in portrait mode, 26
to disk, 40
See also fonts; line height; line spacing;
margins; page offset
ProFinder, 40
program files. See nondocument files
proportional spacing, 41
proposals, and paragraph numbering, 37
protect files, 41
PRVIEW.PDF, 40
APS (underline text), 49
APT (superscript), 47
pull-down menus, 32
display/hide classic commands on, 6,
17,43
See also specific pull-down menus by name
APV (subscript), 47
APW (insert custom printer code), 13
APX (strikeout text), 47
APY (italic text), 25

Q

AQ 0-9 (find marker), 12, 31

AQ= (find font tag), 12

AQA (find and replace text or command tags),
12, 20-21

AQB (move to beginning of block), 12




AQC (move to end of file), 12

AQD (move to end of line), 11

AQ Del (delete line left of cursor), 15

"QE (move to beginning of screen), 11

AQF (find text or command tags), 13, 20

QG (move to next occurrence of specified
character), 12

QG Enter (move to end of paragraph), 12

~AQH (move to previous occurrence of specified
character), 12

QI (go to specified page/line number), 12

AQ) (thesaurus), 49

QK (move to end of block), 12

QL (check spelling in part or all of
document), 45

AQM (calculator), 5

AQN (check spelling of a word), 45

QO (check spelling of a word not in
document), 45

AQQ (repeat a command), 42

AQQAC (scroll continuously down, one screen
atatime), 12

AQQ”R (scroll continuously up, one screen at a
time), 11

AQR (move to beginning of file), 11

AQS (move to beginning of line), 11

AQT (delete to specified character), 15

QU (align rest of document), 21, 41

Quattro. See spreadsheets

quit file and abandon changes (*KQ), 19, 43

See also exit document or WordStar; stop
repeating a command

AQV (move to most recent find/replace or
block), 12

AQW (scroll continuously up, one line at a
time), 11

AQX (move to end of screen), 12

QY (delete line right of cursor), 15

AQZ (scroll continuously down, one line at a

time), 12

R

R command (Opening Menu), 42
AR
restore information, 16
scroll up a screen, 10, 11
ragged right margin, 26
RAM, display usage ("O?), 31, 46
read block into file (*KR), 3, 24
README, 41
realign text. See align text
record macro (*MR), 28
reform text. See align text; formatting
refresh screen, 6, 33
remove. See delete
renaming
files, 42, 43
macros (*ME), 28
paragraph styles, 37
See also naming
repeat
a command (*QQ), 42
previous find/replace (L), 20-21
replace text or command tags (*QA), 12, 20-21
restore deleted text (AU), 50
restore information in dialog boxes (*R), 16
Return key. See Enter key
Return to Previous Style command (Style
pull-down menu), 37
right, move cursor to, 10, 11
right-align text, 1, 26
Right Arrow, move right one character, 11
ARight Arrow, move right one word, 11
right margin. See margins
.rm (right margin), 30
ruler line
described, 42
display/hide (*OB), 17, 42, 43
indentation and, 24, 29, 42
margins and, 30, 42
tab stops and, 7, 14, 42, 48
Ruler Line dialog box, 24




INDEX

run DOS command (AKF), 42-43
.rv (name variables), 33

S

S command (Opening Menu), 17, 45
AS (move left one character), 10, 11
save
backup file automatically, 2
dialog box settings, 16
file and abandon latest changes (*KQ),
19, 43
file and exit WordStar (AKX), 19, 43
file and go to Opening screen (*KD), 19, 43
file and name file (*KT), 19, 42, 43
file and resume editing (*KS), 18, 43
screen
clear, 6, 33
display/hide screen settings (*OB), 6,
16-17, 21, 42, 43-44, 46, 47
move to beginning of (*QE or Home), 11
move to end of (*QX or End), 12
scroll down a screen (AC or PgDn), 10,
12, 44
scroll down continuously, one screen at a
time (*\QQAC), 12
scroll up a screen (~R or PgUp), 10, 11, 44
scroll up continuously, one screen at a time
(MQQAR), 11
Screen Settings dialog box, 17, 43
scroll bar, 17, 43, 44
scrolling, 10, 11, 12, 44
search. See find text or command tags
Select Paragraph Style command (Style
pull-down menu), 37
sentences
convert first letter of block sentences to
uppercase (*K.), 4, 5
delete sentence (*QT.), 15
Set Marker command (Edit pull-down menu), 31
set variable command (.sv), 33-34
set variable to math result command (.ma), 33
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Settings command (Style pull-down menu),
47,49
shadings, printing in (AP-), 7
sheet feeders, 37
shorthand macros. See macros
show. Seedisplay
single spacing. See line spacing
single step macro (*MS), 28, 29
slowing down scrolling, 11, 12
snaking columns. See newspaper-style columns
soft carriage returns, 5
soft hyphens, 23-24
soft spaces, 16-17, 43, 44
sort block (*KZ), 4, 44
Spacebar, 16, 42
spaces
binding space (*PO),3
delete previous space (*H or
Backspace), 14
delete space (*G or Del), 14
soft spaces, 16-17, 43, 44
underlining (.ul), 49
spacing. See line height; line spacing; margins
Special Effects command (Layout pull-down
menu), 3, 23-24, 36, 50
Speed Write, 45
speeding up scrolling, 11, 12
spelling check, 26, 45
spreadsheets
converting files, 9, 45, 46
and merge printing, 32
using data files from, 14, 45
.sr (set roll for subscript/superscript), 47
Star Exchange, 9, 45, 46
start WordStar, 46
status line, 17, 43, 46
status screen (~O?), 31, 46
stop repeating a command (Spacebar), 42
See also abandon changes to file and quit;
exit document or WordStar
strikeout text (APX or .xx), 47
style bar, 17, 43, 47




Style pull-down menu
Bold command, 4
Convert Case command, 4, 5
Define Paragraph Style command, 37
Font command, 21
Italic command, 25
Manage Paragraph Styles command, 37
Other command, 7, 18, 47
Return to Previous Style command, 37
Select Paragraph Style command, 37
Settings command, 47, 49
Underline command, 49
style sheets. See paragraph styles
subscript ("\PV), 47
superscript (MPT), 47
.sv (set variable), 33-34
switch between windows (*OK), 13, 51
Symphony. See databases; spreadsheets
synonyms (*Q)J), 49

T

INDEX

top of page, suppress blank lines at (*QY), 48
translate files. See convert files

triple spacing. See line spacing

typefaces. See fonts

typewriter mode, 40

U

T command (Opening Menu), 48
AT (delete word or carriage return), 15
Tab key, 7, 15, 24
table. See columns
table of contents, 48
tabs
decimal tabs, 14, 48
move to next tab stop (Tab or *\I), 7
set tabs, 7, 14, 24, 42, 48
.tc (table of contents entry), 48
telecommunications. See TelMerge
TelMerge, 48
temporary files, 49
temporary markers. See markers
thesaurus (*Q)), 49
time, merge printing predefined variable for, 34
title bar, 49
TOC command (Utilities pull-down menu), 48
TOC Entry dialog box, 48
top margin. See margins

AU (undo), 50
.uj (microjustification), 26, 35
.ul (underline spaces and words), 49
underline text (APS), 49
undo (~U), 50
unerase. See undo (MU)
unformatted files. See ASClII files
units of measurement, 50
unmark block (*KU), 4
up, move cursor up, 10, 11
Up Arrow, move up a line, 11
uppercase conversion, 4, 5
Utilities pull-down menu
Block Math command, 4
Calculator command, 5
Index command, 24
Inset command, 22
Language Change command, 26
Macros command, 28-29
Merge Print Commands command, 32-34
Repeat Next Keystroke command, 42
Sort Block command, 4
Spelling Check command, 45
Thesaurus command, 49
TOC command, 48
Word Count command, 4, 51

\%

AV (turn insert mode on/off), 25
variables, merge print, 33-34, 40
vertical centering (*OV), 50
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INDEX

vertical spacing. See line height; line spacing;

margins

view. See display
View pull-down menu

\%Y%

Block Highlighting command, 3

Command Tags command, 1617, 21

Open/Switch Window command, 51

Preview command, 39

Screen Settings command, 6, 16-17, 21,
42, 43-44, 46, 47

AW (scroll up a line), 10, 11
windows

close, 49

copy block between windows (AKA), 4,
9,51

copy block from clipboard (*K]), 4, 6, 9

copy block to clipboard (~K]), 4, 6, 9

maximize/minimize size of, 49

move block between windows (AKG), 4, 9

open/switch between windows (*OK),
13,51

Windows program, clipboard and, 4, 6, 9
WINSTALL, 13, 39, 51

word count (AK?), 4, 51

word wrap (.aw), 51

words
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check spelling of a word, 45

count number of (AK?), 4, 51

delete word (AT), 15

double words, find, 45

keep together on line (APO), 3

move left one word (*A), 10, 11
move right one word (AF), 10, 11
move to specified word (*QF), 13, 20

WordStar

convert files from one version to another,

9, 46
customize, 13
and EMS, 18
exit, 19, 43
install, 25, 52
start, 46

start Inset from within (AP&), 22

write block to file ("\KW), 3
WS4.PDF, 40
WSCHANGE, 13, 14, 51
WSSETUP, 52

X

X command (Opening Menu), 19
AX (move down a line), 10, 12
.xe (custom printer code), 13
Xerox 4045, fonts for, 28

Xl (define form feed string), 22
.Xq (custom printer code), 13

.Xr (custom printer code), 13
XTRACT.PDF, 40

.XW (custom printer code), 13

XX (strikeout text), 47

Y

Y command (Opening Menu), 15
AY (delete line), 15

Y4

AZ (scroll down a line), 10, 12
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CHAPTER 1

WORDSTAR BASICS

“WordStar Basics” describes the organization and conventions used in this
manual. It also presents an overview of the WordStar menus and commands,
cursor movement, and mouse support.
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The procedures in this manual assume that you've installed WordStar following
the instructions in the Installing and Customizing booklet, and that the default
settings are in effect. If you’ve changed any default settings, you can adapt the
instructions to your settings.

How 10 USE THIS MANUAL

The Reference manual gives detailed explanations of features, functions, and
commands available in WordStar, organized by commands on the pull-down
menus. Each chapter describes the commands on one pull-down menu, in the
order they appear on the menu. For example, Chapter 2 describes each com-
mand on the File menu, which is the first menu on the Opening menu bar.

You can enter each command in several ways. “Menus and Commands” in this
chapter describes in detail how to enter commands. The heading for each com-
mand in this manual includes the corresponding Alt key shortcut followed by
the equivalent classic command.




WORDSTAR BASICS

If you don’t know what command performs the function you want, or if you
don’t use pull-down menus, you can easily find any feature by using the subject
index and the command index (which contains all the classic commands).

KEYBOARD CONVENTIONS

This manual uses several conventions to describe commands you enter from the
keyboard.
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The arrow symbol (= ) points to the next item you choose on a pull-down
menu or in a dialog box. For example, File=>Copy means to choose the File
menu and then choose Copy from the menu. Following the pull-down com-
mand, the equivalent classic command is shown.

Alt+KEY means to hold down the Alt key and press another key.

Alt+KEY1,KEY2 means to hold down the Alt key while you press KEYT. Then
you can release the Alt key or keep it depressed and press KEYZ2.

AKEY means to hold down the Ctrl (*) key while you press the key assigned to
the command.

AKEY1 KEY2 means to hold down the Ctrl (*) key while you press the first key,
and then press the second key. (It doesn’t matter whether or not you are still
pressing the Ctrl key when you press the second key.)

STARTING WORDSTAR

To start WordStar, at the system prompt, type ws and press Enter. The first
screen that appears shows the version number, serial number, copyright notice,
and the names of your computer and printer. Then the Opening screen
appears, and you can choose a command from one of the menus.




MENUS AND COMMANDS

MENUS AND COMMANDS

WordStar has two complete sets of menus. They are pull-down menus and
classic menus. The commands on both sets of menus perform the same tasks,
using different keystrokes.

HELP LEVELS

The help level setting determines which menus WordStar displays. Pull-down
menus (help level 4) are the default. You can change between pull-down and
classic menus, and change the way classic menus are displayed, by choosing
Help=>Change Help Level, or (except in help level 4) by pressing F1 F1. For a
complete description of the five help levels, see “Change Help Level” in the
“Opening Screen Help Menu” chapter.

PULL-DOWN MENUS AND COMMANDS

At help level 4, the default setting, the menu bar at the top of the Opening and
Edit screens displays the menus available at that screen.

WordStar
menu bar —[File Utilities Additional Help

Filenames: Path: C:\WS 6.1M free ATt
.o \ | CONVERT \ | FAX N\ | INSET \
MACROS \ | OPTIONS \ | 2258DUAL.PS 1.5k | 2250DULB.PS 1.7k
2258DUTB.PS 1.7k | ZDDUAL.PS 2.8k | 2DDUPLB.PS 2.2k | 2DDUPTB.PS 2.2k
3256DUAL.PS 1.5k | 3258DULB.PS 1.7k | 325@8DUTB.PS 1.7k | ARROW.HP .3k
BORDER. P8 .9k | BOX .4k | BOX.PS 1.8k | CAN3R.PS 2.5k
CAN3T. PS 2.7k | CAN4.PS 1.8k | CANIII.PS 1.3k | CHEX.HP .5k
DB@8.DTB 80k | DB@O@.DTD 77k | DB81.DTB 375k | DBB1.DTD 74k
DBBZ2.DTB 84k | DBBZ.DTD 28k | DB@4.DTB 188k | DBB4.DTD 14k
DPSFEED.PS 1.4k | EHANDLER.PS 2.8k | FONTID.CTL 7.3k | HARRIET .3k
HP-ENU.LST 1.8k | HPZ-ENU.LST 1.8k | IBM4B1SF.PS 4.7k | IBM4823F.PS 4.7k
IBMFEED.PS 1.5k | INDEX.DTB 46k | INDEX.DTD 11k | JOAN .3k
JUST .3k | KEYBOARD.MRG .1k | LETTER.PS 2.5k | LIST.DOC .8k
LOGO. PS 5.6k | LWFEED.PS .5k | MACRO.BAK .3k | MACRO.DOC .3k
MAILING.DOC 1.8k | NECFEED.PS .6k | NEUW .3k | OPTION.PS 3.7k
PDFEDIT.HLP 35k | PLAYBILL.BAK .6k | PLAYBILL.DOC .8k | PLAYS.DOC .9k
PLEAD. HP .1k | PLEAD.PS 1.3k | P04845.PS 1.4k | POBRHL4.PS 3.8k

—————————————————
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To display a menu at the Opening screen in help level 4, press the first letter of
the menu name or, if you have a mouse, click the name. You can move
between menus using the Right and Left Arrow keys, AS and AD, or a mouse.
To choose a command on a menu, press the highlighted or underlined charac-
ter (depending on what type of monitor you have) or click the command.

A » symbol to the right of a command name indicates that the command dis-
plays a submenu. To display the submenu, choose the command or press the
Right Arrow key or AD. To return to the menu, press the Left Arrow key or AS.

Three dots (...) to the right of a command name indicate that the command
displays a dialog box.

When you're editing a file, you work at the Editing screen.

WordStar - C:\WUS\SHAKE. DOC

File Edit Uieuw

William Shakespeare

Of all the Elizabethan poets, William Shakespeare is the most
Ifamous. He was born in 1564 in the village of Stratford-on-fAuvon
o an old and prominent family. His father, John Shakespeare,

as a glover and uool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
[Elizabethan education uas based on learning by rote, and he had
Bn excellent aural memory. His education in Latin left an unmis-
akable impression on his vocabulary. In the upper school, he
studied logic and rhetoric, and excelled in dialectic argument, a
skill he later put to use in his plays. Shakespeare learned

reek mythology and Roman history. UWhen he began to urite, he
shoued a marvelous ability to make a little knouledge go a long
ay.

Shakespeare married uvhile he was still a minor and needed his
parents’ permission. His bride, Anne Hathauay, uas tuenty-six
Insert P1 L1 ue. 508" C1 He. 88"

To display a menu at the Editing screen in help level 4, press Alt and the first let-
ter of the menu name. When the menu appears, you choose a command by
pressing the highlighted or underlined character (depending on what type of
monitor you have) or by clicking the command name.
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MENUS AND COMMANDS

When the help level is set at 1, 2, or 3, the classic Opening Menu appears
when you start WordStar. The pull-down menus don’t appear. The Opening
Menu lists commands for such operations as editing, printing, and deleting files.
To use a command, press the highlighted character.

OPENING MENU
D open a document L change drive/directory
S speed urite (neu file) C protect/unprotect a file
N open a nondocument E rename a file
P print a file 0 copy a file
\ fax Y delete a file
K print from keyboard F turn directory off
I index a document M macros
T table of contents R run a DOS command
X exit UWordStar A additional
F1 help 7?7 display status

When you open a file, the classic Edit Menu appears. It contains basic editing
commands, including the commands to display the other classic menus.

CURSOR SCROLL
“E up “U up G
~X doun ~Z doun’ ~T
S left “R screen up ¥
“D right “C screen Del
“A word left doun “u
“F uword right

EDIT
DELETE
char
word
line
char
undo

MENU

OTHER MENUS
F1 help ~0 onscreen format
~1 tab “K block & save
U turn insert off "M macros
“B align paragraph "P print controls
“N split the line "Q quick functions
L find/replace again

To see the classic menus in help levels 2, 3, or 4, hold down the Ctrl key and
press the command for the menu you want. You can choose any command on
the menu by pressing the appropriate character.

Classic commands work at all help levels, even if they’re not displayed.
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DISPLAYING CLASSIC COMMANDS AT PULL-DOWN MENUS

Some people who use classic commands like to use pull-down menus so that
they can easily find a command that they don’t remember. As a default, classic
commands are shown next to the corresponding pull-down commands on the
pull-down menus.

If you want to turn off the display of classic commands at the pull-down menus,
choose View=>Screen Settings, or use the AOB classic command, and turn off
the setting for Classic Commands on Pull-down Menus. Classic commands
work at all help levels, even if they’re not displayed.

To change the default setting for the display of classic commands on pull-down
menus, use WSCHANGE, the WordStar customization program. See “Changing
WordStar Settings in WSCHANGE” in the Installing and Customizing booklet.

Dot coMMANDS

WordStar commands include a number of dot commands. Sometimes a dot
command is inserted into a document when you make a choice at a menu or
dialog box. You can also type a dot command directly into a document.

A dot command begins with a period, which is followed by the two-letter or
three-letter command and whatever text or setting is required. The period must
be in column 1 of the line, and the dot command must be on a line by itself.
Dot commands are not part of the text, so they take up no real space in the
document.

As a default, dot commands are shown in the document while you're editing.
When you turn off Command Tags display (View=>Command Tags or AOD),
they are not displayed except while you enter them. If you want to always dis-
play dot commands, choose View=>Screen Settings, or use the AOB classic
command, and select Dot Commands: Always On.

WordStar assumes that any line that begins with a period is a dot command line.
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(NSCREEN HELP

Onscreen help is available for every command in WordStar. To get help at
pull-down menus, press F1 or choose Help from the Help Menu.

To get help at classic menus, press F1 at the Opening Menu, and then press the
command you want help with. To get help while editing a document, press F1,
and then press the command you want help with. To get help for an option in
a dialog box, move the cursor to the option and press F1.

S CREENS AND DIALOG BOXES

The following sections describe the elements that appear on the WordStar
screens.

THE EDITING SCREEN

You create and edit your documents at the Editing screen. The Editing screen
can include several screen elements, including menus and other information. If
you want more space on the screen for editing, you can use the WSCHANGE
customization program to remove most of the Editing screen elements (for infor-
mation about WSCHANGE, see the Installing and Customizing booklet). You
can also turn on and off the display of the scroll bar, style bar, status line, and
ruler line by choosing View=>Screen Settings or using the 2OB classic com-
mand.

The following illustration shows the Editing screen for help level 4 (pull-down
menus). The parts of the screen are described below the illustration.
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Style bar Ruler line Title bar
Menu bar

WordStar — C:\WS\SHAKE.DOC
Style Layout Utilities

William Shakespeare

0f all the Elizabethan poets, William Shakespeare is the most
ifamous. He was born in 1564 in the village of Stratford-on-Avon
ito an old and prominent family. His father, John Shakespeare,
was a glover and wool dealer with a shop in Stratford.

Shakespeare entered grammar school in 1571 at the age of seven.
[Elizabethan education was based on learning by rote, and he had
lan excellent aural memory. His education in Latin left an unmis-
itakable impression on his vocabulary. In the upper school, he
tudied logic and rhetoric, and excelled in dialectic argument, a
kill he later put to use in his plays. Shakespeare learned
reek mythology and Roman history. When he began to urite, he
houed a marvelous ability to make a little knouledge go a long
way.

Shakespeare married while he was still a minor and needed his
parents’ permission. His bride, Anne Hathaway, was tuenty-six
Insert P1 L1 UB.58" C1i

He.es"

Status line —T Flag column
Vertical scroll bar

THE TITLE BAR

The title bar shows the name and path of the file you're editing. If you have
installed a mouse, the Close File button is at the left of the title bar. The com-
mand in progress is shown next to the Close File button. The title bar also
shows messages such as Printing and Replace Y/N. If you have a second win-
dow open, the right side of the title bar shows the current window number and,
if you have a mouse, a button to maximize/minimize window size.

THE MENU BAR

The menu bar displays the names of the pull-down menus.

THE STYLE BAR

The style bar shows information about current settings such as the paragraph
style and font names. If you have a mouse, you can click any setting to select it
or turn it on or off. From left to right, the settings are paragraph style, font
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name, bold, italic, underline, Command Tags display, alignment (left, center,
right, or justify), and line spacing. You can move the style bar to the bottom of
the screen using the WSCHANGE customization program. The style bar is not
displayed in nondocument mode.

THE RULER LINE

The ruler line shows current margin and tab settings. The marker on the ruler
line shows the position of the cursor on the page and moves as you move the
cursor. The ruler line is not used in nondocument mode.

The initial ruler line settings in a document are those in the default paragraph
style. The default settings are left margin at O, right margin at 6.5 inches, and
tab stops every .5 inch.

When you change the margin or tab settings in a document, the ruler line
changes to show the new settings.

The ruler line can contain the following characters:

CHARACTER MEANING
F Left margin
4 Right margin
q First line indent (paragraph margin)
> Tab stops
o Decimal tabs

- Space between margins and tabs
| Temporary indent (*OG)
You can change margin and tab settings using paragraph styles or by choosing

Layout=>Ruler Line (or using the ~OL classic command). For more information,
see “Ruler Line” in the “Editing Screen Layout Menu” chapter.
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THE STATUS LINE

The status line shows the cursor location, messages, and warnings as shown in
the following illustration. The status line is located at the bottom of the screen.
You can move it to the top of the screen using the WordStar customization
program WSCHANGE (DBA2B).

Line Column Size current
State indicators Insert on/off number number window button

Column-Replace 12345678398¢<B><K> Insert P111 L1i1 UB.58" C1 He.@0" =*

t t t
Markers set Page Vertical Horizontal
number  position position

You can use a mouse with several status line options. You can click Insert to
switch between Insert and Overtype. You can click the page number (for docu-
ments) or line number (for nondocuments) to display the Go to Page (or Line)
dialog box, and you can click the beginning and end block markers and marker
numbers to go to those locations.

THE VERTICAL SCROLL BAR
The vertical scroll bar lets you use a mouse to move around in a document. For
more information, see “Moving the Cursor and Scrolling with a Mouse” in this
chapter.
THE FLAG COLUMN
The flag column shows a flag character for each line to remind you of what is
on the line. The flags and their meanings are listed below.
FLAG MEANING

< The line ends with a hard carriage return.

A blank space means that the line ends with a soft carriage
return produced by word wrap within a paragraph.

P This is a page break; a new page begins below this line.
F This line ends with a form feed produced by the APL
command.

This is a column break.
A The file ends on or above this line.

+ Text on this line extends beyond the right edge of the sceen.
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FLAG MEANING

The dot command on this line changes the onscreen format
and the printout.

The dot command on this line changes only the printout.

? The dot command on this line is not recognized by
WordStar.

1 The dot command on this line changes the onscreen format
and the printout; it works best if it's placed at the beginning
of a page.

- The line ends with a carriage return without a line feed,; it
will be overprinted by the next line.

J The line ends with a line feed without a carriage return
(produced by AP)); the next line may not begin at the left
margin when printed.

W This is the second window separator in nondocument mode.

DISPLAYING COMMAND TAGS

When you choose a WordStar command, WordStar often puts a command tag
into your text. For example, AB appears at the beginning and end of bold text,
and if you change the font, for example, to the Courier 10 font, the tag
<Courier 10.0> is inserted.

Command tags and dot commands take up space on the screen and may make
text appear out of alignment. You can choose View=>Command Tags, or use
the AOD classic command, to remove these tags from the screen while you
edit, and to display them again. (If you have a mouse, you can also click the

[*] button on the style bar.) The commands remain in effect even when the
tags aren’t displayed.

If you edit with Command Tags off, you may want to turn them on periodically
to see what commands are active in the file. For example, it’s a good idea to
have Command Tags on before you delete, copy, or remove text, so that you
can see what commands are included in the text.

For more information, see “Command Tags” in the “Editing Screen View Menu”
chapter.

1-11
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DiALOG BOXES

Filename: [CBNISNSE[H0M0e L B
Page Numbers: Pages:
¢ All o 0dd
o Selected Pages: o Even
¢ Both .
Option button
Copies: ———— Check box
Teithiox [X]1 Use Form Feeds
Printer: DG [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text
Redirect To: [ [X1 Interpret Merge Uariables
Printers:
List —» | ASC256 | ASCII | DRAFT | ws4
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If WordStar needs more information to carry out a command, a dialog box
appears. Each dialog box contains one or more areas where you fill in informa-
tion or select settings.

The illustration below shows the Print dialog box.

List box Command button
M—

The list of printers below the dialog box is displayed because the cursor is in
the list box; whenever you move the cursor to a list box, the corresponding list
appears below the dialog box. The list shows the available choices, for
example, for filenames or fonts.

To move around in a dialog box, press the Tab key to move forward and
Shift+Tab to move backward. To select an option directly, press Alt and the
key for the highlighted or underlined character. You can also use a mouse to
move around and select options. To change settings in a dialog box, use these
procedures.

= |n a list box, type a name, or press the Down Arrow key to move to the list
and then use the Arrow keys to select a name from the list. You can use the
AR (Repeat) command to repeat the information you entered most recently.



MOVING THE CURSOR AND SCROLLING

= To select an option button, move to the button for the setting you want. A
diamond shape indicates a selection. If you change your mind, you can
press Alt and the highlighted or underlined character or use the Up or Down
Arrow keys to move to another option button.

= To turn a check box setting on or off, move to the option and press the
Spacebar. An X in the brackets indicates that the setting is on; empty
brackets show an off setting. Once you select the option, you can also press
the Plus (+) key to turn the option on and the Minus (-) key to turn it off.

= When you select an option with a text box, type the appropriate information,
for example, the number of copies to print. (Some text boxes may not be
long enough for the information you need to type; in this case, when you get
to the end of the box, the information you typed scrolls to the left and you
can keep typing.)

To save the settings and close the dialog box, press F10 or choose OK. (F10
enters the WordStar command ~K; you can use ~K and F10 interchangeably.)
To cancel your choices, press Esc or tab to the Cancel button and press Enter
or, if you have a mouse, click Cancel.

TIP If you prefer to use the Enter key instead of the Tab key to move between
options, you can change this setting while editing by choosing Edit—Editing
Settings—.! Closes Dialog. When you use Enter to move between options, it
doesn’t close dialog boxes; use F10, K, or OK. You can also change this
setting using the WINSTALL Change basic editing defaults option.

MOVING THE CURSOR AND SCROLLING

To move the cursor, you can use the direction keys located on the numeric
keypad to the right of the regular keyboard or you can use WordStar com-
mands. (For information about using a mouse to move around in a document,
see “Using a Mouse.”) The direction keys include the Arrow keys, the PgUp
and PgDn keys, the Home key, and the End key.

1-13
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The WordStar commands that move the cursor are called the cursor diamond
because of the locations of the keys on the keyboard.

wlelx
ATl
]

Up one line AEor T

Down one line AXord

Left one character AS or «—

Right one character ADor—

Left one word AA or Ne—
Right one word AF or A—

To column 1 in first onscreen line AQE or Home
Beginning of file AQR or AHome
Right end of last onscreen line AQX or End
End of file AQC or AEnd

1-14
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Scrolling allows you to move another portion of the text onto the screen, either
vertically or horizontally.

Up one line AW or APgUp
Down one line AZ or APgDn
To previous screen AR or PgUp
To next screen AC or PgDn

For a complete list of cursor movement and scrolling commands, see Quick
Reference.

Usine A MOUSE

The mouse pointer, which is normally a rectangle, appears onscreen when a
mouse is installed on your computer. The pointer does not appear in any
companion program except Inset®. You can switch between the mouse and
keyboard at any time.

If you would rather not use a mouse in WordStar, you can turn off mouse sup-
port in the WordStar customization program WSCHANGE (DCHA).

MoUSE CONVENTIONS IN WORDSTAR

Click means to point to an item and press the left mouse button.

Double-click means to point to an item and press the left mouse button twice in
quick succession.

1-15
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Drag means to hold down the left mouse button while you move the mouse,

and then release the button.

Ctrl+Click means to hold down the Ctrl key and press the left mouse button.
Shift+Click means to hold down the Shift key and press the left mouse button.

Ctrl+Shift+Click means to hold down the Ctrl key and press the Shift key and

the left mouse button.

MoVING THE CURSOR AND SCROLLING WITH A MOUSE

The vertical scroll bar, located along the right side of the screen, is for moving
forward and backward in a document. The vertical scroll bar contains a slider

box that indicates the relative position of the cursor in the file.

Previous line

Click T

Next line

Click 1

Previous screen

Click above the slider box

Next Screen

Click below the slider box

Beginning of a document

Drag the slider box to the top

End of a document

Drag the slider box to the bottom

Approximate position in a document

Drag the slider box to the relative
position in the file
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You can use these mouse shortcuts.

FUNCTION KEYS

Change drive/directory at a filenames list

Double-click the directory

Open document

Double-click the document name

Close a document

Double-click the Close File button in
the title bar

Go to page

Click the page number in the status line

Go to marker

Click the marker in the status line

Switch windows

Click in the window

Select setting on style bar

Click the button

When you're using Preview, you can also click on a button in the menu bar to
do the same thing as pressing the corresponding key. You can also use the right
mouse button as a shortcut to View=>Adjust Window, and then drag or click

the mouse to choose a window to view.

Funcrtion KEys

You can use the function keys, which are labeled F1, F2, F3, and so on, to
execute the most frequently used WordStar commands with a single keystroke.
The function keys are set to issue WordStar commands with the WordStar
macro function. For complete information, see Appendix D, “Function Keys

and Other Macros.”
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C OMMAND LINE OPTIONS

When you start WordStar, you can bypass the copyright screen and the
Opening screen to begin editing a document immediately. To do this, type ws
followed by the name of the file you want to edit, for example, ws first.doc.

WordStar opens the file in document mode. To specify nondocument mode,
use the /n option, for example, ws first.doc /n.

The chart below describes the options you can use.

OPTION
/n
/d

/s
/p

/m macroname

/x

/o nnn
/hn

DESCRIPTION
Opens the named file as a nondocument

Opens the named file as a document (use this option if
you've changed the default file mode to nondocument)

Opens a new file with no filename
Prints the named file

Executes the named macro; if a filename is also specified,
opens the file before executing the macro

Exits WordStar upon returning to the Opening screen (use /x
with another option, for example, type filename.doc /p /x
to print the file and then exit WordStar)

Goes to decimal location nnn in the named file

Sets the help level to n (0, 1, 2, 3, or 4)

THE wscHANGE ¢ USTOMIZATION PROGRAM

1-18

The WSCHANGE customization program allows you to set up WordStar to run
the way you want. You can specify initial settings for many features, such as
margins and justification. You can also customize how WordStar works on
your computer. For example, you can change the colors for the screen display.



THE WSCHANGE CUSTOMIZATION PROGRAM

WSCHANGE works through a series of menus, where you make a choice by
typing a letter. When this manual refers to a setting you can change with
WSCHANGE, the letters you press to get to that setting are shown in paren-
theses. For example WSCHANGE (CCD) means that to get to that setting, you
start WSCHANGE and then press C, press C, and press D.

For complete information on WSCHANGE, see the Installing and Customizing
booklet.
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CHAPTER 2

()PENING SCREEN
FILE MENU

The Opening Screen File menu includes commands to open, copy, delete,
rename, and print files, and other commands to manage files.
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OPENING SCREEN FILE MENU

NEW

Pull-down: ALT + F, W
Classic: S

Opens a new file without assigning a name fo it.

When you open a new file, it's empty. You can type or insert other files. When
you save the file, WordStar prompts you for a filename.

The file you open when you use the New command is a document file. If you
like, you can use WSCHANGE (DCBA) to make nondocument the default file
format.

OPEN DOCUMENT Pull-down: ALT + F, D

Classic: D

Opens a document file.
Follow these steps to open a document file.
1 Choose File=>Open Document, or use the D classic command.

2 In the Open Document dialog box, specify the name of the file to open.
You can open either an existing file or a new one. If necessary, specify the
path with the filename.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#!% T (){})-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$?? (where ? can be any character) do
not appear in the WordStar filename lists, so don’t use them to name your

text files. You can change this list of filename extensions using
WSCHANGE (CEC).
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3 Press F10 or choose OK.

TIP To go directly to a specific file when you start WordStar, type the
filename on the command line. For example, type ws \ws\status.dan to go
directly to the STATUS.DAN file.

For more information on documents and nondocuments (ASClI! files), see
“Open Nondocument.”

OPEN NONDOCUMENT Pull-down: ALT + F, N
Classic: N

Opens a nondocument file.
Follow these steps to open a nondocument file.
17 Choose File=>Open Nondocument, or use the N classic command.

2 In the Open Nondocument dialog box, specify the name of the file to open.
You can open either an existing file or a new one. If necessary, specify the
path with the filename.

3 Press F10 or choose OK.

A nondocument file is in ASCII format, which is a standard text format. When
you edit a nondocument, most of the WordStar text formatting capabilities,
such as aligning text, word wrap, and justification, are not applicable.

TIP To go directly to a specific nondocument file when you start WordStar,
type the filename and the /n option on the command line. For example, type
ws \ws\knox.txt /n to go directly to the KNOX.TXT file in the WS directory.

If you open a nondocument file in document mode by mistake, exit the file
without saving it (File=>Close, or ~KQ). If you save the file, WordStar adds for-
matting codes to it. If you open a document file in nondocument mode and
save it, WordStar strips codes necessary for formatting.

When you print a nondocument, select Print Unformatted Text in the Print
dialog box. (Otherwise, any lines that begin with periods will be considered
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dot commands.) You can print a nondocument with any printer definition file
(PDF), but if your PDF contains formatting codes for documents, you may get
unexpected printing results. If you have problems printing a nondocument,
choose DRAFT for the printer.

DOCUMENTS AND NONDOCUMENTS

The differences between documents and nondocuments are described below.

Menus and Commands Documents have complete menus. For nondocu-
ments, classic menus include only the commands available in nondocument
mode; pull-down menus are the same as those in document mode, but com-
mands that apply only to documents do not work. Two commands work dif-
ferently: in a nondocument, the A0l command sets tab width rather than
displaying the Ruler Line dialog box, and the A6 command turns auto-indent on
and off rather than changing hard carriage returns to soft returns.

Note: When auto-indent is on, WordStar indents lines as they are typed. Type
spaces or tab to the column to which you want to indent. Each time you press

Enter, the new line starts at that column. You can change the amount of inden-
tation by adding or deleting spaces or tabs on the line where you want the new
indentation to begin.

Formatting The following functions are not available for nondocuments:
centering, automatic hyphenation, justification, line spacing, margins, ruler
line, soft hyphens, and word wrap.

Tab Stops Document tab stops are initially set every .5 inch, but you can reset
them anywhere on the ruler line. Tabs in nondocuments usually use a special
tab character and are customarily set every 8 spaces; you can use the A0l
classic command to reset them only to a binary multiple, such as 1,2, 4, or 16
spaces. You can also use WSCHANGE (DCBD) to set nondocument mode to
use other tab stops.

Cursor Indicator In documents, the status line shows the page, line, and

column where the cursor is located. In nondocuments, it shows only line and
column.

Dot Commands WordStar checks dot commands in documents and changes
the screen display and printed documents accordingly. Dot commands in a
nondocument do not take effect, and the commands themselves are printed.
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Embedded Information If you open a document file as a nondocument, you
will see printing-related information embedded in codes throughout the
document.

Go to Page The Go to Page command on the Edit menu (*QI) finds a page
number in documents; it finds a line number in nondocuments.

Aligning Text In nondocument mode, using the Reformat commands on the
Utilities menu (B or AQU) strips high order bits and symmetrical sequences.
Tab sequences are replaced with blanks; soft carriage returns are replaced with
hard carriage returns. Other sequences are deleted.

CONVERTING DOCUMENTS TO NONDOCUMENTS

Before editing a document in nondocument mode, you should convert the file
to nondocument (ASCII) format. Depending on the type of nondocument you
want, you can use any of three methods:

= QOpen the file in nondocument mode, and then choose
Utilities=>Reformat=>Rest of Document, or press AQU. This method
doesn’t preserve any formatting, such as page offset or page breaks.

= Print the file to disk using the ASCII or ASC256 special printer selection. Use
ASC256 if you want extended characters to remain in the file. This method
preserves formatting; spaces are at the beginning of each line if there was a
page offset, and blank lines are at the ends of pages for page breaks.

Use this procedure: Choose File=>Print and specify the file to convert. In
the Print dialog box, select ASCIl or ASC256 in the Printer list box. In the
Redirect To text box, type the name you want to give the ASClI! file. If you
don’t type a filename, the file is named ASCII.WS or ASC256 .WS. Press F10
or choose OK to start printing to disk.

For more information on printing to disk, see “Printing to Disk” in “Print” in
this chapter.

= Mark the entire file as a block, and then choose Edit=>Copy=>To Another File,
or press AKW. In the dialog box, select the Copy in ASCII Format check box.
This method does not preserve any formatting, and does not insert carriage
returns at the end of each line; each paragraph appears as one long line.
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CONVERTING NONDOCUMENTS TO DOCUMENTS

If you want to edit a nondocument (ASCII) file in document mode, open the file
as a document. Before you start editing, you should change the hard carriage
returns to soft returns. Press 76 at each line, except at the last line of each para-
graph and the blank lines between paragraphs. (Use the 6 at the top of the
keyboard and not the 6 in the numeric keypad.) This changes hard carriage
returns to soft returns. Then reformat the entire file (Utilities=>Reformat=>Rest
of Document, or ~QU).

Note: If the text in the nondocument doesn’t start in the far left column on the
screen, before you use 76, you can delete the spaces at the beginning of each
line by putting the cursor in column 1 and pressing AT. Or you can mark the

entire area to the left of the text as a column block and delete the block.

PRINT

Pull-down: ALT + F , P
Classic: P

Prints a file.
Follow these steps to print a file:
17 Choose File=Print, or use the P classic command.

2 In the Print dialog box, change any of the print options you want. The print
options and their defaults are described below.

“

Filename: [SBNTREIEE0MIe L OK B
Page Numbers: Pages: il Cancel §
¢ All o 0dd
o Selected Pages: o Even
¢ Both
Copies:

[X]1 Use Form Feeds
Printer: DRGNS [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text

Redirect To: [N [X1 Interpret Merge Uariables
T T e S T T S T |




PRINT

Filename Select the file to print. The default is the last file you edited.

Page Numbers Select All (the default) to print every page in the file. To
specify the pages to print, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to print pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, printing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Copies You can print more than one copy of the document. The default
is one copy. To change it, type the number of copies you want. (If you
always want the file printed a certain number of times, you can use
Utilities=>Merge Print Commands=>Print File n Times, or the .rp dot
command. See “Merge Print Commands” in “Editing Screen Utilities
Menu.”)

Printer WordStar displays the name of the printer assigned to the file. To
change it, type another printer name or select a name from the list of your
installed printers.

Redirect To The output normally goes to whatever port you specified for
the printer you are using. If you want to redirect the output to another port,
type the name of the port. If you want to redirect output to a disk file, type
the filename. For more information, see “Printing to Disk” in this section.

Pages To print only odd or only even pages, select Odd or Even. The
default is Both.

Use Form Feeds If you want WordStar to send a form feed command when
moving to the next page of a printout, select this check box. Form feeds are
required for a laser printer or other sheet feeder. The default depends on the
type of printer you are using. You can use PRCHANGE to specify a different
default for each of your printers. Whenever you print on paper shorter than

11 inches, clear this box.

Pause Between Pages If you need to have the printer pause between pages
so that you can feed individual sheets of paper to it, select this check box.
You can use PRCHANGE to specify a different default for each of your
printers. The default is no pause. If you select this option, WordStar pauses
before the second page and each subsequent page.
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Print Unformatted Text If you select this option, WordStar prints all the dot
commands and does not execute them. Always use this option for printing
nondocuments. The check box is clear as a default.

Interpret Merge Variables Merge print variables and commands are
interpreted as a default. If you clear this check box, variable names are
printed in the text rather than the variables, and merge print commands are
ignored. For more information on merge print commands and variables, see
“Merge Print Commands” in “Editing Screen Utilities Menu.”

Note: You can change the default settings for many of the print options
using WSCHANGE or PRCHANGE.

3 Press F10 or choose OK to print the file.

WordStar normally prints in the background so that you can continue with what
you were doing before you started printing. The word Printing appears in the
status line. If printing stops during background printing, Print Wait replaces
Printing. You can use WSCHANGE (BDCA) to turn background printing off.
This makes printing faster.

If your file contains any Ask for Variable, Pause Print, or Clear Screen com-
mands, and you are using background printing, the Print Wait message appears
in the status line. You must press P to go to the Printing screen (described
below), and then enter the required response. If your file contains any Display
Message commands, you don't see the messages unless you go to the Printing
screen.

TIP The default speed for printing is full speed. However, some printers
can't receive the printing input at this speed. If you're printing while editing,
you may notice a time lag between pressing keys and the resulting onscreen

operation. To eliminate this lag, use PRCHANGE to change the printing speed
to a slower setting.

The Printing screen shows messages and commands related to printing. The
Printing screen is hidden during background printing. You must display the
Printing screen before you can see a printing-related message or enter a printing-
related command during printing. To display this screen, choose File=>Print or
use the classic command P at the Opening screen or AKP while editing.




PRINT

P Pause F Print at Full Speed

C Continue after Pausing Esc Cancel Printing
B Print from Background

Messages appear below the Printing screen commands. The commands are
described below.

COMMAND DESCRIPTION
P Pauses printing temporarily
C Continues printing after a pause
B Starts background printing and exits the Printing screen
F Starts full-speed printing if you used PRCHANGE to choose

a slower printer speed

Esc Cancels printing completely and exits the Printing screen

During printing, the Printing screen status line shows the page number that is
currently being printed. It also shows the copy number that is currently being
printed. This is useful if you are printing more than one copy of a document.

PRINTING TO DISK

Sometimes you may want to “print” a document to a file on disk rather than
printing it on paper. For example, you can review merge-printed form letters
on the screen before you print them on letterhead paper. You can print to disk
either by typing a filename to redirect the output to or by using one of the spe-
cial printer description files (PDFs). Both methods are described below.

SENDING PRINTER-FORMATTED OUTPUT TO A FILE

To tell WordStar to run a file through a specific PDF and send the output to a
new file rather than sending it to the printer, specify the new filename in the
Redirect To box in the Print dialog box.

You can print to disk if your computer is not connected to the printer, and
produce a disk copy of the document formatted with all the proper codes for
the printer. You can then take the file on a floppy disk to a computer con-
nected to the printer and print the file using the DOS COPY command. For
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example, if the printer is connected to port LPT1, type copy output.doc Ipt1 /b
at the system prompt. For more information on the DOS COPY command, see
your DOS manual.

SPECIAL PDFS FOR PRINTING TO DISK

WordStar allows you to select any of five “printers” that make disk files rather
than sending text to a regular printer. They are named PRVIEW, ASCII,
ASC256, XTRACT, and WS4. You can select one in the Printer box in the Print
dialog box.

Note: The ASCII, ASC256, and WS4 PDFs are already created for you. If you
want to use the PRVIEW or XTRACT PDF, use PRCHANGE to install it.

PRVIEW Produces a file that looks as much like an actual printout as possible,
with headers and footers and with data inserted if you are merge printing. It
begins with the .pl dot command so that the page breaks appear in the proper
spots when you look at the file in document mode. Each line ends with a hard
carriage return.

ASCIl and ASC256 Produce a file that is an ASCII version of the document,
with all print controls and dot commands removed. Each line ends with a hard
carriage return. With ASCII, extended characters (ASCII 128-255) are not
printed or are replaced with ASCII characters; ASC256 prints extended charac-
ters. (You can also use Edit=Copy to Another file, or AKW, to write text to an
ASClI file.)

XTRACT Produces a file similar to the PRVIEW file, but without headers,
footers, and page breaks, and with soft carriage returns. This format allows you
to perform some simple manipulations on text and data files. For example, if
you had a data file named FORM1.DTA with several fields (such as name, title,
company, address, city, state, and zip), you could use XTRACT to create a data
file containing only the information in the name field. Create a file called
FORMI1.LTR containing these commands:

.op

.df forml.dta

.rv name,title, company,address,city,state, zip
&name&
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Note that this file ends with a carriage return after &name& so that each name
prints on a separate line.

When you merge print this file and use the XTRACT PDF, the output file con-
tains only the names from the data file.

WS4  Creates a file that is compatible with WordStar Release 4.

When you use any of these PDFs, specify a name for the output file by typing
the new filename at the Redirect To box in the Print dialog box. If you don’t
specify a new filename when printing with ASCII, ASC256, PRVIEW, or
EXTRACT, the output file is given the same name as the PDF but with a

WS extension, for example, ASCII.WS. With WS4, the new file has the same
filename as the original file with the .\WS4 extension.

PRINT FROM KEYBOARD Pull-down: ALT + F, K
Classic: K

Allows you to use your printer as a typewriter.

This command is useful for addressing envelopes and filling out forms. Follow
these steps:

7 Choose File=Print from Keyboard, or use the K classic command.

2 Inthe Print from Keyboard dialog box, select the template filename, printer,
and, if necessary, the port. These options are described below.

Print from Keyboard

Template Filename: [NINIONG:I0TIHE LB OK B

Printer: [LGIEN I § Cancel &

Redirect Output To: NN
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Template Filename A sample template file (KEYBOARD.MRQG) is included
with WordStar. You can use that file or create a new one. More
information is given below this list.

Printer Select the printer you’re using. Do not specify a printer, such as
the ASCII printer, that is used to create disk files.

Redirect Output To You can direct the printed output to a different port
just as you can from other printing dialog boxes.

3 Press F10 or choose OK.

4 Type the text you want, and press Enter after each line. As soon as you
press Enter, that line of text is sent directly to the printer. (You must press
Enter before text will print, even if your printer is in unbuffered mode.)
When you print from keyboard, text doesn’t wrap automatically and it can’t
be reformatted.

You can type dot commands while printing from the keyboard. When you
type Enter at the end of the line, the line is not printed, and the dot
command takes effect. Do not use the .co command (for columns) because
printing is unpredictable. WordStar interprets any line that begins with a
period as a dot command.

5 When you finish typing the text, press Esc to quit.

When printing begins depends on the type of printer you have. On page
printers, the entire page must be filled before printing begins. If you want to
print before the page is full, try a manual form feed or type a .pa (page break)
command or use a APL (form feed) command. On daisy wheel printers, the
internal buffer must be full.

Template Files Template files for printing from the keyboard contain dot
commands that define the page margins. A template file can also include dot
commands for selecting a font, changing line height and line spacing, and turn-
ing off page numbers. A template file also includes .av dot commands that ask
for variables at print time.
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A template file might look like this:

Lk, T

.rp 65000 (lets you repeat the instructions that
follow up to 65,000 times)

.mt 0 top margin of zero)

.mb 0 bottom margin of zero)

.op omits page numbers)

(
(
(
.av text (asks for variable “text”)
(
(
(

.1h 8 line height of 6 lines per inch)
.1s 2 double spacing)
&texté& text variable)
FAX Pull-down: ALT + F, F

Classic: \
Creates files that you can send with a fax board.

This command creates fax files in .PCX format. These files can be transmitted
directly through a fax board using the software that came with the fax board.
The resulting faxes look like the printed file, including all the fonts and other
formatting.

Note: Most fax boards can transmit .PCX files. However, if your board does
not support .PCX format, you must convert the .PCX file to a format supported
by the board. Most fax board software includes a conversion utility that can
do this.

One .PCX file is created for each page in a document. All the .PCX files you
create are placed in the WS\FAX directory, which WordStar creates the first
time you create a fax file. You can specify another fax file directory using
WSCHANGE (CD4l).

Follow these steps to create fax files:

7 Choose File=>Fax, or use the \ classic command.

2 In the Fax dialog box, specify the name of the file to fax. If necessary,
specify the path with the filename.

2-13



OPENING SCREEN FILE MENU

2-14

3

4

Fax File Location: C:\WS\FAX . Cancel

If you want to change the displayed name for the first fax file to create,
specify the name you want. The default is the first five letters of the original
filename, followed by three digits that represent the page number, starting
with 001. Fax files for subsequent pages are numbered sequentially. The
filename extension is always .PCX.

If the filename you specify is the name of an existing file, WordStar asks if
you want to overwrite the file. If you choose Overwrite (or press Y),
WordStar deletes the old file and replaces it with the new file. If you choose
Cancel (or press N), WordStar does not create the fax files. You can start
again and use a different filename.

TIP To avoid confusion, always choose a unique filename when you
create fax files, and delete fax files promptly when you no longer need them.

Change any of the options you want. These options are described below.

File to Fax: [sHNINNNITTHORII0 L

Name of Fax File: FINY [LH. PCX Resolution: § view §
o Lou

High

Special 388 dpi

9-pin Dot Matrix

24-pin Dot Matrix

Fax Page Numbers:
¢ All

o Selected Pages: [N

0O 00 ¢

Fax Page Numbers Select All (the default) to create fax files for every page.
To specify pages, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, for pages 1 through 3 and pages 5 and 7, type 1-3 5 7.

IMPORTANT When you use Selected Pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For
example, if you have a three-page document with no page number on the
first page, and the second and third pages numbered 1 and 2, you must
specify 2-3 (or 2 3) to create fax files for the last two pages. If you're not
sure about the physical page numbers, you can choose the View button
(described below) to start Preview. Preview displays the physical page
numbers at the top of the screen or, if more than one page is displayed,
above each page.
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Resolution Select the resolution your fax board uses. High resolution, the
default, is 200x200 dots per inch (dpi), and low resolution is 200x100 dpi.
The Special 300 dpi option is provided for fax drivers that use this
resolution. The 9-Pin Dot Matrix and 24-Pin Dot Matrix settings are not
used for creating fax files. They create files that can be printed on a dot
matrix printer using a utility (not provided with WordStar) for printing .PCX
files.

If the setting does not match the setting in your fax software, the file may not
look right when it is faxed. High resolution produces much better-looking
output. (Be sure to send the fax using the same resolution you create it with.)

View You can choose the View button to preview the file in order to
decide which pages to create fax files for. While you are previewing the
file, you can use all the usual Preview commands, including the Options
command to create fax files. If you create fax files in Preview, you return to
editing when you exit Preview; otherwise, you return to the Fax dialog box.
For more information about Preview, see “Preview” in “Editing Screen View
Menu.”

5 When you finish, press F10 or choose OK. WordStar creates the fax file or
files, displaying the progress.

You can press Esc to cancel fax file creation after the current page, or
press Esc twice to cancel it immediately.

After you create a fax file, you can use the SHOWPCX utility to identify the file,
to make sure you’ve processed the correct pages, and to check the quality of
the fonts. Start at the system prompt, type showpcx fax\filename (you don’t
need to type the .PCX extension), and press Enter. The fax file appears on the
screen in half-size format, so that you can see more of the page. Press the

plus (+) key on the numeric keypad to view it in maximum resolution. You can
use the scrolling commands and PgUp and PgDn to move around on the page.
When you finish viewing the file, press Esc to exit SHOWPCX. (Depending on
your monitor and the resolution you specified for the fax file, the image may
not have the proper proportions.)
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When you are working with fax files, keep these things in mind:

The fax file is a graphic representation of the printed page and is created
using the same process as Preview. All the features and limitations of
Preview apply to creation of fax files. For example: The same fonts are
available, and a 72-point font is used for fonts that are larger than 72 points.
Colors other than white are changed to black. System variables (such as date
and time) and merge print variables are not replaced with the corresponding
data.

For the best appearance of fonts in fax files, it’s best to use the FAX.PDF
printer driver for the document. This printer driver supplies fonts
comparable to Hewlett-Packard Laseret Il fonts, including Courier, Line
Printer, and scalable Times and Univers fonts. FAX.PDF is installed when
you install WordStar. You can add your own fonts to this PDF using
PRCHANGE.

The best way to determine how the fax will look is by using Preview at
4x zoom. Usually (depending on your monitor resolution), this option
corresponds most closely with the fax file resolution.

Creating fax files requires up to 27K of memory in addition to what WordStar
usually needs. You may need to free up memory for optimum performance
with fax files. See Installing and Customizing for guidelines on memory
usage. If your fax driver software remains in memory, you may need to
remove it before starting WordStar, and send your faxes after exiting
WordStar.

If the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating screen fonts. If less than 512K is
available when you start WordStar, you can remove memory-resident
programs or use WSCHANGE settings to make more memory available, and
then run the DELCRT utility to delete the blocky fonts. Then start WordStar
and create the fax files again. You can also improve these fonts by creating
.WSF files for large fonts using smaller symbol sets. For more information on
WSF files, see the Installing and Customizing booklet.

Fax files are large, and take up a lot of disk space. You may want to delete
them regularly. Also, .CRT files are created when you create fax files. You
can delete .CRT files that you no longer need using the DELCRT utility. For
more information, see “Preview Files” in “Preview” in “Editing Screen View
Menu.”
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COPY

Pull-down: ALT + F - 0
Classic: O

Copies a file.

Copying makes an exact duplicate of the file being copied; the original is saved,
not erased. Follow these steps to copy a file:

1

2

Choose File=Copy, or use the O classic command.

In the Copy dialog box, specify the name of the file to copy. If the file is not
on the current drive and directory, specify the path with the filename.

Specify the name of the file to copy to. You can put the copy on another
drive or directory by specifying the path with the filename.

You can use the same filename if you copy from one drive or directory to
another, but you cannot have two files with the same name in the same
directory. If the filename you specify for the new copy is the name of an
existing file, WordStar asks if you want to overwrite the file. If you choose
Overwrite (or press Y), WordStar deletes the old file and replaces it with the
new file. If you choose Cancel (or press N), WordStar does not copy the
file. You can start again and use a different filename.

Press F10 or choose OK to copy the file.

DELETE

Pull-down: ALT + F, T
Classic: 'Y

Deletes a file.

Follow these steps to delete a file:

1

2

Choose File=Delete, or use the Y classic command.

In the Delete dialog box, specify the name of the file to delete. If the file is
not on the current drive and directory, specify the path with the filename.
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3 Press Y or Enter to confirm you want to delete the file.

4 Press F10 or choose OK to delete the file.

RENAME Pull-down: ALT + F, E
Classic: E

Renames a file.
Follow these steps to rename a file:
7 Choose File=Rename, or use the E classic command.

2 In the Rename dialog box, specify the name of the file to rename. If the file
is not on the current drive and directory, specify the path with the filename.

3 Type a new name for the file.

If the filename you specify is the name of an existing file, WordStar tells you
that the file already exists. Type a different name.

4 Press F10 or choose OK to rename the file.

TIP You can move a file when you rename it by specifying the path with the
filename. The new location must be on the same disk drive.

PROTECT/UNPROTECT Pull-down: ALT + F, C
Classic: C

Protects a file so that it can’t be changed, or removes protection from a
protected file.

Use this command to protect master versions of form documents and final

drafts of documents so they can’t be changed accidentally. You may want to
protect files if you share disks with other people. You can remove the
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protection whenever you want. Follow these steps to protect a file or remove
the protection from a file.

1 Choose File=Protect/Unprotect, or press C, the classic command.

2 In the Protect/Unprotect dialog box, specify the name of the file to protect or
unprotect. If the file is not on the current drive and directory, specify the
path with the filename.

WordStar shows whether the file is currently protected and asks if you want
to change the setting.

3 Press F10 or choose OK to protect or unprotect the file.

When you edit a protected file, Protect is displayed in the status line. You can
move through the file, but you can’t use commands that would change it, and
you can’t add or delete anything. To leave a protected file, choose File=>Close
or use the AKQ classic command.

WordStar automatically protects backup files (.BAK) from changes as a safety
measure. Files are also protected by DOS if you have too many files in the root
directory of a disk (for most disks, 110-112 files). You must remove some files
from the full directory to unprotect the files in the directory.

You can also protect files (or make them read-only) using the operating system
or other software, such as local area network (LAN) software. WordStar can’t
unprotect files protected by other software.

CHANGE DRIVE/DIRECTORY Pull-down: ALT + F, V
Classic: L

Changes the logged drive and directory.
The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive and directory unless you tell it

otherwise.

1 Choose File=Change Drive/Directory, or use the L classic command.
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2 In the Change Drive/Directory dialog box, specify the name of the drive and
directory to change to.

3 Press F10 or choose OK.

CAUTION When you change disks in a floppy disk drive, log on to the
drive again. If you don’t, the operating system may refuse to write to the disk,
or it may damage data on the new disk. (Never remove a floppy disk while
you're editing a file on it and then log on to the drive again.)

CHAN GE FILENAME DISPIAY Pull-down: ALT + F, H
Classic: F

Changes which filenames are displayed in the filenames list.

When you choose File =>Change Filename Display, or use the F classic command,
the Change File Listings dialog box appears. Type the filenames you want to
see at the Opening screen. Use the * and ? wild-card characters. For example,
begin with CHAP, have four more characters, and have no filename extension.
Note: You can omit all filenames with a certain extension from the filename

list using WSCHANGE (CEC). For more information, see “Open Document” in
this chapter.

RUN DOS COMMAND Pull-down: ALT + F, R
Classic: R

Allows you to run a DOS command without leaving WordStar.

When you use this command, WordStar temporarily moves into the back-
ground, and you can type the DOS command you want. For example, you can
start Lotus 1-2-3 and look up information on a spreadsheet, or you can use the

DOS CHKDSK command to check how much free disk space you have.

7 Choose File=Run DOS Command, or use the R classic command.
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2 In the Run DOS Command dialog box, type the DOS command to run.

3 Press F10 or choose OK.

TIP If you want to run more than one DOS command without returning to
WordStar, type command and press Enter to run the DOS command processor.
You can then run as many commands as you want. When you finish using DOS
commands, type exit and press Enter. Then press any key to return to WordStar.

The amount of memory you can use to run DOS commands depends on how
much memory WordStar is using, whether you are using any memory-resident
programs, how much EMS memory is available to WordStar, and how much
disk space is available.

CAUTION Never load a memory-resident program (such as DOS PRINT
or Sidekick) using this command. If you plan to use such a program from
within WordStar, be sure you load it before you start WordStar.

S TATUS

Pull-down: ALT + F, U

Displays the Status screen.

“

Classic: ?

Current Filename: C(noned Continue
Inset: Not Loaded
Default printer: DRAFT
Release: WordStar for DOS North American Uersion 7.8 Reu. A
Serial Number: 12345678
Language: United States (881)
— Memory Usage
WordStar: 218k Messages: 2k Hyphenation: Bk
Text and Data: 86k Printing: Bk Thesaurus: Bk
Spelling: 8k
Conuentional Memory In Use: 298k Available: 278k
Expanded Memory C(EMS) In Use: 256k Available: 4336k
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The Status screen gives information on last file edited, Inset status, default
printer, WordStar version and serial number, language, and memory usage.

E XIT WORDSTAR Pull-down: ALT + F, X
Classic: X

Exits WordStar.
If you’re printing in the background when you use the Exit command, the Print-

ing screen appears. You must wait until printing finishes, or press Esc to cancel
printing, before you exit WordStar.



CHAPTER 3

OPENING SCREEN
UTILITIES MENU

The Opening Screen Ultilities menu includes commands for creating an index or
a table of contents and for using the WordStar macro system.

Utilities]
T

TOC...
Macros >

~
m
Z
Z
o)
%]
9
=
m
m
Z
&
~
-
=
m
¥,
=
™
Z
c

Jl%V])lle Pull-down: ALT + U, I
Classic: 1

Creates an index.
You can create an index from entries you’ve already made in a document, or
you can tell WordStar to index every word except those listed in an exclusion

list. (Exclusion lists are described later in this section.)

For information on marking index entries in your documents, see “Index/TOC
Entry” in “Editing Screen Insert Menu.”
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Follow these steps to create an index:
7 Choose Utilities=>Index, or use the | classic command.

2 In the Index dialog box, specify the name of the file to index. Specify the
directory path if necessary.

3 Select any options you want to change. The options are described below.

Page Numbers Select All (the default) to index the entire file. To specify
the pages to index, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to index pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, indexing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Index Every Word If you don't select this check box (the default), WordStar
indexes only the entries you’ve marked and typed. If you select this option,
WordStar indexes all those entries, and all the words in the document minus
any words that appear in exclusion lists.

)
z
Wy
E \
Y5}
y
=~
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&=
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z
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Pages To index only odd or only even pages, select Odd or Even. The
default is Both.

4 Press F10 or choose OK to create the index.

WordStar creates an index file that has the same filename as the document with
the .IDX extension. All entries in the file are in alphabetical order with the page
numbers listed, and duplicate entries are combined. You can edit the index file
to make any formatting changes or corrections.

EXCLUSION LISTS

An exclusion list is a nondocument file that contains an alphabetical list of
words to exclude from an index. WordStar uses two exclusion lists.

The general exclusion list is named WSINDEX.XCL and is supplied with
WordStar. It contains a list of the most common words in English (articles,
pronouns, prepositions, conjunctions, and so on) that are rarely indexed.
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The document-specific exclusion list has the same name as the document for
which you are making the index, but with the .XCL extension. To create this
list, create a nondocument file with the appropriate name, and type the specific
words from your document that you want to exclude from the index. Be sure to
type each word on a separate line.

TIP You can quickly create a document-specific exclusion list. First, use the
Index command to index every word in your document. Next, open the index
file as a nondocument and delete the words you do want in the index. Then
change the extension of the file to .XCL. This file is now an exclusion list.

TOC

Pull-down: ALT + U, T
Classic: T

Creates a table of contents.

The table of contents is created from entries you’ve previously inserted in your
document. For information on entering table of contents entries, see
“Index/TOC Entry” in “Editing Screen Insert Menu.”

Follow these steps to create a table of contents:
1 Choose Utilities=>TOC, or use the T classic command.

2 In the Table of Contents dialog box, specify the name of the file to create the
table of contents for. Specify the directory path if necessary.

3 Select any options you want to change. The options are described below.

Page Numbers Select All (the default) to include table of contents entries
from the entire file. To specify pages, select Selected Pages and type the
page numbers, separated with spaces. You can specify a range by using a
hyphen. For example, to create a table of contents for pages 1 through 3
and pages 5 and 7, type 1-3 5 7. (If you've reassigned page numbers,
when you use Selected Pages, the table of contents starts at the first
occurrence of the first number specified, and ends at the first occurrence of
the last number specified.)
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Pages To create a table of contents from entries on only odd or only even
pages, choose Odd or Even. The default is Both.

4 Press F10 or choose OK to create the table of contents.

WordStar places all the table of contents entries, with page numbers, in a new
file that has the same filename as the document with the .TOC extension. You
can edit the table of contents file to make any formatting changes or corrections.

If you specified table of contents entries for separate tables of contents using
.tc1, .tc2, and so on, WordStar creates a separate table of contents file for each
with the extensions .TO1, .TO2, and so on.

MACROS Pull-down: ALT + U, M
Classic: M

Records, creates, edits, or runs a macro that enters a longer series of text and
commands.

The WordStar macro capabilities allow you to use a few keystrokes to enter a
series of keystrokes and commands. For example, you can create a macro so
that each time you press Alt+W, the word WordStar is inserted in your text. Or
a macro can change the order of two words (mark the first word as a block,
move the cursor to the end of the next word, and move the block).

When you choose Macros, the following menu appears.

Play. .. MP
Record. .. MR

Edit/Create... MD
Single Step... MS

Copy... MO
Delete... MY
Rename. . . ME

You can create a macro in either of two ways:

= Use Record, or the MR classic command, to record keystrokes. This is the
easier way to create a macro. WordStar records commands and keystrokes



MACROS

as you enter them. When you are finished, WordStar compiles them into a
macro file that contains all the appropriate macro commands.

= Use Edit/Create, or the MD classic command, to enter macro commands into
a file that you edit like a nondocument. To use this command, you need to
know the WordStar macro language. This language allows you to create
macros that are too complex to record with the Record command. For
example, you can repeat a certain action as many times as needed each time
you run the macro. The example in “The Macro Language” in “Editing
Screen Ultilities Menu” enters a bullet character and waits for you to type
text, then repeats that sequence after the end of each paragraph; the macro
stops and returns you to editing when you finish your bulleted list.

If you need to write a macro that is too complex to record, you can first record
a simple macro that contains commands and keystrokes that can be recorded,
then use Edit/Create to add the macro language for the rest of the macro. You
can also copy a macro and edit it to create a similar one, and you can copy
blocks of macro commands from one macro file to another.

After you create a macro, you can use Single Step, or the MS classic command
to play it back step by step to identify any problems.

To execute a macro, you can either use a hot key, or use Play or the MP classic
command. You can stop the macro by pressing Esc or ABreak. (When a macro
is paused for input, you must use ~Break.) You can change the Esc keystroke or
add another key to stop a macro in WSCHANGE (DCDC and DCDD).

You can also copy, rename, and delete macros using commands on the Macros
menu.

TIP You can set up a macro to run a series of commands that you frequently
use when you start WordStar. Then you can run the macro immediately when
you start WordStar by typing ws /mmacroname. for example, you can set up a
macro named LETTER to change to the C:\CUSTOMER directory, open a new
file, and read in a file of boilerplate text and formatting. Then, any time you
want to start WordStar and start a new letter, type ws /mletter. If you want to
start WordStar, open a file, and then run a macro, type the filename before the
/m option.
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W ORKING WITH MACROS

MACRO HOT KEYS

You can execute a macro by pressing a single key or key combination called a
hot key. You can assign a hot key to a macro when you create it. Eighty-two
hot keys are available:

The function keys F2 through F9, and F11 and F12. (F1 is reserved for Help
and F10 for closing dialog boxes.)

The function keys F1 through F12 combined with the Shift key.
The function keys F1 through F12 combined with the Ctrl key.
The function keys F1 through F12 combined with the Alt key.

The Alt key combined with the letters A-Z and the digits 0-9.

Keep these points in mind about macro hot keys:

The Alt key combined with the letters F, E, V, I, S, L, U, and H access the
WordStar pull-down menus. If you use any of these keystrokes as hot keys,
you can'’t use them for those menus. (You can still display the menus using a
mouse or using the Right and Left Arrow keys in the menu bar.)

You don't have to assign a hot key to each macro. If a macro is not assigned
a hot key, you can run the macro using the Play command (or the MP classic
command).

If you want to assign a hot key to a macro that doesn’t have one, or change
the hot key assigned to a macro, use Macros=>Rename, or ME. Don’t use
Macros=>Record (MR); it will erase the macro and create a new one.

WordStar comes with predefined macros for most of the function key hot
keys and for several other hot keys. These macros are listed in Appendix D,
“Function Keys and Other Macros.” You can define new macros for these
keys if you want, using Record (MR) or Edit/Create (MD).
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MACRO FILES AND DIRECTORIES

Each macro is stored as a file, with the name you gave it while recording or edit-
ing and the .WSM extension.

CAUTION When you record, create, or edit a macro and save it,
WordStar compiles the macro, adding executable code. Macro files appear to
be nondocuments (ASCII files) when you edit them, but they contain other
information. You must edit them with Macros=>Create/Edit (or MD) to get
usable macros.

On most systems, all the macro files are stored in one directory. The default

macro directory name is WS\MACROS; you can change it with WSCHANGE
(CD2G).

Pull-down: ALT + U, M, P
Classic: MP

Executes a macro.

You can execute a macro either using a hot key or using this command. For an
explanation on using hot keys, see “Macro Hot Keys” in this section.

Follow these steps to play a macro:
1 Choose Utilities=Macros=>Play, or use the MP classic command.

2 In the Play Macro dialog box, specify the macro to play. You can choose
the macro either by name or hot key. When you press the Down Arrow key
and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.

3 Press F10 or choose OK.

WordStar executes all the commands and enters all the text specified in the
macro. Generally, menus and dialog boxes are not displayed unless you need
to enter input.

You can stop the macro by pressing Esc or ~Break. (When a macro is paused
for input, you must use ~Break.)
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REcorD

Pull-down: ALT + U, M, R
Classic: MR

Records a series of keystrokes and stores them as a macro that you can
execute.

You can create a macro by choosing Record and then pressing all the
keystrokes that you want in the macro. Follow these steps:

7

2

Choose Utilities=>Macros=>Record, or use the MR classic command.

In the Record Macro dialog box, type the name you want to give the macro.
If the macro name is already in use, confirm that you want to redefine the
macro, or specify another name.

Specify the hot key that will execute the macro. You can press the Down
Arrow key and scroll through the list to see which hot keys are available. If
the hot key you specify is already in use, confirm that you want to reassign
the hot key or specify another hot key. If you don’t want to assign a hot key
to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK.

Enter all the keystrokes you want in the macro. Enter them in the same way
you want to play them back when you run the macro.

You may need the macro to pause when you run it so that you can enter
information such as a filename. At any place you want the macro to pause,
press Alt+hyphen. Then type any number of keystrokes as an example of
the input. Press Alt+hyphen again to end the pause, and continue entering
the macro keystrokes. When you execute the macro, it pauses at that point
for input and continues after you press Alt+hyphen. (You can change the
Alt+hyphen keystroke to another keystroke in WSCHANGE (DCDB).)

Note: Mouse actions and clicks are not recorded in macros and do not
work while you are recording a macro; you must use the keyboard.
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7 When you finish entering the keystrokes, press Alt+= (hold down the Alt key

and press =). (You can change the Alt+= keystroke to another keystroke

using WSCHANGE (DCDA).)

WordStar records and compiles the macro. If you want to make adjustments to
the macro, you can either record it again or edit it using Macros=>Edit/Create,
or the MD classic command.

EDIT/CREATE Pull-down: ALT + U, M, E

Classic: MD

Creates and modifies a macro that contains keystrokes and commands that
you enter.

Each macro consists of a series of WordStar commands and functions. You edit
a macro using the same commands you use for editing a nondocument file. Fol-
low these steps:

-4

Choose Utilities=>Macros=>Edit/Create, or use the MD classic command.
In the Edit/Create Macro dialog box, specify the macro name.

When you press the Down Arrow key and scroll through the list of macros,
the description for the highlighted macro appears in the dialog box.

If you're creating a new macro, specify the hot key that will execute the
macro. You can press the Down Arrow key and scroll through the list to see
which hot keys are available. If the hot key you specify is already in use,
confirm that you want to reassign the hot key or specify another hot key. If
you don’t want to assign a hot key to the macro, you can skip this step.

Type a description of the macro to remind you of what it does and to help
you find it in the list. The description can be up to 48 characters long. If
you don’t want to give a description for the macro, you can skip this step.

Press F10 or choose OK. WordStar opens a full-screen editing window for
the macro.
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7

Type the text of the macro or make any editing changes. For information
about what you can enter, see “The Macro Language” in “Macros” in
“Editing Screen Utilities Menu.” When you edit a macro, you can use the
commands used for editing nondocuments.

TIP You may want to periodically use File=>Save (*KS) to save your
changes while editing.

When you finish, save the macro using File=>Save and Close (*KD).

WordStar compiles the macro. If it finds any syntax errors or other errors, they
are entered into the macro file. You must edit the macro again to correct the
errors.

Errors in a macro file are noted by a message describing the error, followed by
the line of the macro that contains the error, with a caret (*) below the line
pointing to the location of the error.

TIP The Alt+D hot key is preassigned to a macro that goes to the next error
message in a macro file. This is helpful when you edit macros to fix errors.

If you want to copy a block of text from one macro into another, be sure to start
from the Opening screen. Choose Macros=>Edit/Create (or MD), and then
choose File=>Open/Switch (or ~OK). Then copy the block between the win-
dows in the same way you would while editing a document.

SINGLE STEP Pull-down: ALT + U, M, S

Classic: MS

Plays back a macro one step at a time to locate errors.

After you create or edit a macro, you can play it back step by step to identify
any problems. This command is helpful when a macro doesn’t work exactly as
you expect it to. Follow these steps:

1

2

Choose Utilities=>Macros=>Single Step, or use the MS classic command.

In the Single Step dialog box, specify the macro to play. You can specify
the macro either by name or by hot key. When you press the Down Arrow
key and scroll through the list of macros, the description for the highlighted
macro appears in the dialog box.
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Press F10 or choose OK.
WordStar executes the first command or keystroke in the macro, and pauses.

Press the Spacebar to continue to the next command, function, or keystroke.
Continue in this manner until the macro finishes. You can stop running the
macro by pressing Esc or ABreak. (When a macro is paused for input, you
must use ABreak.)

Pull-down: ALT + U, M, C
Classic: MO

Copies a macro.

If you want to create a macro similar to another one, you can copy the first
macro and edit the copy. You can also make copies of macros so that several
people can use them on their computers. Follow these steps:

1

2

Choose Utilities=>Macros=>Copy, or use the MO classic command.
In the Copy Macro dialog box, specify the macro to copy.

You can specify the macro either by name or by hot key. When you press
the Down Arrow key and scroll through the list of macros, the description
for the highlighted macro appears in the dialog box.

Specify the macro name for the new copy. Type the path with the name if
necessary. If the name is already in use, confirm that you want to overwrite
the current macro.

4 Press F10 or choose OK to copy the macro.

The copied macro has the same description as the original, but is not assigned a
hot key. You can assign a hot key and description when you edit the macro, or
you can use Rename Macro (or the ME classic command).

3-11
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DELETE Pull-down: ALT + U, M, D
Classic: MY

Deletes a macro.

Follow these steps to delete a macro:

1 Choose Utilities=>Macros=>Delete, or use the MY classic command.

2 In the Delete Macro dialog box, specify the macro to delete. You can
specify the macro either by name or by hot key. When you press the Down
Arrow key and scroll through the list of macros, the description for the

highlighted macro appears in the dialog box.

3 Press F10 or choose OK to delete the macro, and confirm the deletion.

RENAME Pull-down: ALT + U, M, N
Classic: ME

Renames a macro.

You can use this command to rename a macro, assign a new hot key, or add or
edit a description. Follow these steps:

T Choose Utilities=>Macros=>Rename, or use the ME classic command.

2 In the Rename Macro dialog box, specify the macro to rename. You can
specify the macro either by name or by hot key. When you press the Down
Arrow key and scroll through the list of macros, the description for the
highlighted macro appears in the dialog box.

3 Specify the new macro name, hot key, and/or description. If the name or
hot key is already in use, confirm that you want to overwrite the current
assignment.

4  Press F10 or choose OK to rename the macro.




CHAPTER 4

(O PENING SCREEN
ADDITIONAL MENU

The Opening Screen Additional menu includes commands for starting the
MailList”, TelMerge®, and Star Exchange® companion programs.

Additional
MailList AM
TelMerge AT

Star Exchange AS

MAILLIST Pull-down: ALT + A, M
Classic: AM

Starts the MailList program.

MailList lets you easily create, update, and sort mailing lists and inventories by
providing you with ready-made forms on which to enter your data. You can
then merge print letters, envelopes, reports, labels, and lists using this data. For
information, see “MailList” in the Companion Programs manual.

@
N
™
Z
P4
%)
¥ o}
@)
=~
m
™
P4
>
O
&)
=
Q
P4
>
P~
=
m
Z
c




o)
Z
W
D
—
<t
z
Q
o
Q
Q
<<
Z
y
Ly
[~
@)
¥
O
Z
Z
W
Q.
Q

OPENING SCREEN ADDITIONAL MENU

TELMERGE Pull-down: ALT + A, T

Classic: AT
Starts the TelMerge telecommunications program.
TelMerge lets you easily link to telecommunications services such as MCI Mail

and electronic bulletin boards. It also lets you send files over your phone lines.
For information, see “TelMerge” in the Companion Programs manual.

S TAR EXCHANGE Pull-down: ALT + A, S

Classic: AS
Starts the Star Exchange file conversion program.

Star Exchange converts documents created with one word processor to docu-
ments that are compatible with another word processor. After you convert a
file to WordStar format using Star Exchange, you can edit the file with
WordStar. For information, see “Star Exchange” in the Companion Programs
manual.
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(O PENING SCREEN
HELP MENU

Use the commands on the Opening Screen Help menu to get onscreen help for
WordStar commands and options, and to change the way WordStar displays
menus and prompts.

Change Help Level...

H ELP Pull-down: ALT + H, H
Classic: F1

Displays help for the current command.

You can get onscreen help for every WordStar command and for each option in
a dialog box.

If you are using pull-down menus, when you choose Help from the Help menu,
you get an overview of WordStar help. To get help for a specific command,
highlight it on the menu and press F1. To get help in a dialog box, press F1.
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If you are using classic menus, press F1 at the Opening Menu or at the editing
screen, and then press the command you want help with. To get help in a
dialog box, press F1.

CHAN GE HELP LEVEL Pull-down: ALT + H, C
Classic: F1 F1

Changes which menus and prompts are displayed.

Once you're an experienced WordStar user, you might want to display classic
menus instead of pull-down menus, or turn off the display of menus and confir-

. mation prompts altogether. You can do either of these by changing the help
level.

The classic menus take up one third of most screens, so turning them off by
changing from help level 3 to help level 2 allows you to see considerably more
of a document while you edit. Even when menus are not displayed, you can
still use the commands.
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Follow these steps to change the help level:

7 If you are using pull-down menus, choose Help=>Change Help Level. If
you are using classic menus, press F1 F1.

2 Choose the help level you want.

HELP LEVEL DESCRIPTION

4 Pull-down menu names are displayed on the menu bar at
the top of the screen. To see a menu, hold down the Alt
key and press the first letter of the menu name. All prompts
are displayed. This is the default setting.

3 All classic menus and prompts are displayed.

2 The classic Edit Menu is not displayed, but prompts are
displayed. This gives a full-screen display of the document.
Other classic menus are displayed if you pause after
pressing the menu letter (AK, 2O, AP, Q).
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HELP LEVEL DESCRIPTION

1 No menus are displayed during editing unless you ask for
help. Dialog boxes asking you to confirm a response are
not used either.

0 Menus are not displayed unless you ask for help.
Confirmation dialog boxes are not displayed. You can
move, copy, and delete hidden blocks.

3 Press F10 or choose OK.

At help levels 2 and below, you can display the classic Edit Menu by pressing
F1.

You can change the default help level at the WINSTALL Set Basic Editing
Defaults menu or using WSCHANGE (DBAA).




CHAPTER 6

EDITING SCREEN
FILE MENU

The File menu includes commands to open, close, save, and print files, prepare
files for fax transmission, and other commands to manage files.
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Open/Suitch. .. ~0K |
Close

Save “KS
Save fis... “KT
Save and Close “KD
Print... “KS™KP
Fax... “K\
Change Printer... “P?
Copy. .. “KO
Delete. .. ~KJ
Rename. . . “KE
Change Drive/Directory... "KL
Run DOS Command. .. “KF
Status ~07
Exit WordStar “KQX
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EDITING SCREEN FILE MENU

OPEN/SWITCH Pull-down: ALT F, W

Classic: "OK

Opens a window so that you can look at two documents at once, or at two
parts of the same document. If two windows are already open, moves the
cursor to the other window.

Follow these steps to open a new window or to move the cursor to the other
window:

17 Choose File=>Open/Switch, or use the AOK classic command.

2 In the Open dialog box, specify the name of the file to open. You can open
either an existing file or a new one.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#1% " (){}-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$2? (where ? can be any character) do not
appear in the WordStar filenames lists, so don’t use them to name your text
files. You can change this list of filename extensions using WSCHANGE (CEC).

3 Press F10 or choose OK. The screen splits in half. The cursor is located in

the new file on the bottom half of the screen.

You can edit in either window. To move the cursor to the other window, use
this command or choose View=>Open/Switch Window, or use the AOK classic
command.

The title bar shows a [1] when the cursor is in the top window and a [2] when
the cursor is in the bottom window. It also shows the name of the file where
the cursor is currently located. You can use a mouse to switch to the other win-
dow by clicking this number.

The file in the second window is always opened as a document if the file in the
first window is a document, or as a nondocument if the file in the first window
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is a nondocument. If you want to be able to open a document and a nondocu-
ment at the same time, use WSCHANGE (DCGQ) to turn on the prompt that
asks you whether to open a document or a nondocument when you open a
second window.

TIP If you want to see how the document you're editing looked before you
made your most recent editing changes, you can open a second window on the
same document. The second window shows the version that you saved last, in
protected mode, because you can’t make changes to both copies.

Keep these points in mind when working with two windows:

= To change the sizes of the windows, choose View=Change Window Size,
or use the AOM classic command. You can also press A~ (hyphen) to
enlarge the current window one line at a time. For more information, see
“Change Window Size” in “Editing Screen View Menu.”

= You can mark blocks in both windows at once. To copy a block between
windows, choose Edit=>Copy=>Block from Other Window, or press KA.
To move a block between windows, choose Edit=>Move=>Block from Other
Window, or press AKG. For more information, see “Copy” and “Move” in
“Editing Screen Edit Menu.”

= You cannot edit notes or macros when you have a document in the second
window.

CLOSE

Pull-down: ALT + F, C

Closes the file you are editing.

If you have made any changes to the file since you last saved it, WordStar asks
if you want to save the changes, abandon them, or cancel the operation. The
default is to save the changes.

You can also use the AKQ classic command to close the file and abandon
changes. If you press AKQ, and you have made changes to the file since you
last saved it, WordStar tells you that you’ve made changes and asks whether
you want to abandon it anyway. The default is Yes, to abandon. If you choose
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No, WordStar returns you to editing; if you choose Save, WordStar saves the
changes and closes the file.

SAVE

Pull-down: ALT + F, S
Classic: "KS

Saves the file you’re editing, then resumes editing in the same place.

It's a good idea to use this command periodically when you're working in a file. It
guarantees you won't lose your work if you have a power failure or other problem.

When you edit an existing file, the original file stays on disk while you work on
a copy in the computer’s memory. Each time you save the file, the copy in
memory (with all your changes) goes back on the disk and replaces the original
file. The original is saved as the backup file, with the .BAK extension.

SAVE AS Pull-down: ALT + F > A

Classic: "KT
Saves the file you are editing and allows you to rename the file.
Follow these steps to save and name a file.
7 Choose File=>Save As, or use the AKT classic command.

2 In the Save As dialog box, specify the name for the file. Include a directory
path if necessary.

3 Press F10 or choose OK to save the file.
If you keep the same filename, the previous version of the file is saved as the
backup file. If you give the file a different name than it originally had, the

original file is unchanged.

T1P Ifthe current disk is full and you want to save the file to another disk,
just specify the new drive as part of the filename.
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SAVE AND CLOSE Pull-down: ALT + F, L

Classic: KD
Saves the file and returns you to the Opening screen.
This command saves the file with the same name it had when you opened it.

When you edit an existing file, the original file stays on disk while you work on
a copy in the computer’s memory. Each time you save the file, the copy in
memory (with all your changes) goes back on the disk and replaces the original
file. The original is saved as the backup file, with the .BAK extension.

TIP Ifyou try to save a file and WordStar tells you there is insufficient disk
space to save it, you can choose File=>Save As (or use “KT) to save it to a
different disk, or you can choose File=Run DOS Command (or use "KF) to
delete files from the disk so that you can save the file.

PRINT

Pull-down: ALT + F, P
Classic: "KS"KP

Saves the current file and then prints it.
This command saves the current file and then prints it (or prints another file that
you specify). The file is not closed; you can continue editing it, although your

changes aren’t printed. Follow these steps:

7 Choose File=>Print, or use the classic commands ~KS (to save the file) and
then ~AKP (to print it).

2 In the Print dialog box, change any of the print options you want. The print

options and their defaults are described below.
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Filenane: [IIXTEHIY

Page Numbers: Pages: ¢ Cancel
* All o 0dd
o Selected Pages: o Even
¢ Both
Copies:

[X] Use Form Feeds
Printer: [ 1 Pause Betueen Pages
[ 1 Print Unformatted Text
Redirect To: Interpret Merge Uariables

e ————————

Filename Specify the file to print. The default is the file you are currently
editing.

™
x
P&

Page Numbers Select All (the default) to print every page in the file. To
specify the pages to print, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, to print pages 1 through 3 and pages 5 and 7, type 1-3 5 7. (If
you've reassigned page numbers, when you use Selected Pages, printing
starts at the first occurrence of the first number specified, and ends at the
first occurrence of the last number specified.)

Copies You can print more than one copy of the document. The default
is one copy. To change it, type the number of copies you want. (If you
always want the file printed a certain number of times, you can use
Utilities=>Merge Print Commands=>Print File n Times, or the .rp dot
command. See “Merge Print Commands” in “Editing Screen Ultilities
Menu.”)

Printer WordStar displays the name of the printer assigned to the file. To
change it, type another printer name or select a name from the list of your
installed printers.

Redirect To The output normally goes to whatever port you specified for
the printer you are using. If you want to redirect the output to another port,
type the name of the port. If you want to redirect output to a disk file, type
the filename. For more information, see “Printing to Disk” in “Print” in
“Opening Screen File Menu.”
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Pages To print only odd or only even pages, choose Odd or Even. The
default is Both.

Use Form Feeds If you want WordStar to send a form feed to the printer
when moving to the next page of a printout, select this check box. Form
feeds are required for a laser printer or other sheet feeder. The default
depends on the type of printer you are using. You can use PRCHANGE to
specify a different default for each of your printers. Clear this box whenever
you print on paper shorter than 11 inches.

Pause Between Pages If you need to have the printer pause between pages
so you can feed individual sheets of paper to it, select this check box. You
can use PRCHANGE to specify a different default for each of your printers.
The default is no pause. If you select this option, WordStar pauses before
the second page and each subsequent page.

Print Unformatted Text If you select this option, WordStar prints all the dot
commands and does not execute them. Always use this option for printing
nondocuments. The check box is clear as a default.

Interpret Merge Variables Merge print variables and commands are
interpreted as a default. If you clear this check box, variable names are
printed in the text rather than the variables, and merge print commands are
ignored. For more information on merge print commands and variables, see
“Merge Print Commands” in “Editing Screen Utilities Menu.”

Note: You can change the default settings for many of the print options
using WSCHANGE or PRCHANGE.

Press F10 or choose OK to print the file.

WordStar normally prints in the background so that you can continue with what
you were doing before you started printing. The word Printing appears in the
status line. If printing stops during background printing, Print Wait replaces
Printing. You can use WSCHANGE (BDCA) to turn background printing off.
This makes printing faster.

If your file contains any Ask for Variable, Pause Print, or Clear Screen com-
mands, and you are using background printing, the Print Wait message appears
in the status line. You must press P to go to the Printing screen (described
below), and then enter the required response. [f your file contains any Display
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Message commands, you don't see the messages unless you go to the Printing
screen.

TIP The default speed for printing is full speed. However, some printers
can't receive the printing input fast enough. If you're printing while editing,
you may notice a time lag between pressing keys and the resulting onscreen
operation. To eliminate this lag, use PRCHANGE to change the printing speed
to a slower setting.

The Printing Screen shows messages and commands related to printing. The
Printing screen is hidden during background printing. You must display the
Printing screen before you can see a printing-related message or enter a printing-
related command during printing. To display this screen, choose File=>Print or
use the classic command P at the Opening screen or AKP while editing.

Printing

P Pause F Print at Full Speed

C Continue after Pausing Esc Cancel Printing
B Print from Background

Messages appear below the Printing screen commands. The commands are
described below.

COMMAND DESCRIPTION
P Pauses printing temporarily
C Continues printing after a pause
B Starts background printing and exits the Printing screen
F Starts full-speed printing if you used PRCHANGE to choose

a slower printer speed
Esc Cancels printing completely and exits the Printing screen
During printing, the Printing screen status line shows the page number that is

currently being printed. It also shows the copy number that is currently being
printed. This is useful if you are printing more than one copy of a document.
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FAX

Pull-down: ALT + F, F
Classic: K\

Creates files that you can send with a fax board.

This command creates fax files in .PCX format. These files can be transmitted
directly through a fax board using the software that came with the fax board.
The resulting faxes look like the output to the printer, including all the fonts and
other formatting.

Note: Most fax boards can transmit .PCX files. However, if your board does
not support .PCX format, you must convert the .PCX file to a format supported
by the board. Most fax board software includes a conversion utility that can
do this.

One .PCX file is created for each page in a document. All the .PCX files you
create are placed in the WS\FAX directory, which WordStar creates the first
time you create a fax file. You can specify another fax file directory using
WSCHANGE (CD4l).

Follow these steps to create fax files:
17 Choose File=>Fax, or use the AK\ classic command.

2 In the Fax dialog box, specify the name of the file to fax. If necessary,
specify the path with the filename.

3 If you want to change the displayed name for the first fax file to create,
specify the name you want. The default is the first five letters of the original
filename, followed by three digits that represent the page number, starting
with 001. Fax files for subsequent pages are numbered sequentially. The
filename extension is always .PCX.

If the filename you specify is the name of an existing file, WordStar asks if
you want to overwrite the file. If you choose Overwrite (or press Y),
WordStar deletes the old file and replaces it with the new file. If you choose
Cancel (or press N), WordStar does not create the fax files. You can start
again and use a different filename.

TIP To avoid confusion, always choose a unique filename when you
create fax files, and delete fax files promptly when you no longer need them.
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6-10

4 Change any of the options you want. These options are described below.

File to Fax: [BENIETTIEMI0e L

Fax File Location: C:\WS\FAX Cancel
Name of Fax File: [IGIHY (. PCX Resolution: B view §
o Lou

Fax Page Numbers: ¢ High
¢ All o Special 380 dpi
o

o Selected Pages: [ 9-pin Dot Matrix

o 24-pin Dot Matrix

Fax Page Numbers Select All (the default) to create fax files for every page.
To specify pages, select Selected Pages and type the page numbers,
separated with spaces. You can specify a range by using a hyphen. For
example, for pages 1 through 3 and pages 5 and 7, type 1-3 5 7.

IMPORTANT  When you use Selected Pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For
example, if you have a three-page document with no page number on the
first page, and the second and third pages are numbered 1 and 2, you must
specify 2-3 (or 2 3) to create fax files for the last two pages. If you're not
sure about the physical page numbers, you can choose View=>Preview (or
AOP). Preview displays the physical page numbers at the top of the screen
or, if more than one page is displayed, above each page.

Resolution Select the resolution your fax board uses. High resolution,
the default, is 200x200 dots per inch (dpi), and low resolution is 200x100
dpi. The Special 300 dpi option is provided for fax drivers that use this
resolution. The 9-Pin Dot Matrix and 24-Pin Dot Matrix settings are not
used for creating fax files. They create files that can be printed on a dot
matrix printer using a utility (not provided with WordStar) for printing
PCX files.

If the setting does not match the setting in your fax software, the file may not
look right when it is faxed. High resolution produces much better-looking
output. (Be sure to send the fax using the same resolution you create it with.)

View You can choose the View button to preview the file in order to
decide which pages to create fax files for. While you are previewing the
file, you can use all the usual Preview commands, including the Options
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command to create fax files. If you create fax files in Preview, you return to
editing when you exit Preview; otherwise, you return to the Fax dialog box.
For more information about Preview, see “Preview” in “Editing Screen View
Menu.”

5 When you finish, press F10 or choose OK. WordStar creates the fax file or
files, displaying the progress.

You can press Esc to cancel fax file creation after the current page, or press
Esc twice to cancel it immediately.

After you create a fax file, you can use the SHOWPCX utility to identify the file,
to make sure you've processed the correct pages, and to check the quality of
the fonts. Start at the system prompt, type showpcx fax\filename (you don't
need to type the .PCX extension) and press Enter. The fax file appears on the
screen in half-size format, so that you can see more of the page. Press the Plus
(+) key on the numeric keypad to view it in maximum resolution. You can use
the scrolling commands and PgUp and PgDn to move around on the page.
When you finish viewing the file, press Esc to exit SHOWPCX. (Depending on
your monitor and the resolution you specified for the fax file, the image may
not have the proper proportions.)

When you are working with fax files, keep these things in mind:

= The fax file is a graphic representation of the printed page and is created
using the same process as Preview. All the features and limitations of
Preview apply to creation of fax files. For example: The same fonts are
available, and a 72-point font is used for fonts that are larger than 72 points.
Colors other than white are changed to black. System variables (such as
date and time) and merge print variables are not replaced with the
corresponding data.

= For the best appearance of fonts in fax files, it's best to use the FAX.PDF
printer driver for the document. This printer driver supplies fonts
comparable to Hewlett-Packard LaserJet Il fonts, including Courier, Line
Printer, and scalable Times and Univers fonts. FAX.PDF is installed when
you install WordStar. You can add your own fonts to this PDF using
PRCHANGE.

= The best way to determine how the fax will look is by using Preview at
4x zoom. Usually (depending on your monitor resolution), this option
corresponds most closely with the fax file resolution.
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Creating fax files requires up to 27K of memory in addition to what WordStar
usually needs. You may need to free up memory for optimum performance
with fax files. For guidelines on memory usage, see Installing and
Customizing. If your fax driver software remains in memory, you may need
to remove it before starting WordStar, and send your faxes after exiting
WordStar.

If the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating screen fonts. If less than 512K is
available when you start WordStar, you can remove memory-resident
programs or use WSCHANGE settings to make more memory available, and
then run the DELCRT utility to delete the blocky fonts. Then start WordStar
and create the fax files again. You can also improve these fonts by creating
\WSF files for large fonts using smaller symbol sets. For more information on
\WSF files, see the Installing and Customizing booklet.

Fax files are large, and take up a lot of disk space. You may want to delete
them regularly. Also, .CRT files are created when you create fax files. You
can delete .CRT files that you no longer need using the DELCRT utility. For
more information, see “Preview Files” in “Preview” in “Editing Screen View
Menu.”

CHAN GE PRINTER Pull-down: ALT + F, H

6-12

Classic: “P?

Changes the printer assigned to the file you are editing.

When you choose this command, WordStar displays a list of the available
printer description files (PDFs), and you can choose the one you want. Follow
these steps:

1

2

Choose File=>Change Printer, or use the ~AP? classic command.

In the Change Printer dialog box, specify the name of the printer to use. The
list below the dialog box shows the available printers.

Press F10 or choose OK.
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After you change the printer, you can use Style=>Font (or AP=) to see the fonts
available for that printer. See “Font” in “Editing Screen Style Menu.”

After you change the printer and any fonts you need to change, be sure to refor-
mat your document (Utilities=>Reformat=>Rest of Document or the AQU classic
command).

COPY

Pull-down: ALT + F ) o0
Classic: "KO

Copies a file.

Copying makes an exact duplicate of the file being copied; the original is saved,
not erased. Follow these steps to copy a file:

1

2

Choose File=>Copy, or use the AKO classic command.

In the Copy dialog box, specify the name of the file to copy. If the file is not
on the current drive and directory, specify the path with the filename.

Specify the name of the file to copy to. You can put the copy on another
drive or directory by specifying the path with the filename.

You can use the same filename if you copy from one drive or directory to
another, but you cannot have two files with the same name in the same
directory. If the filename you give for the new copy is the name of an
existing file, WordStar asks if you want to overwrite the file. If you choose
Overwrite (or press Y), WordStar deletes the old file and replaces it with the
new file. If you choose Cancel (or press N), WordStar does not copy the
file. You can start again and use a different filename.

4 Press F10 or choose OK to copy the file.
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D ELETE

Pull-down: ALT + F = T
Classic: “KJ

Deletes a file.

Follow these steps to delete a file:

1 Choose File=>Delete, or use the ~AKJ classic command.
2 In the Delete dialog box, specify the name of the file to delete. If the file is
not on the current drive and directory, specify the path with the filename.
3 Press Y or Enter to confirm you want to delete the file.
4 Press F10 or choose OK to delete the file.
RENAME Pull-down: ALT + F, E

Classic: "KE

Renames a file.

Follow these steps to rename a file:

1

2

4

Choose File=>Rename, or use the ~KE classic command.

In the Rename dialog box, specify the name of the file to rename. I[f the file
is not on the current drive and directory, specify the path with the filename.

Type a new name for the file.

If the filename you type is the name of an existing file, WordStar tells you
that that file already exists. Type a different name.

Press F10 or choose OK to rename the file.

TIP You can move a file when you rename it by specifying the path with the
filename. The new location must be on the same disk drive.
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CHAN GE DRIVE/DIRECTORY Pull-down: ALT + F,V
Classic: "KL

Changes the logged drive and directory.

The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive and directory unless you tell it

otherwise.

1 Choose File=>Change Drive/Directory, or use the ~AKL classic command.

2 In the Change Drive/Directory dialog box, specify the name of the drive and
directory to change to.

3 Press F10 or choose OK.

CAUTION When you change disks in a floppy disk drive, log on to the
drive again. If you don’t, the operating system may refuse to write to the disk,
or it may damage data on the new disk. (Never remove a floppy disk while
you’re editing a file on it and then log on to the drive again.)

RUN DOS COMMAND Pull-down: ALT + F, R
Classic: “"KF

Allows you to run a DOS command without leaving WordStar.

When you use this command, WordStar temporarily moves into the back-
ground, and you can type the DOS command you want. For example, you can
start Lotus 1-2-3 and look up information on a spreadsheet, or you can use the
DOS CHKDSK command to check how much free disk space you have.

7 Choose File=>Run DOS Command, or use the AKF classic command.

2 Inthe Run DOS Command dialog box, type the DOS command to run.

3 Press F10 or choose OK.
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TIP If you want to run more than one DOS command without returning to
WordStar, type command and press Enter to run the DOS command processor.
You can then run as many commands as you want. When you finish using
DOS commands, type exit and press Enter. Then press any key to return to
WordStar.

The amount of memory you can use to run DOS commands depends on how
much memory WordStar is using, whether you are using any memory-resident
programs, how much EMS memory is available to WordStar, and how much
disk space is available.

CAUTION Never load a memory-resident program (such as DOS PRINT,
Inset or Sidekick) using this command. If you plan to use such a program from
within WordStar, be sure you load it before you start WordStar.

S TATUS Pull-down: ALT + F ’ U
Classic: "O?

Displays the Status screen.

d_

Current Filename: C:\WS\SHAKE.DOC

Continue

Byte count: 128
Markers set: (noned
Inset: Not Loaded
Current printer: HP3

Release: WordStar for DOS North American Uersion 7.8 Reu. A
Serial Number: 12345678
Language: United States (881>

— Memory Usag
WordStar: 210k Messages: 2k Hyphenation: Bk
Text and Data: 188k Printing: Bk Thesaurus: Bk
Spelling: Bk
Conuentional Memory In Use: 298k flvailable: 278k
Expanded Memory C(EMS) In Use: 256k Available: 4336k
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The Status screen gives information on the current filename, byte count from
the beginning of the file to the cursor position, markers set, Inset status, printer,
WordStar version and serial number, language, and memory usage.

EXIT WORDSTAR Pull-down: ALT + F, X
Classic: "KQX

Closes the file without saving changes, then immediately exits WordStar.

If you’ve made changes to the file since the last time you saved it, WordStar
prompts you to verify that you want to abandon your changes.

If you're printing in the background when you use the Exit command, the Print-
ing screen appears after you exit the file. You must wait until printing finishes,
or press Esc to cancel printing, before you exit WordStar.



CHAPTER /.

EDITING SCREEN
EDIT MENU

The Edit menu includes commands for marking and working with blocks of
text, finding and replacing text, going to various locations in the file, editing
notes, and other editing operations.

i T R R e e 0
Mark Block Beginning "“KB
Mark Block End “KK
Move >
Copy >
Delete >

Mark Previous Block "KU

Find... “QF
Find and Replace... "0A
Next Find L
Go to Character... “QG
Go to Page... ~QI
Go to Marker >
Go to Other »
Set Marker >
Edit Note “OND
Note Options >
Editing Settings >
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UNDO

Pull-down: ALT + E, U
Classic: U

Cancels or stops a command.
You can use Undo to cancel many WordStar operations. For example, you can

= Restore the text that you most recently deleted

® Cancel a response to a prompt before the response is final
= Stop a find or a find-and-replace operation

= Stop a spelling check

= Stop printing

RESTORING TEXT

When you choose Edit=>Undo or use the AU classic command, the last group
of characters you erased is restored to the screen (unerased) at the current cur-
sor location.

Undo does not unerase single characters erased with the Backspace key, the
Del key, ~G, or AH (except for note tags, index tags, graphics tags, and user
print tags). However, you can use WSCHANGE (DBEB) to specify that they can
be unerased.

TIP Unerasing is an easy way to move a phrase. Erase the text, move the
cursor to the new location, and choose Edit=>Undo.

WordStar stores your last erasure in a special memory buffer. Only the last
erasure is stored. Each time you erase something, WordStar empties the buffer
of the previous erasure and puts the current erasure in its place.

Using Undo copies the contents of the buffer into the text. It does not empty
the buffer. You can unerase the same text repeatedly. This is useful for
duplicating words and phrases.
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Normally, WordStar unerases a maximum of 500 bytes, but you can change
that value with WSCHANGE (CCJ). Keep in mind that the buffer is in working
memory. Therefore, the larger the buffer, the less memory is available for edit-
ing your files and other WordStar operations.

MARK BLOCK BEGINNING Pull-down: ALT + E, B
Classic: "KB

Marks the beginning of a block of text.

A block is a portion of text that you mark so that you can perform a task on it,
for example, move, copy, or delete it.

When you choose Edit=>Mark Block Beginning or use the ~KB classic com-
mand, the <B> marker appears. Once you mark both ends of the block, the
markers disappear, and the block is highlighted.

TIP |t's a good idea to have Command Tags display on before you mark a
block, so that you can see what commands you're including in the block. For
example, if you mark bold text, be sure to include both the beginning and end
bold command tags.

MARKING A BLOCK WITH A MOUSE

To mark a block using a mouse, position the mouse pointer where you want the
block to begin. Drag the mouse to where you want the block to end and
release the button.

If you drag the mouse down, the text above it is highlighted to the end of each
line unless column mode is on (for information on column mode, see “Editing
Settings” in this chapter).

You can also use the following keyboard/mouse button combinations to mark a
block:

Ctrl+Click If no block is marked, marks a block from the cursor to the mouse
pointer. If a block is already marked, sets a new block beginning marker.
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Shift+Click If no block is marked, marks a block from the cursor to the mouse
pointer. If a block is already marked, sets a new block ending marker.

Ctrl+Shift+Click Unmarks the block in the current window and moves the cur-

sor to the mouse pointer position.

WORKING WITH BLOCKS

Keep these points in mind when you work with blocks:

* The block beginning marker, <B>, must precede the block end marker, <K>,
in the text. In column block mode, the end marker must also be to the right

of the beginning marker.

= To mark a new block, move the cursor to the new block beginning and end
locations and mark them. The <B> and <K> markers move to the new

locations.

= A block is marked only while you are editing. After you exit the file, the

block is no longer marked.

®  You can mark one block at a time in each window.

® You can unmark the block in the current window by pressing AKU.

For more information about working with blocks, see the following sections:

TOPIC

Moving a block

Copying a block

Copying a block to another file
Deleting a block

Column blocks

Hiding a block

Inserting a block from another file

SECTION

“Move” in this chapter

“Copy” in this chapter

“Copy” in this chapter

“Delete” in this chapter
“Editing Settings” in this chapter

“Block Highlighting” in “Editing Screen
View Menu”

“File” in “Editing Screen Insert Menu”
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TOPIC SECTION

Block math “Block Math” in “Editing Screen
Utilities Menu”

Sorting a block alphabetically “Sort Block” in “Editing Screen
Utilities Menu”

Converting the case of the text “Convert Case” in “Editing Screen

in the block Style Menu”

Counting words in a block “Word/Character Count” in “Editing

Screen Utilities Menu”

MARK BLOCK END Pull-down: ALT + E, E

Classic: "KK
Marks the end of a block of text.

When you choose Mark Block End, the <K> marker appears. Once you mark
both ends of the block, the marker disappears, and the block is highlighted.

To include the carriage return in the last line of the block, mark the block end
at the beginning of the next line.

For more information on working with blocks, see “Mark Block Beginning”
above.

Move

Pull-down: ALT + E, V

Moves a block of text to the current cursor position.

The following table describes the commands on this menu and the correspond-
ing classic commands.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Block AKV Moves the marked block to the current
cursor position.

Block from ~KG Moves the block marked in the other

Other Window window to the current cursor position.

The block is inserted; it does not overtype text. The text at the original location
disappears.

For information on moving a block in column mode, see “Editing Settings” in
this chapter.

COPY

Pull-down: ALT + E, C

Copies a block of text.

Block “KC
Block from Other Windou “KA
From Windous Clipboard "KL
To Windows Clipboard “K1
To Another File... “Ku

The following table describes the commands on this menu and the correspond-
ing classic commands.

PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Block AKC Copies the marked block of text to the
current cursor position.

Block from AKA Copies the block of text marked in the

Other Window other window to the current cursor
position.

From Windows AK] Copies the block of text from the

Clipboard Microsoft Windows Clipboard to the

current cursor position.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

To Windows ~K] Copies the block of text to the Microsoft
Clipboard Windows Clipboard.

To Another File AKW Copies the marked block of text to

another file. In the dialog box, specify
the name of the file to which to copy the
block. Include a path if necessary. If
you select Copy in ASCII Format,
WordStar strips out the formatting
(command tags and dot commands) and
converts tabs to spaces. If you specify a
file that already exists, you can either
Overwrite (delete the old file and create
a new one consisting of the block) or
Append (add the block to the end of the
existing file). If you type a filename that
does not already exist, a new file is
created and the block is copied to it.

The block you copy is inserted; it does not overtype text. The text at the
original location remains where it is and is still marked as a block.

To copy a block to or from the Windows Clipboard, you must be running
WordStar under the Windows program in 386 enhanced mode. When you
copy a block from the Clipboard, the text is inserted into your WordStar file in
ASCII format. You cannot copy a block from the Clipboard if it contains
graphics or text that is not in ASCIl format. When you copy a block to the Clip-
board, all WordStar formatting commands are removed, so that only the text is
copied, in ASCII format. The block replaces the previous contents of the Clip-
board. If the block includes a note tag, only the reference number is copied; to
copy a note to the Clipboard, display the note text, mark it as a block, and then
copy it.

Note: The Windows clipboard is limited to 64K of data; if you try to copy a
larger block, only the first 64K can be copied. Also, WordStar needs up to 64K
of memory (depending on the size of the block) to copy a block to the Clip-
board; if enough memory is not available, only part of the block is copied.

For information on copying a block when you're using column mode, see “Edit-
ing Settings” in this chapter.
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D ELETE

Deletes text.

Pull-down: ALT + E, D

Block
Word
Line

Line Left of Cursor "QDel
Line Right of Cursor "QY
To Character... “QT

The following table describes the commands on this menu and the correspond-

ing classic commands.

PULL-DOWN
COMMAND

Block

Word

Line

Line Left of
Cursor

Line Right
of Cursor

To Character

CLASSIC

COMMAND DESCRIPTION

NICY

AT

A

AQDel

/\QY

/\QT

Deletes the currently marked block.
The text around it is automatically
reformatted.

Deletes from the cursor position to the
end of the word.

Deletes the entire current line (the one
containing the cursor).

Deletes the text on the same line as and
to the left of the cursor.

Deletes the text on the same line as and
to the right of the cursor.

Deletes all the text up to a specified
character. Specify the character at the
Delete to Character dialog box. You
can type a period to delete to the end of
the sentence, or press Enter to delete to
the end of the paragraph. (If display of
dot commands is off, dot commands are
not deleted.)

You can also use several other keys to delete text.
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COMMAND DESCRIPTION

AG or Del Deletes the character, space, or command tag at
the cursor.

AH or Backspace Deletes the character, space, or command tag to the

left of the cursor.

TIP Use Edit=>Undo ("U) to restore the last text deleted (except single
characters). See “Undo” in this chapter.

MARK PREVIOUS BLOCK Pull-down: ALT + E, K
Classic: "KU

Marks the block that was marked before you marked the current block or
moved a block marker.

When you choose Edit=>Mark Previous Block, or use the ~KU classic com-
mand, WordStar marks the block that was previously marked. If no block was
marked before the current one, the command has no effect.

This command allows you to work with two blocks of text. You can, for
example, mark one block and copy it, then mark another and move it, then
re-mark the first block to copy it again.

FIND Pull-down: ALT + E, F
Classic: AQF

Locates text that you specify.
Follow these steps to find text in the current document.
1 Choose Edit=>Find, or use the AQF classic command.

2 In the Find dialog box, type the text to find. Guidelines for typing text are
given after these steps.
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| BT HlCity- Boys-and- Girls: Club

options: [N = Cancel

Search:

¢ For Next Occurrence [ 1 Whole Words
o Entire File/Global [ 1 Ignore Case (WD
[ 1 Backuard
Occurrence: Z [ 1 Use 7 Wildcard Character

3 Select any options you want to use, or type the option letters in the Options
box, which shows all the selected options. Press AY if you want to clear all
the options. The options are described below. As a default, the search is for
the next occurrence and no other options are used. You can set default
options with WSCHANGE (DBGA).

Search For Next Occurrence (C) Finds the next occurrence (or the
previous one, if Search Backward is also used) after the current cursor
location.

Search Entire File/Global (G) Moves to the beginning of the file (or the
end, if Search Backward is also used) before beginning the search.

Occurrence (n) When you select this option, you also type a number, n.
Then the search goes to the nth occurrence of the search text. For example,
to find the fifth occurrence of a word in the document, type 5.

Whole Words (W) Finds whole words only. For example, if you type
“can” and don't select this option, WordStar finds “can,” “canned,”
“American,” and “scandal.”

Ignore Case (U) Ignores the case (uppercase or lowercase) of the
characters. This option finds text whether or not any letters are capitalized.

Backward (B) Searches backward from the cursor toward the beginning of
the file.

Use 2 Wildcard Character (2) Treats a question mark (?) in the search text
as a wildcard character. For example, if you type “d?g” and select this
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option, WordStar finds “dig,” “dog,” and “dug.” If you use a ? in the search
text and don’t select this option, WordStar searches for the ? character.

When you finish selecting options, press F10 or choose OK to start the find
operation. The cursor moves to the next instance of the text you typed.

If you want to go to the next instance of the text you typed, choose
Edit=>Next Find, or use the AL classic command.

To interrupt a Find operation, press Esc.

TYPING THE TEXT TO FIND

When you type the text to find, keep these things in mind:

WordStar can find any sequence of characters, including spaces and control
characters (control characters are the command tags that begin with a caret,
such as AB for bold). The text to find can be up to 65 characters long.

When you type the text to find, you must be precise. WordStar searches for
exactly what you type. If you type an extra space after a word, WordStar
finds it only if you used an extra space in the text.

You can use the question mark (?) as a wildcard character. For example, to
find all occurrences of Suzy, Susy, and Suzi, type Su??.

To specify a control character that is included in the text to find, press AP
and the character. For example, to specify a bold command (APB), hold
down the Ctrl key and press PB (be sure to hold down the Ctrl key for both
keystrokes).

To specify a hard carriage return, hold down the Ctrl key and press N. To
find a soft hyphen at the end of a line, hold down the Ctrl key and press P—.
To find a soft hyphen in the middle of a line, hold down the Ctrl key and
press P6.

Note: You can find some elements using Go To commands. See the informa-
tion on the Go To commands in this chapter.
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FIND AND REPIACE Pull-down: ALT + E, R
Classic: AQA

Locates text and replaces it with text you specify.
Follow these steps to find and replace text in the current document.
1 Choose Edit=>Find and Replace, or use the A"QA classic command.

2 In the Find and Replace dialog box, type the text to find. Guidelines for
typing text are given after these steps.

Find and Replace

|30 HlCheryl Mattheus

Replace: Cancel
Options: NN
[X1 Align
Search: [ 1 Don’t Ask
¢ For Next Occurrence [ 1 Whole Words
o Entire File/Global [ 1 Ignore Case (WD
o Rest of File [ 1 Maintain Case
[ 1 Backuard
Replace [Jji] Occurrences [ 1 Use ? Wildcard Character

—

3 Type the replacement text.

4 Select any options you want to use, or type the option letters in the Options
box, which shows all the selected options. Press AY if you want to clear all
the options. The options are described below. As a default, the search is for
the next occurrence and no other options are used. You can set default
options with WSCHANGE (DBGA).

Search For Next Occurrence (C) Finds the next occurrence (or the
previous one, if Search Backward is also used) after the current cursor

location.

Search Entire File/Global (G) Searches globally through the entire file
starting from the beginning (or the end if Search Backward is also used).
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Search Rest of File (R) Searches through the rest of the document for all
occurrences of the text.

Replace n Occurrences (n) When you select this option, you also type a
number, n. Then WordStar finds and replaces n occurrences of the text.
For example, to replace five occurrences of a word, type 5.

Align (A) Aligns the paragraph after replacement. After reaching the end of
the paragraph, the cursor returns to the spot where the replacement was
made. If you don’t use this option, you may need to reformat your
paragraphs after replacing text.

Don’t Ask (N) Replaces text without asking whether or not you want to
make the replacement. As a default, the replace operation is displayed so
that you can keep track of it.

Whole Words (W) Finds whole words only. For example, if you type
“can” and don’t select this option, WordStar finds “can,” “canned,”
“American,” and “scandal.”

Ignore Case (U) Ignores the case (uppercase or lowercase) of the
characters. This option finds text whether or not any letters are capitalized.

Maintain Case (M) Enters the replacement text using the same case as the
text you're replacing.

Backward (B) Searches backward from the cursor toward the beginning of
the file.

Use ? Wildcard Character (?) Treats a question mark (?) in the search text
as a wildcard character. For example, if you type “d?g” and select this
option, WordStar finds “dig,” “dog,” and “dug.” If you use a ? in the search
text and don't select this option, WordStar searches for the ? character.

TIP When you select Entire File or Rest of File with the Don’t Ask option,
you can turn off the display of replacements to speed up the operation. Just
press the Spacebar after the operation starts.

5 When you finish selecting options, press F10 or choose OK to start the Find
and Replace operation. The cursor moves to the next instance of the text
you typed and WordStar asks whether you want to replace this instance

(unless you selected the Don’t Ask option).
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6

7

Choose Yes to replace the text or No to skip this instance.

If you selected the Entire File option, WordStar goes to the next instance of
the text to find, and you repeat step 6.

If you didn’t select the Entire File option, and you want to go to the next
instance of the text you typed, choose Edit=>Next Find, or use the AL classic
command.

To interrupt a Find and Replace operation, press Esc.

TyYPING THE TEXT TO FIND

When you type the text to find or the replacement text, keep these things in
mind:

WordStar can find and replace with any sequence of characters, including
spaces and control characters (control characters are the command tags that
begin with a caret, such as ~B for bold). The text to find and the
replacement text can each be up to 65 characters long.

When you type the text to find, you must be precise. WordStar searches for
exactly what you type. If you type an extra space after a word, WordStar
finds it only if you used an extra space in the text.

You can use the question mark (?) as a wildcard character in the text to find.
For example, to find all occurrences of Suzy, Susy, and Suzi, type Su??.

To specify a control character that is included in the text to find or the
replacement text, press AP and the character. For example, to specify a bold
command (*PB), hold down the Ctrl key and press PB.

To specify a hard carriage return, hold down the Ctrl key and press N. To
find a soft hyphen at the end of a line, hold down the Ctrl key and press P-.
To find a soft hyphen in the middle of a line, hold down the Ctrl key and
press P6.

Note: You can find some elements using Go To commands. See the informa-
tion on the Go To commands in this chapter.




NEXT FIND

NEXT FIND Pull-down: ALT + E, X
Classic: "L

Locates the next instance of text you specified with Find or Find and Replace.

If you used Find, WordStar moves the cursor to the next occurrence of the
specified text and returns you to the editing screen.

If you used Find and Replace, WordStar moves the cursor to the next occur-
rence of the specified text, asks whether you want to replace it, replaces it if
you answer Yes, and then returns you to the editing screen.

GO TO CHARACTER Pull-down: ALT + E, G
Classic: AQG

Moves the cursor to the next occurrence of a particular character.
To go to a character, follow these steps:
1 Choose Edit=>Go to Character, or use the *QG classic command.

2 In the Go to Character dialog box, type the character to go to. You can type
any character, or you can press Enter to go to the end of the paragraph.

If dot command display is off, WordStar ignores characters in a dot command.

GO TO PAGE Pull-down: ALT + E, P
Classic: AQI

Moves the cursor to the first character on the page (or line, in a
nondocument) you specify.

Follow these steps to go to a page:

1 Choose Edit=Go to Page, or use the ~QI classic command.
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2 In the Go to Page dialog box, type the page number to go to. You can also
type the Plus ( + ) sign for the next page or the Minus (- ) sign for the
previous page. To go forward or back a certain number of pages, type +n or
-n, where n is the number of pages to move. For example, +6 moves the
cursor forward six pages.

3 Press F10 or choose OK.

GO TO MARKER Pull-down: ALT + E ’ M
Classic: AQ 0-9

Moves the cursor to the marker you specify.
To move the cursor to a marker, choose Go to Marker, and then choose a num-
ber for the marker (0-9) from the menu that appears. Alternately, you can use

the classic command AQ followed by the marker number.

For information on setting markers, see “Set Marker” in this chapter.

GO TO OTHER Pull-down: ALT + E, (0]

Moves the cursor to a particular location.

Font Tag e
Style Tag K
Note. .. “ONG
Previous Position “QP
Last Find/Replace “QuU
Beginning of Block “QB
End of Block “QK
Document Beginning “QR
Document End ~QC
Scroll Continuously Up  "QU
Scroll Continuously Doun "QZ

The following table describes the commands on this menu and the correspond-
ing classic commands.
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PULL-DOWN
COMMAND

Font Tag
Style Tag

Note

Previous Position

Last Find/Replace

Beginning of Block
End of Block
Document Beginning

Document End

CLASSIC

GO TO OTHER

COMMAND DESCRIPTION

AQ=
Q<

AONG

AQP

AQV

AQB

AQK

AQR

~rQC

Moves the cursor to the next font tag.

Moves the cursor to the next paragraph
style tag.

Moves the cursor to the next note.
Select the type of note (the default is
Any Note). Specify Note Tag Only to
move to the note tag. If this check box
is clear, WordStar opens a window on
the note, and you can specify text to
locate within the note and options for
the text. (If no text is specified,
WordStar goes to the beginning of the
note.) See “Find and Replace” in this
chapter for information on the options.

Moves the cursor to where it was
located before the previous operation.

Moves the cursor to the previous Find or
Find and Replace location or to the last
block location.

Moves the cursor to the beginning of the
currently marked block.

Moves the cursor to the end of the
currently marked block.

Moves the cursor to the beginning of the
document.

Moves the cursor to the end of the
document.
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PULL-DOWN CLASSIC

COMMAND COMMAND DESCRIPTION

Scroll Continuously Up AQW Scrolls continuously up, one line at a
time. When you choose this command,
the screen starts scrolling up toward the
beginning of the document (the text
moves down). You can stop the
scrolling by pressing any key.

Scroll Continuously rQZ Scrolls continuously down, one line at a

Down time. When you choose this command,
the screen starts scrolling down toward
the end of the document (the text moves
up). You can stop the scrolling by
pressing any key.

S ET MARKER Pull-down: ALT + E, S

Classic: "K 0-9
Puts a temporary marker in the file to mark a certain location.

You can use place markers to help find your place in a file. Once you set a
marker, you can then quickly move the cursor to that location. You can put up
to 10 markers in a file.

To set a marker, choose Edit=>Set Marker, and then choose a number for the
marker (0-9) from the menu that appears. Alternately, you can use the classic
command ~K followed by the marker number.

To move a marker, move the cursor to the new location and choose
Edit=>Set Marker (or AK) with the same marker number. To delete a marker,
move the cursor to the marker and use Set Marker with the same marker
number.

To move the cursor from anywhere in the file to a marker, use Go to Marker or
the classic command ~Q followed by the marker number. See “Go to Marker”
in this chapter.



EDIT NOTE

Markers are in effect only while you edit the file. They are not saved when
you exit.

If you sort text that contains markers, the markers stay in their original location
and do not move with the text.

EDIT NOTE Pull-down: ALT + E, N
Classic: "OND

Allows you to edit an existing footnote, endnote, annotation, unprinted
comment, or index entry.

Follow these steps to edit a note:

1 Place the cursor on the note you want to edit.

2 Choose Edit=>Edit Note, or use the AOND classic command.
If the note is a footnote, endnote, annotation, or unprinted comment,
WordStar opens a window on the note so that you can edit it. Or, if the
note is an index entry, the Edit Index Entry dialog box appears.

3 If the note is a footnote, endnote, annotation, or unprinted comment, edit
the note as you would a document. When you finish editing, choose

File=>Save, or press ~KD, to save your changes.

Or, if the note is an index entry, edit the entry, and then press F10 or choose
OK to save your changes.

This command is used for editing existing notes only. For information on insert-
ing notes, see “Note” and “Index Entry” in “Editing Screen Insert Menu.”
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N OTE OPTIONS Pull-down: ALT + E, T

STARTING NUMBER FOR NOTE

Sets options for notes.

Starting Number for Note...

Convert Note... “ONU
Convert at Print... .cv
Endnote Location .pe

Pull-down: ALT + ET,S

Changes the starting number for footnotes and endnotes.

Footnotes and endnotes are usually numbered, starting with 1. You can change
the starting number, or change to a letter sequence. You can also choose to
restart footnote numbering on each page or to number footnotes consecutively
throughout the document.

It's usually best to use this command at the beginning of the file; otherwise,
only the subsequent notes will be numbered in the new sequence. Follow
these steps:

1

Choose Edit=>Note Options=>Starting Number for Note or use the AONN
classic command.

In the Starting Number for Note dialog box, choose Footnote Starting Value
or Endnote Starting Value.

Type the new starting number or letter. For example, you could type A to
use an alphabetical sequence, 4 to use a numeric sequence starting with the
number 4 rather than the number 1, or F to use an alphabetical sequence
starting with F.

As a default, footnote numbers start with the starting value on each

page. To number footnotes sequentially throughout the document, select
Continuous Through Document. To return to the default, select

Restart on Each Page.

Press F10 or choose OK.
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WordStar inserts the .f# (footnote numbering) or .e# (endnote numbering) dot
command, followed by the new starting number or letter, for example, .e# a.
The .f# command can also have a d for numbering throughout the document or
a p to restart numbering on each page, for example, .f#d 1. You can get the
same result by typing the .f# or .e# command. To return to default numbering,
delete the dot command line.

CONVERT NOTE Pull-down: ALT + E, T, C
Classic: ONV

Converts a footnote, endnote, annotation, or comment to another type of note.
7 Place the cursor on the note you want to convert.

2 Choose Edit=>Note Options=>Convert Note. Alternately, you can use the
AONV classic command.

3 In the Convert Note dialog box, select the type of note to convert to.

4 Press F10 or choose OK.

CONVERT AT PRINT Pull-down: ALT + E, T, P
Classic: CV

Converts all footnotes, endnotes, and comments from one type of note to
another for printing only.

This command allows you to print all notes of one type as another type of note.
For example, if you have both footnotes and endnotes in one document, you
can print all the notes as footnotes, and they will be numbered consecutively.
You can also print comments as either endnotes or footnotes.

17 Choose Edit=>Note Options=>Convert at Print.

2 Inthe Convert at Print Time dialog box, select the appropriate conversion
or conversions.

3 Press F10 or choose OK.
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The .cv dot command is inserted, followed by the appropriate conversion. The
possible dot command lines are .cv f>e (print footnotes as endnotes), .cv e>f
(print endnotes as footnotes), .cv ¢>f (print comments as footnotes), and

.cv c>e (print comments as endnotes). You can get the same result by typing
the appropriate .cv command. To delete the conversion, delete the dot com-
mand line.

The notes will be converted when you print. Each note will appear the same as
the printed type of note in the text, but will revert to its original type if you
remove the .cv dot command. To convert a note permanently, use the Convert
Note command on this menu.

ENDNOTE LocATION Pull-down: ALT + E, T, E

Classic: .PE
Changes the location in the file where endnotes are printed.
Endnotes are usually printed at the end of a file, but you can print them at
another location using this command. For example, if you have three chapters
of a book in one file, you can print the endnotes for each chapter at the end of
that chapter rather than printing all of them at the end of the third chapter.
1 Place the cursor at the first location where you want to print endnotes.
2 Choose Edit=>Note Options=>Endnote Location.
All the endnotes that are inserted earlier in the file will be printed at this
location. Subsequent endnotes will be printed at the next location where
you use this command. Endnotes that come after the last location where

you use this command will be printed at the end of the document.

The .pe dot command is inserted. You can get the same result by typing the .pe
command. To delete the endnote location, delete the dot command line.

For information about endnotes, see “Note” in “Editing Screen Insert Menu.”
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E DITING SETTINGS Pull-down: ALT + E, I

Changes settings for column block mode, column replace mode, auto align,
and for using the Enter key in dialog boxes.

Column Block Mode “KN

Column Replace Mode "KI
.Auto Align ~0A
.4 Closes Dialog "0«

These settings are either on or off. When a setting is on, a dot is displayed next
to it on the menu. To change a setting, choose the command or use the cor-
responding classic command.

COLUMN BLOCK MODE Pull-down: ALT + E, I, C
Classic: "KN

Turns column block mode on and off.

In column block mode, block operations are performed with column blocks, as
opposed to regular blocks. With column block mode on, the beginning and
end block markers define the top-left and bottom-right corners of the block.

column mode off column mode on

AKBtext text ~“"KBtext text
text text text text text text
text text text text text text
text textAKK text textAKK

You can use column block mode, for example, to switch two columns of infor-
mation in a table. When column mode block is on, the word Column appears
in the status line.

TIP If your text contains command tags, turn on Command Tags display
before marking the block to make sure you include the command tags in the
block. Then turn off Command Tags display to make sure you included all the
columns you want in the block.
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Keep these points in mind when you work with column blocks:

= A dot command is not considered part of a column block. If you move or
delete a column block, a dot command within the block remains at its
original location.

= When column block mode is on, moving, copying, inserting, or deleting a
block affects the surrounding text. It's a good idea to save your work just
before doing any of these operations, so you can go back to the previous
version quickly. Also see “Column Replace Mode” below.

= When you sort a column block (Utilities=>Sort Block, or AKZ), WordStar uses
the highlighted portion of each line to determine how to sort the entire line.

= When you insert a file (Insert=File, or AKR) when column block mode is on,
WordStar expects the inserted file to be a column; it inserts the file one line
at a time and expects all lines to be the same length. If a line in the block is
not the same length as the previous lines, WordStar pauses and warns you.

For more information on working with column blocks, see “Column Replace
Mode” below. For information on blocks, see “Mark Block Beginning” and
“Mark Block End” in this chapter.

COLUMN REPLACE MODE Pull-down: ALT + E, I, R

Classic: “KI

Turns column replace mode on and off.

Column replace mode determines how moving, copying, inserting, and deleting
column blocks affect the surrounding text. Column replace mode is effective
only when column block mode is on. When column replace mode is on,
Column-Repl appears in the status line.

When column replace mode is on, if a block is moved or deleted, spaces
replace the block, leaving a “hole” at its original location. A moved, copied, or
inserted block replaces any text at the cursor. You can use Edit=Undo, or AU,
to restore that text.

CAUTION Ifthe text that is replaced is too long to fit in the undo buffer,

no warning is given, and you will be unable to restore all the text. See “Undo”
in this chapter for more information.
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When column replace mode is off, if a block is moved or deleted, surrounding
text fills in the space that was originally occupied by the block. A moved,
copied, or inserted block pushes to the right any text at its new location.

AUTO ALIGN Pull-down: ALT +E, I, A
Classic: “"OA

Turns auto align off or on.

When you edit a document, you often change the length of lines. WordStar
then aligns the paragraph you’re editing to fit the lines within the margins. This
is called auto align. When you start WordStar, auto align is normally on.
When auto align is off, text in a paragraph is not realigned when you edit that
paragraph.

Use this command to turn auto align on and off while you’re editing.

Auto align works only in paragraphs that you edit. You must use
Utilities=>Reformat, or AB or AQU, to reformat other paragraphs or the rest
of the document. You would use Reformat, for example, if you changed

margin or tab settings. See “Reformat” in “Editing Screen Utilities Menu.”

If you turn off Word Wrap (Layout=>Alignment and Spacing, or .aw), Auto Align
is also off until you turn Word Wrap on again.

You can change the default setting for auto align using WSCHANGE (DBCE).

Pull-down: ALT + E, I, D
Classic: O

) CLOSES DIALOG

Changes the function of the Enter key in dialog boxes.

Normally, when you press the Enter key in a dialog box, WordStar closes the
dialog box. Use this command to make the Enter key move the cursor to the
next option. At the last option, the Enter key still closes the box.

This command changes the Enter key function for the current editing session.
You can change the default setting using WSCHANGE (DBH2D).




CHAPTER 8

EDITING SCREEN
VIEW MENU

The View menu includes commands for previewing your printed document
onscreen, turning on and off the display of command tags and other screen
elements, and opening, switching, and sizing windows.

Previeu “0P
Command Tags “0D

Block Highlighting “KH

Open/Suitch Windouw “OK
Change Windou Size... "OM

Screen Settings... “0B
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P REVIEW Pull-down: ALT +V, P
Classic: "OP

Displays the document onscreen exactly as it will appear printed.
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When you start Preview, you see the current page onscreen, with columns,
headers, footers, footnotes, fonts, line spacing, and so on. At the top of the
screen is the Preview menu bar. The commands on the Preview menus let you
move around in your document and change your view of the document. You
can view another page, choose a different view of a page or pages, scan a range
of pages, and display a grid for checking page alignment. You can also prepare
faxes for transmission.

The Preview commands are described below.




Go 1o

ViEw

Pull-down

PREVIEW

. ALT+V, P, G
Classic: "OPG

Previews another page.

GO To

| Specified Page ...
{ First Page -
| Last Page
Next Page
| Previous Page

To display the first, last, next, or previous page, choose the appropriate option.
To preview a specific page, choose Specified Page, type the page number and
press Enter. Preview goes to the specified physical page and ignores any page
number commands you may have set. If Preview is displaying more than one
page, the page you specify will be the first page at the top of the screen.

Pull-down: ALT +V, P,V
Classic: "OPV

Previews the document from any of several perspectives.

Uiew

f! “ntire Page
Facing Pages

Multiple Pages

} Thumbnail Display

1 2x Zoon :

4 4x Zoom

1 Adjust Window ...

Entire Page Displays the entire current page, the same view as when you first
choose Preview.

Facing Pages Zooms out and displays two pages next to each other, the way
pages look in a book or newsletter.
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Multiple Pages Zooms out and displays four to ten pages, depending on your
monitor and the page size. It is good for looking at the overall layout of a short
document, or a section of a longer one.

Thumbnail Display Zooms out and displays ten or more pages, depending on
your monitor and the page size. It's good for looking at the overall layout of a
document. Press APgDn or ~PgUp to see the next set or the previous set of
pages. Press AHome or AEnd to see the first or last page of a document. To
zoom in on a specific page, use the direction keys to move the highlighting to
the page number, and then choose the magnification.

TIP You can quickly change the magnification by using the Plus (+) or
Minus (<) keys on the numeric keypad. For example, if you’re viewing the
thumbnail display, press + to see the multiple pages display. If you’re viewing
the entire page display, press — to see facing pages.

2x Zoom Zooms in and makes the page appear twice as large. You can then
use the direction keys to move the display window to a different part of the
page. For example, press the Down Arrow key or AX to move down a few
lines, or press PgDn or AC to move down a full screen. Use APgDn to move to
the next page.

4x Zoom Zooms in and makes the page appear four times as large. You can
use the same commands as you can with 2x Zoom.

Adjust Window Lets you move to a different part of the page. When you
choose this command, WordStar displays a small picture of the page with a box
outlining the current window display. Use the direction keys to move the box
to the area of the page you want to see. (To move the box more quickly, use
the Shift key with the direction keys.) When the box is where you want it,

press Enter to return to the page. The area you selected appears on the screen.

TIP To adjust the window display without choosing View and Adjust
Window, press Insert to display the box, and use the direction keys to move it.
When you stop moving the box, WordStar returns you to the page.
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OPTIONS Pull-down: ALT +V, P, O
Classic: "OPO

Scans the document, displays a grid to check the alignment of text, and
prepares faxes for transmission.

These options are described below.

Automatic Scan Shows successive portions of the document until you
press Esc.

TIP To locate a portion of your document quickly, scan the document in
thumbnail display, then press Esc when you see the page you want. Move the
highlighting to that page number and choose a View command to preview, or
press Alt+1 or choose Return to Editing and then Current page to exit Preview
and edit that page.

Scan Range Scans a specified range of pages. After you choose Scan range,
you specify the page numbers where you want the scan to start and stop.

Fax Files for Entire Document Creates a .PCX file for each page of the docu-
ment. You can send these files through a fax board using the software that
came with the board. The resulting page printed by the fax machine at its
destination looks exactly like the previewed page. If you did not start Preview
from the Fax dialog box, WordStar prompts you for a five-letter name for the
first fax file. The default name is FnnnPmmm.PCX, where nnn is a document
number and mmm is the page number, assigned sequentially. The default
resolution is used (high resolution unless you’ve changed the value for FAX_RES
in the FONTID.CTL file).

When you choose this command, an entire view of each page is displayed in
Preview as its .PCX file is created, and the .PCX filename is displayed at the top
of the screen. When all the .PCX files are created, Preview displays the entire
page view of the last page for which a .PCX file was created. The .PCX files are
created in the WS\FAX directory. (The fax directory is a subdirectory of the
directory that contains the FONTID.CTL file. If it doesn’t already exist when
you create fax files, WordStar creates it.)

You can also create fax files using the Fax=>File command. For more informa-
tion on creating fax files, see “Fax” in “Opening Screen File Menu.”
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Exir

Fax Files for Range Creates fax files for a specified range of pages. After you
choose this command, you specify the page numbers where you want the range
to begin and end. For more information on creating fax files, see the informa-
tion above on the previous command, Fax Files for Entire Document. If you
want to create fax files for several ranges, just use this command as many times
as necessary.

IMPORTANT  When you specify the range of pages, you must specify the
physical page numbers, even if you've reassigned page numbers. For example,
if you have a three-page document with no page number on the first page, and
the second and third pages numbered 1 and 2, you must specify 2-3 to print the
last two pages. If you're not sure about the physical page numbers, you can
check them using Preview. Preview displays the physical page numbers at the
top of the screen or, if more than one page is displayed, above each page.

Grid Display On/Off Displays a grid across the page. Grid display is useful
for making sure your text is properly aligned.

Pull-down: ALT + V, P , E
Classic: "OPE

Exits Preview and returns you to the editing screen.

You can choose to return to the page you're currently viewing or to the original
page you were editing when you chose Preview.

To return to the page you're currently viewing, choose Current Page or

press Alt+1. If you're in a view that displays more than one page, you return
to the page whose number is highlighted. To return to the page you were edit-
ing before you chose Preview, choose Original Page or press Alt+2.

PREVIEW FILES

Preview creates CRT directories containing screen font files (.CRT) and graphics
files (.Gn$, where n is a number) in your WordStar directory. WordStar may
create a number of CRT directories, depending on your monitor(s) and on the
page size and orientation.
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The .CRT files are created when you preview a document with fonts that you
haven’t previewed before. Each time you see the message Building preview font,
WordStar is creating a .CRT file.

The .Gn$ files are created when you use the zoom commands in Preview with
graphics (.PIX) files.

Each time you preview a document that contains a new Inset graphic, a

\WSG file is created. This file contains specific graphics information that is
needed for Preview. The .WSG files are stored in the directory that contains
your .PIX files. To save disk space, you can delete the .WSG files when you're
finished with them (use the DOS DEL command).

To save disk space, you may want to delete the .CRT and .Gn$ files and the
CRT directories periodically, especially if they contain files for fonts and
graphics that you are no longer using. You can delete these files and directories
individually by using the DOS DEL and RD commands, or you can delete them
all at once by using the DELCRT.EXE program, which is in your WordStar direc-
tory. At the DOS prompt in the WordStar directory, type delcrt and press Enter.
DELCRT.EXE deletes all of the .CRT files, .Gn$ files, and CRT directories from
your WordStar directory. (Note that DELCRT deletes only those .CRT files with
eight digits in the filename (nnnnnnnn.CRT).

PREVIEW ADVISORIES
Keep these points in mind when you use Preview:
= Preview works only on monitors with graphics capability.

= Preview can’t run with two windows open, unless you are have at least 80K
(5 pages) of EMS memory available.

= |f the appearance of fonts (especially large fonts) is blocky, WordStar may
need more memory while creating fonts. If less than 512K is available when
you start WordStar, you can remove memory-resident programs or use
WSCHANGE settings to make more memory available, and then run the
DELCRT program to delete the blocky fonts. Then start WordStar and use
Preview again. You can also improve these fonts by creating .WSF files for
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large fonts using smaller symbol sets. For more information on .WSF files,
see the Installing and Customizing booklet.

= |f an Inset graphic is too compressed (for example, if a very large graphic is
reduced to a small size for printing), it won’t be displayed correctly in
Preview.

= Preview does not support text mode .PIX files. If you want to preview a page
with a text mode pix file, you must first convert the .PIX file to graphics
mode, which may affect the appearance of the printed page. For more
information, see “Converting a text screen to graphics” in the “Inset” section
of the Companion Programs manual.

= |[f you often start WordStar from ProFinder™, you may want to redefine the
+ and - ProFinder hot keys. Otherwise, you won’t be able to use the + and
— keys as zoom keys in Preview. For more information, see “Setting the
Configuration Options” in the “ProFinder” section of the Companion
Programs manual.

COMMAND TAGS Pull-down: ALT +V, C

Classic: “OD
Turns display of WordStar command tags on and off.

WordStar command tags, such as B for bold and <COURIER 10> for a font
change, are normally displayed onscreen. However, they take up space and
may make text appear out of alignment. Choose View=>Command Tags, or use
the AOD classic command, to remove these tags from the screen while you
edit, or to display them again. The commands remain in effect even when the
tags aren’t displayed.

It's a good idea to turn Command Tags display on before you mark a block to
see what commands you’re including in the block. For example, if bold text

begins at the beginning of the block, be sure to include the tag that begins bold
in the block.

View=>Command Tags can also turn on and off the display of dot commands,
soft space characters, and the flag column at the right of the screen. You can
specify whether or not to include each of these elements in Command Tags by
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choosing View=>Screen Settings, or "OB. If display of dot commands is off
and you type a dot in column 1, the new dot command disappears after you
press Enter. For more information, see “Screen Settings” in this chapter.

You can turn Command Tags display on and off with a mouse by clicking the
[*] button in the style bar.

You can use WSCHANGE (DBAB) to turn the default setting for Command Tags
on or off and to change which elements are turned on and off when you choose
Command Tags.

B LOCK HIGHLIGHTING Pull-down: ALT +V, B
Classic: "KH

Turns block highlighting (and display of block markers) on and off.

You can use this command to hide the block markers and highlighting, and to
turn them on again. If you hide a block or a marker, and then mark a new
block beginning or end, block highlighting is turned on again.

At all help levels except 0, you can hide the marked block as a safety measure.
At these levels, WordStar won’t move, copy, erase, or write blocks when the

markers are hidden.

You can delete block markers, rather than hiding them, by pressing AK<.

OPEN/SWITCH WINDOW Pull-down: ALT +V, O
Classic: "OK

Opens a window so that you can look at two documents at once, or at two
parts of the same document. If two windows are already open, moves the
cursor to the other window.

Follow these steps to open a window or move the cursor to the other window:

7 Choose View=>Open/Switch Window, or use the AOK classic command.
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2 In the Open dialog box, specify the name of the file to open. You can open
either an existing file or a new one.

A filename can have up to eight characters and an optional extension of up
to three characters. Type a period between the filename and the extension.
Don’t use spaces between the characters. Filenames can include letters,
numbers, and these symbols:

$&#!1% " (){})-_~@

Note: Files with the extensions .COM, .EXE, .OVR, .SYS, .DCT, .CRT, .WSF,
.PDF, .DCC, .INF, .PRD, .WSM, and .$?? (where ? can be any character) do
not appear in the WordStar filenames lists, so don’t use them to name your

text files. You can change this list of filename extensions using
WSCHANGE (CEC).

3  Press F10 or choose OK.

The screen splits in half. The cursor is located in the new file on the bottom
half of the screen.

You can edit in either window. To move the cursor to the other window, use
this command or choose File=>Open/Switch, or use the AOK classic command.

The title bar shows a [1] when the cursor is in the top window and a [2] when
the cursor is in the bottom window. It also shows the name of the file where
the cursor is currently located. You can use a mouse to switch to the other win-
dow by clicking this number.

The file in the second window is always opened as a document if the file in the
first window is a document, or as a nondocument if the file in the first window
is a nondocument. If you want to be able to open a document and a non-
document at the same time, use WSCHANGE (DCGGQG) to turn on the prompt
that asks you whether to open a document or a nondocument when you open a
second window.

TIP If you want to see how the document you’re editing looked before you
made your most recent editing changes, you can open a second window on the
same document. The second window shows the version that you saved last, in
protected mode because you can’t make changes to both copies.
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Keep these points in mind when working with two windows:

To change the sizes of the windows, choose View=>Change Window Size,
or use the AOM classic command. You can also press A~ (hyphen) to
enlarge the current window one line at a time. For more information, see
“Change Window Size” in this chapter.

You can mark blocks in both windows at once. To copy a block between
windows, choose Edit=>Copy=>Block from Other Window, or press KA.
To move a block between windows, choose Edit=>Move=>Block from Other
Window, or press AKG. For more information, see “Copy” and “Move” in
“Editing Screen Edit Menu.”

You cannot edit notes or macros when you have a document in the second
window.

CHAN GE WINDOW SIZE Pull-down: ALT + V, W

Classic: "OM

Changes the number of lines displayed in a window.

When you open a second window, each window takes up half the screen.
Follow these steps to change the window size:

1

2

3

Choose View=>Change Window Size, or use the AOM classic command.

In the Change Window Size dialog box, choose Full Screen or Half Screen
or specify the number of lines you want for the current window.

If you choose Full Screen, each window takes up the full screen, and the
screen flips from one file to the other when you move the cursor between

windows.

Press F10 or choose OK.

You can specify a default window size in WSCHANGE (DCGH).

Note: You can press A— (hyphen) to enlarge the current window one line at
a time.
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SCREEN SETTINGS Pull-down: ALT +V, S

Classic: "OB

Determines which screen elements are displayed during editing.

You can use this command to turn on and off the display of several screen
elements and to decide which elements to turn on and off using
View=>Command Tags (or AOD). Follow these steps:

1

2

Choose View=>Screen Settings, or use the 2OB classic command.

In the Screen Settings dialog box, change any options you want. The
options are described below.

Screen Settings

Dot Commands: Display On Screen:
o Aluays On
¢ Display with Command Tags [X1 Scroll Bar

Flag Column: [X]1 Style Bar
o Aluways On

¢ Display with Command Tags [X]1 Status Line

Soft Space Dots: [X]1 Ruler Line

o Always On

¢ Aluays Off [X] Classic Commands on
o Display with Command Tags Pull-down Menus

Dot Commands Dot commands can be always displayed or turned on and
off with Command Tags (the default). If display of dot commands is off and
you type a dot in column one, the new dot command disappears after you
press Enter. You can change the default in WSCHANGE (DBAE).

Flag Column The flag column at the right of the screen can be always
displayed or turned on and off with Command Tags (the default). You can
change the default in WSCHANGE (DBAC).

Soft Space Dots The spaces that WordStar inserts when it justifies text to
make the line end at the right margin are called soft spaces. WordStar can
display soft spaces as small dots. These dots can be always displayed, never
displayed (the default), or turned on and off with Command Tags. You can
change the default in WSCHANGE (DBAD).
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Scroll Bar This option turns on and off the display of the vertical scroll bar
at the right of the screen. The scroll bar is especially useful for mouse users.
The default is scroll bar display on. You can change the default in
WSCHANGE (DBA)).

Style Bar This option turns on and off the display of the style bar. The style
bar displays information about current settings, and allows easy access to
these settings using a mouse. The default is style bar display on. You can
change the default in WSCHANGE (DBAG).

Status Line This option turns on and off the display of the status line. The
status line displays information about the current editing status. The default
is status line display on. You can change the default or move the status line
to the top of the screen using WSCHANGE (DBAI or DBA2B).

Ruler Line This option turns on and off the display of the ruler line at the
top of the screen. The ruler line shows the margins and tab stops that
currently apply to your text. The default is ruler line display on. You can
change the default in WSCHANGE (DBAH). You can still make changes to
the ruler when it’s not displayed. For more information on ruler lines, see
“Ruler Line” in “Editing Screen Layout Menu.”

Classic Commands on Pull-down Menus This option turns on and off the
display of classic commands on the pull-down menus. If you use the classic
commands, this display is useful as a reminder and to determine the related
pull-down commands. The default is classic commands on. You can
change the default in WSCHANGE (DBAK).

3 Press F10 or choose OK.

For more information on these screen elements, see “Screens and Dialog
Boxes” in “WordStar Basics” in this manual.




CHAPTER 9

EDITING SCREEN
INSERT MENU

The Insert menu includes commands for inserting elements such as page
breaks, other files, graphics, footnotes, and so on, into your documents.
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P AGE BREAK Pull-down: ALT + I, P

Classic: JPA
Inserts a page break.

Use Page Break when you want to force a new page to start before the next
automatic page break.

Place the cursor on the first line you want to appear on the new page, and
choose Insert=>Page Break.

The .pa dot command is inserted. You can get the same result by typing the .pa
command. To delete the page break, delete the .pa command line.

This command inserts a hard page break, which stays in the same location rela-
tive to the surrounding text when you edit the document. The page break that
WordStar automatically inserts when you fill a page is a soft one. Text moves
across a soft page break as needed when you add or delete lines.

For information on page length, see “Length of Page” in “Page Layout” in
“Editing Screen Layout Menu.” For information on keeping lines on the same
page, see “Special Effects” in “Editing Screen Layout Menu.” For information
on handling blank lines at the end of a page, see “Suppress Blank Lines at Top
of Page” in “Page Layout” in “Editing Screen Layout Menu.”

COLUMN BREAK Pull-down: ALT + I, C

Classic: .CB

Starts a new column.

WordStar automatically ends a column at the bottom of a page. Use Column
Break when you want to force a new column to start before the next automatic
column break.

Place the cursor on the first line you want to appear in the new column, and
choose Insert=>Column Break.
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The .cb dot command is inserted. You can get the same result by typing the .cb
command. To delete the column break, delete the .cb command line.

This command inserts a hard column break, which stays in the same location
relative to the surrounding text when you edit the document. The automatic
column break is a soft one. Text moves across a soft column break as needed
when you add or delete lines.

For more information on columns, see “Columns” in “Editing Screen Layout
Menu.”

TODAY’S DATE VALUE Pull-down: ALT + I, T
Classic: "M@

Inserts the current date at the cursor position.

When you choose Insert=>Today’s Date Value, or use the "M@ classic com-
mand, the date is inserted, for example, June 4, 1992. You can change the date
format with WSCHANGE (DCDG). For example, you can format the date like
this: 4 June 1992.

‘[;’:ITJIZI{ VALUFE Pull-down: ALT + 1; A

Inserts a value into the text.

Current Time “M?
Last Math Result M=

Last Math Expression “Mit
Last Math as Dollar "M$

Current Filename M
Current Drive “M:
Current Directory “M.
Current Path “MN
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When you choose Insert=>Other Value, WordStar displays a menu of the values
you can insert. Choose the one you want. The table below describes all of the
values and gives the classic command that inserts each one.

CLASSIC
VALUE COMMAND DESCRIPTION
Current Time AM! Inserts the current time, for example,

9:30 p.m. You can change the time
format with WSCHANGE (DCDH).

Last Math Result M= Inserts the last math result you obtained
using Utilities=>Calculator (*\QM) or
Utilities=>Block Math (AKM).

Last Math Expression ~ AM# Inserts the last math expression you
entered using Utilities=>Calculator
("QM).

Last Math as Dollar AM$ Inserts the last math result you obtained

using Utilities=>Calculator (*QM) or
Utilities=>Block Math (AKM), in dollar
format. For example, if the result was
23.1, itis inserted as $23.10; if it was
28, it is inserted as $28.00.

Current Filename AM* Inserts the name of the current file.

Current Drive AM: Inserts the currently logged drive letter.

Current Directory AM. Inserts the currently logged directory
name.

Current Path AM\ Inserts the full path and filename of the
current file.
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VARIABLE Pull-down: ALT + 1,V

Inserts a predefined variable into the text.

Date &6
Time &'&

Page &it&
Line & &
Filename &*&
Drive &:&
Directory &.&
Path &\&

A variable is information that is inserted into a document when you print it; you
put the variable name in the text, and WordStar replaces it with the appropriate
value at print time. The commands on this menu insert variable names for
several predefined variables.

When you choose Insert=>Variable, WordStar displays a menu of the variables
you can insert. Choose the one you want. The table below describes all of the
variables. You can type the variable names in the text instead of issuing the
command if you like.

VARIABLE NAME DESCRIPTION

Date &@& Inserts the current date, for example,
September 28, 1992. You can change
the date format with WSCHANGE
(DCEC).

Time &l& Inserts the current time, for example,
9:30 a.m. You can change the time
format with WSCHANGE (DCED).

Page &#& Inserts the current page number. (Note
that the ampersands are not required in
headers and footers.)

Line &_& Inserts the current line number.
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VARIABLE NAME DESCRIPTION

Filename &*& Inserts the name of the current file.

Drive &:& Inserts the currently logged drive letter.

Directory &.& Inserts the currently logged directory
name.

Path &\& Inserts the full path and filename of the
current file.

When you print a file that contains a variable, you must be sure the Interpret
Merge Variables option is selected in the Print dialog box so that WordStar
replaces the variable name with the value. Otherwise, the variable name is
printed.

For more information about variables, see “Merge Printing Commands” in
“Editing Screen Ultilities Menu.”

EXTENDED CHARACTER Pull-down: ALT + I, E

Classic: “"PO

Inserts an extended character.

Some printers can print special characters such as graphics characters, Greek
letters, and accented letters. These characters are called an extended character
set. They vary from printer to printer, and from font to font on many printers.

Before printing an extended character, check your printer documentation to
find the corresponding ASCII code (a number between 0 and 255). Then follow
these steps:

1 Choose Insert=>Extended Character, or use the AP0 (zero) classic command.

WordStar displays the Extended Character dialog box. It includes a chart
that shows the IBM extended character set.

2 Type the code you want. (Use the code from the chart only if your printer

uses the IBM extended character set.) The character is inserted.
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In your text, WordStar displays the characters from the IBM extended character
set. If your printer or font uses a different character set, the characters displayed
in the text will not match those that are printed.

TIP You can use a shortcut to enter an extended character. Just hold down
the Alt key and press the number (ASCII code) on your numeric keypad. When
you release the Alt key, the character appears on the screen.

You can use extended characters for international characters such as accented
letters and for box and line drawing, as described below. For more information
about extended characters, see Appendix B, “ASCII Conversion Charts.”

INTERNATIONAL CHARACTERS

Some languages include characters with accents or other diacritical marks that
distinguish them from other alphabetical characters, such as i and a, other char-
acters such as ; or £, and words with accent marks, such as écran. WordStar
provides several methods for entering these characters:

= |f the character is available on your printer, you can use Insert=>Extended
Character, use the AP0 classic command, or press Alt plus the number for the
character as described above.

= You can use Layout=>Special Effects=Overprint Character, or the APH
classic command, to overprint a character with an accent mark or other
available character. However, if you are using a proportional font, the
accent mark may be off center. In that case, you can try one of the other
methods.

= Many international keyboards produce extended characters when keys are
pressed normally, and some keyboards have a “dead key” that produces
extended characters when used with certain other keys. For information, see
your computer or keyboard documentation.

= When the international character table is turned on in WSCHANGE (DCGM;
the default setting is off), you can enter international characters into your
document by pressing the two keys that compose the character. For
example, if you type a quotation mark (“) and then the letter o, an o with an
umlaut (6) appears on the screen. (The first character you type does not
appear; the international character appears only after you type the second
character.) This method emulates the “dead key” described above.
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The 6 character appears onscreen only if it is supported by your computer’s
onscreen character set (code page). If the character is not supported, the
characters you typed appear next to each other (“0) on the screen. If your
printer supports the 6 character, WordStar prints it as 6; otherwise, WordStar
prints it as 6.

The keys and characters you can use are:

KEY EXAMPLE LETTERS
' a a,e EioufalsoAl O,U,y,Y with
code page 850)
' a a, e i,ouflsoAEIO,U,Yy,Y with
code page 850)
A a a,ei,0,u(also A, E, I, O, Uwith code
page 850)
“ o a,ei,0,ufalsoAE1I O,U,ywith
code page 850)
~ ] n, N (also a, A, o, O with code page 850)
, c c C

If you turn the international character table on, and you need to type two
characters that normally form an international character, type the first charac-
ter twice to override the international character function. For example, to
type the word open in quotation marks, type “ “open”.

You can change the WordStar default settings for the international character
table and the code page in WSCHANGE (DCGM and DCGL). (For informa-
tion about code pages, see Appendix B, “ASCIl Conversion Charts,” and your
DOS manual.)

Bo0X AND LINE DRAWING

The IBM extended character set includes characters for drawing lines and
boxes. If your printer (or the font you are using) uses this character set, you can
draw lines and boxes in WordStar. (If your printer cannot draw these charac-
ters, WordStar may instruct it to use the available characters that are most
similar to them.)
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You can insert a line or box character using Insert=>Extended Character

(or APO), or the Alt key plus the character, or you can use the function keys that
are preset to enter ten of these characters. You can also use the BOX file sup-
plied with WordStar to draw boxes. The function keys and the BOX file are
described below.

When used with the Alt key, ten of the function keys insert line and box draw-
ing characters. The function key settings are shown below. (You can change
these settings using the Macros commands; see “Macros” in “Editing Screen
Utilities Menu.”)

F1o | 2 -
3 F4 4
Fs L F6
7 T F8 L
FO | F10

When you install WordStar, the BOX file is placed in your WS directory. It con-
sists of a box drawn with the function key characters. This box is 23 columns
wide and 7 lines deep. You can use it to enclose a title or text up to 21

columns wide and 5 lines long. You can insert this box into a file using
Insert=>File (or AKR). If you create other boxes or line drawings frequently, you
can keep each one in a separate file, and insert the files when you want them.

Keep these points in mind when working with boxes:

= You must use a nonproportional (fixed width) font for a box. Otherwise, the
right side of the box will be uneven when it’s printed.

= When you edit text inside a box, turn Insert off. With Insert on, characters
and spaces you type push the right side of the box to the right on the line
you're editing. Use column blocks to move text inside a box. Also be
careful when using the Backspace and Del keys. If you accidentally erase a
character that’s part of the box, you can replace it with the appropriate
function key character. You should also turn off auto-alignment before a box
in your text to be sure the box is not accidentally realigned. Then turn it on
again after the box. Use Word Wrap in Layout=>Alignment and Spacing or
.aw off and .aw on.
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= [f you use a laser printer and you want to use a proportional font or edit text
within a box, you can use the .xI0 command to overprint two pages. For
more information, see the laser printer information in “Customizing” in the
Installing and Customizing booklet.

= To quickly add height to an existing box, place the cursor on one row of the
box and delete the line (Edit=>Delete=>Line or AY). Then use Edit=>Undo
(AU) to restore the row. Continue to use Undo until the box is the height
you want. To change the width of a box, use column blocks to add or delete
characters.

CUSTOM PRINTER CODE Pull-down: ALT + I, U

Inserts a custom printer code.

Custom printer codes are special printing instructions that let you take
advantage of a printer’s special features. You can use a custom printer code,
for example, to print a special character, such as a paragraph symbol. You can
also use a custom printer code to insert a file that contains the series of printer
codes you want. For example, you can insert a file in your printer’s program-
ming language to print a border or a logo.

WordStar comes with preset custom printer codes for many printers. If they are
available for your printer, they are listed on the Printer Information screen when
you install your printer. If the printer code you want is not set up for your
printer, you can use the Change Printer Codes command on this menu. See
“Change Printer Codes” in this chapter.

When you choose Insert=>Custom Printer Code, WordStar displays a menu of
the seven available codes. Choose the one you want. Alternately, you can use
the corresponding classic command.

The first six codes, 1-6, enter the preset codes. They correspond to the classic
commands APF, APG, APQ, APW, APE, and APR.

Other (or the AP! classic command) allows you to enter a one-time custom
printer code. When you choose this command, the Custom Printer Code dialog
box appears. The options in this box are described below.
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Printer Code Enter either the ASCII code or the name of the file containing the
printer code. To enter the name of the file, type %F"filename". Be sure to type
an uppercase F and to include the quotation marks. (If you use an ASCII,
ASC256, PRVIEW, or EXTRACT PDF, you can't insert files into a custom printer
code.)

Screen Display Enter a descriptive name. This name will be displayed on the
screen where you insert the code when Command Tags display is off. (When
Command Tags display is on, the ASCII code or filename is shown.)

Width of Character(s) If the code will print a character or characters, type the
width of the character(s) in inches. If the code is nonprinting, use the default
setting, 0".

F ILE

Pull-down: ALT + I, F
Classic: "KR

Inserts a copy of a file into the file you're editing.

This command is useful for inserting standard paragraphs, combining docu-
ments, and inserting files from several other programs.

INSERTING A WORDSTAR FILE

Follow these steps to insert a WordStar file:
1 Choose Insert=>File, or use the AKR classic command.

2 In the Insert File dialog box, specify the file you want to insert. Include the
path if necessary.

Note: With a dBASE file, you can insert only field names by typing the
filename followed by /f; for example, address.dbf/f.

If the file is a spreadsheet, another dialog box appears. See the instructions
below for inserting a spreadsheet.

3 Press F10 or choose OK to insert the file.
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If column mode is on, the file is inserted as a column. Text to the right of the
column moves to the right.

INSERTING A SPREADSHEET OR DATABASE

2

You can insert a WordStar file, a dBASE Il, dBASE 111, dBASE lll+, or dBASE IV
database file, a Lotus 1-2-3 (versions previous to 3.0), Symphony, or Quattro
spreadsheet, or a file in any of these formats created by another program.

For Lotus 1-2-3 version 3.0 and later and for other file formats, either save the
file to a supported format or use Star Exchange to convert the file to WordStar
format before inserting it.

Follow these steps to insert a spreadsheet or database:

1 Choose Insert=>File, or use the AKR classic command.

In the Insert File dialog box, specify the file you want to insert. Include the
path if necessary.

Note: With a dBASE file, you can insert only field names by typing the
filename followed by /f; for example, address.dbf/f.

If the file is a spreadsheet, specify the range to insert. The default displayed
shows the full range of the worksheet, and if you assigned range names to
the worksheet, these names are also displayed. To insert the entire
worksheet, press F10 or choose OK. To insert part of the worksheet, specify
the range of cells or a range name and press F10 or choose OK. You can
use * to mean the end of the worksheet; for example, if Z41 is the last cell,
D1..* is the same a